aboutsummaryrefslogtreecommitdiff
path: root/sysutils/autopsy
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-08 11:38:15 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-08 11:38:15 +0000
commitbabdeb62a0b60b9afed1678dfdddc3cedbe280fa (patch)
tree84f15e9fee236be07e50635aace5d42251206b0b /sysutils/autopsy
parentb70039a2af189f3bbe25eed04089970fb16856ad (diff)
downloadports-babdeb62a0b60b9afed1678dfdddc3cedbe280fa.tar.gz
ports-babdeb62a0b60b9afed1678dfdddc3cedbe280fa.zip
Notes
Diffstat (limited to 'sysutils/autopsy')
-rw-r--r--sysutils/autopsy/Makefile40
-rw-r--r--sysutils/autopsy/distinfo1
-rw-r--r--sysutils/autopsy/files/patch-configure11
-rw-r--r--sysutils/autopsy/pkg-descr13
-rw-r--r--sysutils/autopsy/pkg-plist140
5 files changed, 205 insertions, 0 deletions
diff --git a/sysutils/autopsy/Makefile b/sysutils/autopsy/Makefile
new file mode 100644
index 000000000000..c56c1ab7c67a
--- /dev/null
+++ b/sysutils/autopsy/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: autopsy
+# Date created: 2003-08-12
+# Whom: Pieter Danhieux <opr@bsdaemon.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= autopsy
+PORTVERSION= 1.73
+CATEGORIES= sysutils security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= opr@bsdaemon.be
+COMMENT= The Autopsy Forensic Browser is a GUI for Sleuthkit
+
+#
+# It should have a BUILD_DEPENDS on something in sysutils/sleuthkit,
+# but I'm not sure which what to do it on.
+#
+BUILD_DEPENDS= ${LOCALBASE}/bin/ifind:${PORTSDIR}/sysutils/sleuthkit
+
+USE_PERL5= yes
+IS_INTERACTIVE= yes
+WEB= pict/*
+WEBHELP= help/*
+MAN1= autopsy.1
+
+do-configure:
+ @echo "Note: use ${LOCALBASE}/ as your Sleuth Kit install directory!"
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/autopsy ${PREFIX}/bin
+ cd ${WRKSRC}/man/man1 && ${INSTALL_MAN} ${MAN1} ${PREFIX}/man/man1
+ ${MKDIR} ${PREFIX}/share/autopsy
+ ${MKDIR} ${PREFIX}/share/autopsy/pict
+ ${MKDIR} ${PREFIX}/share/autopsy/help
+ cd ${WRKSRC} && ${INSTALL_DATA} ${WEB} ${PREFIX}/share/autopsy/pict
+ cd ${WRKSRC} && ${INSTALL_DATA} ${WEBHELP} ${PREFIX}/share/autopsy/help
+.include <bsd.port.mk>
diff --git a/sysutils/autopsy/distinfo b/sysutils/autopsy/distinfo
new file mode 100644
index 000000000000..0beab7448562
--- /dev/null
+++ b/sysutils/autopsy/distinfo
@@ -0,0 +1 @@
+MD5 (autopsy-1.73.tar.gz) = ea6d78cc494aa7255ef05ccb2006f0e8
diff --git a/sysutils/autopsy/files/patch-configure b/sysutils/autopsy/files/patch-configure
new file mode 100644
index 000000000000..a3844306c7ba
--- /dev/null
+++ b/sysutils/autopsy/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Mon Sep 8 04:13:10 2003
++++ configure Mon Sep 8 04:15:15 2003
+@@ -39,7 +39,7 @@
+
+
+ # Directories to search in
+-dirs='/usr/local/bin/ /usr/bin/ /usr/ccs/bin/ /bin/ /usr/ucb/bin/ /sbin/ /usr/sbin/ /usr/local/sbin/'
++dirs="${LOCALBASE}/bin/ /usr/bin/ /usr/ccs/bin/ /bin/ /usr/ucb/bin/ /sbin/ /usr/sbin/ ${LOCALBASE}/sbin/"
+
+
+ echo ""
diff --git a/sysutils/autopsy/pkg-descr b/sysutils/autopsy/pkg-descr
new file mode 100644
index 000000000000..74e65ff715bb
--- /dev/null
+++ b/sysutils/autopsy/pkg-descr
@@ -0,0 +1,13 @@
+The Autopsy Forensic Browser is a graphical interface to the command line
+digital forensic analysis tools in The Sleuth Kit. Together, The Sleuth Kit
+and Autopsy provide many of the same features as commercial digital
+forensics tools for the analysis of Windows and UNIX file systems
+(NTFS, FAT, FFS, EXT2FS, and EXT3FS).
+
+The Sleuth Kit and Autopsy are both Open Source and run on UNIX platforms.
+As Autopsy is HTML-based, the investigator can connect to the Autopsy
+server from any platform using an HTML browser. Autopsy provides
+a "File Manager"-like interface and shows details about deleted data
+and file system structures.
+
+WWW: http://www.sleuthkit.org/autopsy/index.php
diff --git a/sysutils/autopsy/pkg-plist b/sysutils/autopsy/pkg-plist
new file mode 100644
index 000000000000..6a6cf9233e86
--- /dev/null
+++ b/sysutils/autopsy/pkg-plist
@@ -0,0 +1,140 @@
+bin/autopsy
+
+share/autopsy/pict/back_pix.jpg
+share/autopsy/pict/but_addnote.jpg
+share/autopsy/pict/but_alloc_list.jpg
+share/autopsy/pict/but_export.jpg
+share/autopsy/pict/but_force.jpg
+share/autopsy/pict/but_indexdb.jpg
+share/autopsy/pict/but_lookup.jpg
+share/autopsy/pict/but_new_name.jpg
+share/autopsy/pict/but_next.jpg
+share/autopsy/pict/but_ok.jpg
+share/autopsy/pict/but_prev.jpg
+share/autopsy/pict/but_replace.jpg
+share/autopsy/pict/but_report.jpg
+share/autopsy/pict/but_view.jpg
+share/autopsy/pict/file_b_alldel.jpg
+share/autopsy/pict/file_b_check.jpg
+share/autopsy/pict/file_b_expand.jpg
+share/autopsy/pict/file_b_hide.jpg
+share/autopsy/pict/file_b_md5list.jpg
+share/autopsy/pict/file_h_acc_cur.jpg
+share/autopsy/pict/file_h_acc_link.jpg
+share/autopsy/pict/file_h_chg_cur.jpg
+share/autopsy/pict/file_h_chg_link.jpg
+share/autopsy/pict/file_h_cre_cur.jpg
+share/autopsy/pict/file_h_cre_link.jpg
+share/autopsy/pict/file_h_del_cur.jpg
+share/autopsy/pict/file_h_del_link.jpg
+share/autopsy/pict/file_h_gid_cur.jpg
+share/autopsy/pict/file_h_gid_link.jpg
+share/autopsy/pict/file_h_meta_cur.jpg
+share/autopsy/pict/file_h_meta_link.jpg
+share/autopsy/pict/file_h_mod_cur.jpg
+share/autopsy/pict/file_h_mod_link.jpg
+share/autopsy/pict/file_h_nam_cur.jpg
+share/autopsy/pict/file_h_nam_link.jpg
+share/autopsy/pict/file_h_siz_cur.jpg
+share/autopsy/pict/file_h_siz_link.jpg
+share/autopsy/pict/file_h_uid_cur.jpg
+share/autopsy/pict/file_h_uid_link.jpg
+share/autopsy/pict/file_h_wr_cur.jpg
+share/autopsy/pict/file_h_wr_link.jpg
+share/autopsy/pict/hashdb_h_alert.jpg
+share/autopsy/pict/hashdb_h_ig.jpg
+share/autopsy/pict/hashdb_h_nsrl.jpg
+share/autopsy/pict/int_b_calc.jpg
+share/autopsy/pict/int_b_valid.jpg
+share/autopsy/pict/int_h_data.jpg
+share/autopsy/pict/int_h_img.jpg
+share/autopsy/pict/int_h_str.jpg
+share/autopsy/pict/int_h_tl.jpg
+share/autopsy/pict/int_h_unalloc.jpg
+share/autopsy/pict/logo.jpg
+share/autopsy/pict/main_t_dat_cur.jpg
+share/autopsy/pict/main_t_dat_link.jpg
+share/autopsy/pict/main_t_fil_cur.jpg
+share/autopsy/pict/main_t_fil_link.jpg
+share/autopsy/pict/main_t_fil_org.jpg
+share/autopsy/pict/main_t_ftype_cur.jpg
+share/autopsy/pict/main_t_ftype_link.jpg
+share/autopsy/pict/main_t_ftype_org.jpg
+share/autopsy/pict/main_t_img_cur.jpg
+share/autopsy/pict/main_t_img_link.jpg
+share/autopsy/pict/main_t_img_org.jpg
+share/autopsy/pict/main_t_met_cur.jpg
+share/autopsy/pict/main_t_met_link.jpg
+share/autopsy/pict/main_t_met_org.jpg
+share/autopsy/pict/main_t_srch_cur.jpg
+share/autopsy/pict/main_t_srch_link.jpg
+share/autopsy/pict/menu_b_cancel.jpg
+share/autopsy/pict/menu_b_ccls.jpg
+share/autopsy/pict/menu_b_cnew.jpg
+share/autopsy/pict/menu_b_copen.jpg
+share/autopsy/pict/menu_b_fs.jpg
+share/autopsy/pict/menu_b_hashdb.jpg
+share/autopsy/pict/menu_b_hcls.jpg
+share/autopsy/pict/menu_b_help.jpg
+share/autopsy/pict/menu_b_hnew.jpg
+share/autopsy/pict/menu_b_inew.jpg
+share/autopsy/pict/menu_b_int.jpg
+share/autopsy/pict/menu_b_menu.jpg
+share/autopsy/pict/menu_b_note.jpg
+share/autopsy/pict/menu_b_ok.jpg
+share/autopsy/pict/menu_b_ref.jpg
+share/autopsy/pict/menu_b_rem.jpg
+share/autopsy/pict/menu_b_seq.jpg
+share/autopsy/pict/menu_b_tl.jpg
+share/autopsy/pict/menu_h_cdet.jpg
+share/autopsy/pict/menu_h_cnew.jpg
+share/autopsy/pict/menu_h_hdet.jpg
+share/autopsy/pict/menu_h_hnew.jpg
+share/autopsy/pict/menu_h_idet.jpg
+share/autopsy/pict/menu_h_inew.jpg
+share/autopsy/pict/menu_t_cg_cur.jpg
+share/autopsy/pict/menu_t_cg_link.jpg
+share/autopsy/pict/sanit_b_san.jpg
+share/autopsy/pict/menu_t_hg_cur.jpg
+share/autopsy/pict/menu_t_hg_link.jpg
+share/autopsy/pict/menu_t_hg_org.jpg
+share/autopsy/pict/menu_t_hm_cur.jpg
+share/autopsy/pict/menu_t_hm_link.jpg
+share/autopsy/pict/menu_t_hm_org.jpg
+share/autopsy/pict/sanit_b_norm.jpg
+share/autopsy/pict/sanitized.jpg
+share/autopsy/pict/srch_b_lorig.jpg
+share/autopsy/pict/srch_b_lun.jpg
+share/autopsy/pict/srch_b_srch.jpg
+share/autopsy/pict/srch_b_str.jpg
+share/autopsy/pict/srch_b_un.jpg
+share/autopsy/pict/tab_close.jpg
+share/autopsy/pict/tab_help.jpg
+share/autopsy/pict/tl_t_data_cur.jpg
+share/autopsy/pict/tl_t_data_link.jpg
+share/autopsy/pict/tl_t_notes_link.jpg
+share/autopsy/pict/tl_t_notes_org.jpg
+share/autopsy/pict/tl_t_tl_cur.jpg
+share/autopsy/pict/tl_t_tl_link.jpg
+share/autopsy/pict/tl_t_view_cur.jpg
+share/autopsy/pict/tl_t_view_link.jpg
+share/autopsy/help/blank.html
+share/autopsy/help/caseman.html
+share/autopsy/help/data_mode.html
+share/autopsy/help/file_category.html
+share/autopsy/help/file_mode.html
+share/autopsy/help/fs_mode.html
+share/autopsy/help/general.html
+share/autopsy/help/grep.html
+share/autopsy/help/hash_db.html
+share/autopsy/help/index.html
+share/autopsy/help/int_mode.html
+share/autopsy/help/menu.html
+share/autopsy/help/meta_mode.html
+share/autopsy/help/sequencer.html
+share/autopsy/help/srch_mode.html
+share/autopsy/help/temp.html
+share/autopsy/help/tl.html
+@dirrm share/autopsy/pict
+@dirrm share/autopsy/help
+@dirrm share/autopsy