aboutsummaryrefslogtreecommitdiff
path: root/sysutils/b43-fwcutter
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-21 01:51:14 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-21 01:51:14 +0000
commitfd1b71c3d03429959a60b0775da9ef51b7966526 (patch)
treeba7b7c4ffa8970d2c4d49ce5a9ef803a257069f4 /sysutils/b43-fwcutter
parent6535dc25e89213f435494ab8d1290a37bae8a734 (diff)
downloadports-fd1b71c3d03429959a60b0775da9ef51b7966526.tar.gz
ports-fd1b71c3d03429959a60b0775da9ef51b7966526.zip
- Correct my previous commit
- Add stage support
Notes
Notes: svn path=/head/; revision=345284
Diffstat (limited to 'sysutils/b43-fwcutter')
-rw-r--r--sysutils/b43-fwcutter/Makefile5
-rw-r--r--sysutils/b43-fwcutter/files/patch-Makefile26
2 files changed, 29 insertions, 2 deletions
diff --git a/sysutils/b43-fwcutter/Makefile b/sysutils/b43-fwcutter/Makefile
index d6e629ac0c73..8911c1aba3bf 100644
--- a/sysutils/b43-fwcutter/Makefile
+++ b/sysutils/b43-fwcutter/Makefile
@@ -10,8 +10,9 @@ MAINTAINER= swhetzel@gmail.com
COMMENT= Extracts firmware for Broadcom Wireless adapters
USE_BZIP2= yes
-USES= gmake desthack
+USES= gmake
-PLIST_FILES= bin/b43-fwcutter
+PLIST_FILES= bin/b43-fwcutter \
+ man/man1/b43-fwcutter.1.gz
.include <bsd.port.mk>
diff --git a/sysutils/b43-fwcutter/files/patch-Makefile b/sysutils/b43-fwcutter/files/patch-Makefile
new file mode 100644
index 000000000000..468ef4db0c0c
--- /dev/null
+++ b/sysutils/b43-fwcutter/files/patch-Makefile
@@ -0,0 +1,26 @@
+--- Makefile.orig 2011-08-21 20:17:01.000000000 +0800
++++ Makefile 2014-02-21 09:40:52.782172201 +0800
+@@ -15,7 +15,7 @@
+ QUIET_SPARSE = @true
+ endif
+
+-PREFIX ?= /usr/local
++PREFIX ?= $(DESTDIR)$(PREFIX)
+ CFLAGS ?= -Os -fomit-frame-pointer
+ CFLAGS += -std=c99 -Wall -pedantic -D_BSD_SOURCE
+ LDFLAGS ?=
+@@ -51,10 +51,10 @@
+ $(QUIET_CC) $(CFLAGS) -o $(BIN) $(call OBJS,$(SRCS)) $(LDFLAGS)
+
+ install: all
+- install -d -o 0 -g 0 -m 755 $(PREFIX)/bin/
+- install -o 0 -g 0 -m 755 $(BIN) $(PREFIX)/bin/
+- install -d -o 0 -g 0 -m 755 $(PREFIX)/man/man1/
+- install -o 0 -g 0 -m 644 $(BIN).1 $(PREFIX)/man/man1/
++ install -d -o 0 -g 0 -m 755 $(DESTDIR)$(PREFIX)/bin/
++ install -o 0 -g 0 -m 755 $(BIN) $(DESTDIR)$(PREFIX)/bin/
++ install -d -o 0 -g 0 -m 755 $(DESTDIR)$(PREFIX)/man/man1/
++ install -o 0 -g 0 -m 644 $(BIN).1 $(DESTDIR)$(PREFIX)/man/man1/
+
+ clean:
+ -rm -Rf obj dep *.orig *.rej *~