aboutsummaryrefslogtreecommitdiff
path: root/sysutils/backuppc-devel
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2016-06-21 21:01:27 +0000
committerRene Ladan <rene@FreeBSD.org>2016-06-21 21:01:27 +0000
commit8cc6e64f2f26f042e21e8ff3cf5dda09eb7a0ee7 (patch)
tree891df4a65c1c552dd2beb7d0db96985a4247770a /sysutils/backuppc-devel
parentd7f14db9fc786bef5793acb409a88bb84228fd8d (diff)
downloadports-8cc6e64f2f26f042e21e8ff3cf5dda09eb7a0ee7.tar.gz
ports-8cc6e64f2f26f042e21e8ff3cf5dda09eb7a0ee7.zip
sysutils/backuppc-devel: add a workaround for users of Samba 4.
Using Samba 3.6 is still reccommended PR: 209875 Submitted by: myself, patch by maintainer
Notes
Notes: svn path=/head/; revision=417289
Diffstat (limited to 'sysutils/backuppc-devel')
-rw-r--r--sysutils/backuppc-devel/Makefile2
-rw-r--r--sysutils/backuppc-devel/files/patch-lib_BackupPC_Xfer_Smb.pm33
-rw-r--r--sysutils/backuppc-devel/files/patch-lib__BackupPC__CGI__View.pm17
-rw-r--r--sysutils/backuppc-devel/files/pkg-message.in9
4 files changed, 57 insertions, 4 deletions
diff --git a/sysutils/backuppc-devel/Makefile b/sysutils/backuppc-devel/Makefile
index fb4fd4c694d1..85906a2a163b 100644
--- a/sysutils/backuppc-devel/Makefile
+++ b/sysutils/backuppc-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= backuppc
DISTVERSION= 4.0.0alpha3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-beta/${DISTVERSION}
PKGNAMESUFFIX= -devel
diff --git a/sysutils/backuppc-devel/files/patch-lib_BackupPC_Xfer_Smb.pm b/sysutils/backuppc-devel/files/patch-lib_BackupPC_Xfer_Smb.pm
new file mode 100644
index 000000000000..9a013abb8550
--- /dev/null
+++ b/sysutils/backuppc-devel/files/patch-lib_BackupPC_Xfer_Smb.pm
@@ -0,0 +1,33 @@
+--- lib/BackupPC/Xfer/Smb.pm.orig 2013-12-01 20:58:20 UTC
++++ lib/BackupPC/Xfer/Smb.pm
+@@ -216,7 +216,7 @@ sub readOutput
+ # This section is highly dependent on the version of smbclient.
+ # If you upgrade Samba, make sure that these regexp are still valid.
+ #
+- if ( /^\s*(-?\d+) \(\s*\d+[.,]\d kb\/s\) (.*)$/ ) {
++ if ( /^\s*(-?\d+) \(\s*\d+[.,]\d kb\/s\) (.*)$/ || /^tar:(\d+)\s+\+\+\+ (.*)$/ ) {
+ my $sambaFileSize = $1;
+ my $pcFileName = $2;
+ (my $fileName = $pcFileName) =~ s/\\/\//g;
+@@ -229,7 +229,9 @@ sub readOutput
+ $t->{byteCnt} += $2;
+ $t->{fileCnt}++;
+ $t->{XferLOG}->write(\"$_\n") if ( $t->{logLevel} >= 1 );
+- } elsif ( /^\s*tar: dumped \d+ files/ ) {
++ } elsif ( /^\s*tar: dumped \d+ files/
++ || /Total bytes received: \d+/i
++ || /tar_process done, err = 0/ ) {
+ $t->{xferOK} = 1;
+ $t->{XferLOG}->write(\"$_\n") if ( $t->{logLevel} >= 0 );
+ } elsif ( /^\s*tar: restored \d+ files/ ) {
+@@ -269,6 +271,10 @@ sub readOutput
+ } elsif ( /^\s*directory \\/i ) {
+ $t->{XferLOG}->write(\"$_\n") if ( $t->{logLevel} >= 2 );
+ } elsif ( /smb: \\>/
++ || /^tar:\d+\s/
++ || /^ NTLMSSP_/
++ || /^GENSEC backend /
++ || /^doing parameter /
+ || /^\s*added interface/i
+ || /^\s*tarmode is now/i
+ || /^\s*Total bytes written/i
diff --git a/sysutils/backuppc-devel/files/patch-lib__BackupPC__CGI__View.pm b/sysutils/backuppc-devel/files/patch-lib__BackupPC__CGI__View.pm
index 0799a8575ac9..3318ba50c636 100644
--- a/sysutils/backuppc-devel/files/patch-lib__BackupPC__CGI__View.pm
+++ b/sysutils/backuppc-devel/files/patch-lib__BackupPC__CGI__View.pm
@@ -1,6 +1,6 @@
---- ./lib/BackupPC/CGI/View.pm.orig 2014-09-03 14:15:03.000000000 +0400
-+++ ./lib/BackupPC/CGI/View.pm 2014-09-03 14:15:20.000000000 +0400
-@@ -102,7 +102,7 @@
+--- lib/BackupPC/CGI/View.pm.orig 2013-12-01 20:58:20 UTC
++++ lib/BackupPC/CGI/View.pm
+@@ -102,7 +102,7 @@ sub action
$file = $bpc->ConfDir() . "/hosts";
$linkHosts = 1;
} elsif ( $type eq "docs" ) {
@@ -9,3 +9,14 @@
} elsif ( $host ne "" ) {
if ( !defined($In{num}) ) {
# get the latest LOG file
+@@ -148,6 +148,10 @@ sub action
+ }
+ $s =~ s/[\n\r]+//g;
+ if ( $s =~ /smb: \\>/
++ || $s =~ /^tar:\d+\s/
++ || $s =~ /^ NTLMSSP_/
++ || $s =~ /^GENSEC backend /
++ || $s =~ /^doing parameter /
+ || $s =~ /^\s*(\d+) \(\s*\d+\.\d kb\/s\) (.*)$/
+ || $s =~ /^tar: dumped \d+ files/
+ || $s =~ /^\s*added interface/i
diff --git a/sysutils/backuppc-devel/files/pkg-message.in b/sysutils/backuppc-devel/files/pkg-message.in
index 5a3d8f4dbf64..45e12bcf3cb6 100644
--- a/sysutils/backuppc-devel/files/pkg-message.in
+++ b/sysutils/backuppc-devel/files/pkg-message.in
@@ -13,4 +13,13 @@
This is where all the backup data is stored.
This file system needs to be big enough
to accommodate all the PCs you expect to backup.
+
+ - Users of Samba 4 smbclient should change debug level for smbclient
+ restore command to 5 ('-d 5') in the main configuration, for instance
+
+ $Conf{SmbClientRestoreCmd} = '$smbClientPath \\\\$host\\$shareName $I_option -U $userName -E -d 5 -c tarmode\\ full -Tx -';
+
+ and set in the each host's configuration
+
+ $Conf{BackupZeroFilesIsFatal} = '0';
==========================================================================