aboutsummaryrefslogtreecommitdiff
path: root/sysutils/bacula-libs3
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2023-09-10 12:45:08 +0000
committerDan Langille <dvl@FreeBSD.org>2023-09-10 14:13:59 +0000
commitdd8d93a918b9f922883323abb08fb352a1e1310a (patch)
tree02da9906e8ee383300d2134d1d69c1927722e5dc /sysutils/bacula-libs3
parentd7ba45f6bcbc046d9ca6b670cab78b9a458d90bf (diff)
downloadports-dd8d93a918b9f922883323abb08fb352a1e1310a.tar.gz
ports-dd8d93a918b9f922883323abb08fb352a1e1310a.zip
Diffstat (limited to 'sysutils/bacula-libs3')
-rw-r--r--sysutils/bacula-libs3/Makefile33
-rw-r--r--sysutils/bacula-libs3/distinfo3
-rw-r--r--sysutils/bacula-libs3/files/patch-GNUmakefile101
-rw-r--r--sysutils/bacula-libs3/pkg-descr11
-rw-r--r--sysutils/bacula-libs3/pkg-plist6
5 files changed, 154 insertions, 0 deletions
diff --git a/sysutils/bacula-libs3/Makefile b/sysutils/bacula-libs3/Makefile
new file mode 100644
index 000000000000..cc63e90e2762
--- /dev/null
+++ b/sysutils/bacula-libs3/Makefile
@@ -0,0 +1,33 @@
+PORTNAME= bacula11-libs3
+PORTVERSION= 20200523
+CATEGORIES= sysutils
+MASTER_SITES= https://www.bacula.org/downloads/
+DISTNAME= libs3-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
+
+MAINTAINER= ml@netfence.it
+COMMENT= Bacula libs3
+WWW= https://www.bacula.org/
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS+= libcurl.so:ftp/curl
+
+USES= compiler:gcc-c++11-lib gmake gnome ssl
+USE_GNOME+= libxml2
+
+MAKEFILE= GNUmakefile
+MAKE_ARGS= MYDESTDIR=${STAGEDIR}/${PREFIX} \
+ MYINSTALL=install
+.include <bsd.port.options.mk>
+
+.if (${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && ${SSL_DEFAULT} == base) || \
+ ${SSL_DEFAULT:Mopenssl3*}
+CFLAGS+= -DOPENSSL_API_COMPAT=0x10100000L
+.endif
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/bin/s3
+ ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/lib/libs3.so.4.1.bac
+
+.include <bsd.port.mk>
diff --git a/sysutils/bacula-libs3/distinfo b/sysutils/bacula-libs3/distinfo
new file mode 100644
index 000000000000..594911721d3b
--- /dev/null
+++ b/sysutils/bacula-libs3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1631776465
+SHA256 (libs3-20200523.tar.gz) = a604df5c4c95994a41f14f156b624a6ab87ec71b8320e9bbc7af1a664817812f
+SIZE (libs3-20200523.tar.gz) = 117367
diff --git a/sysutils/bacula-libs3/files/patch-GNUmakefile b/sysutils/bacula-libs3/files/patch-GNUmakefile
new file mode 100644
index 000000000000..c96a7ec2ccaf
--- /dev/null
+++ b/sysutils/bacula-libs3/files/patch-GNUmakefile
@@ -0,0 +1,101 @@
+--- GNUmakefile.orig 2020-05-23 16:23:54 UTC
++++ GNUmakefile
+@@ -83,15 +83,15 @@ endif
+
+
+ # --------------------------------------------------------------------------
+-# DESTDIR directory
+-ifndef DESTDIR
+- DESTDIR := /usr
++# MYDESTDIR directory
++ifndef MYDESTDIR
++ MYDESTDIR := /usr
+ endif
+
+ # --------------------------------------------------------------------------
+ # LIBDIR directory
+ ifndef LIBDIR
+- LIBDIR := ${DESTDIR}/lib
++ LIBDIR := ${MYDESTDIR}/lib
+ endif
+
+ # --------------------------------------------------------------------------
+@@ -149,7 +149,7 @@ CFLAGS += -Wall -Werror -Wshadow -Wextra -Wno-format-t
+ LDFLAGS = $(CURL_LIBS) $(LIBXML2_LIBS) $(OPENSSL_LIBS) -lpthread
+
+ STRIP ?= strip
+-INSTALL := install --strip-program=$(STRIP)
++MYINSTALL := install --strip-program=$(STRIP)
+
+
+ # --------------------------------------------------------------------------
+@@ -171,12 +171,12 @@ exported: libs3 s3 headers
+
+ .PHONY: install
+ install: exported
+- $(QUIET_ECHO) $(DESTDIR)/bin/s3: Installing executable
+- $(VERBOSE_SHOW) $(INSTALL) -Dps -m u+rwx,go+rx $(BUILD)/bin/s3 \
+- $(DESTDIR)/bin/s3
++ $(QUIET_ECHO) $(MYDESTDIR)/bin/s3: Installing executable
++ $(VERBOSE_SHOW) $(MYINSTALL) -Dps -m u+rwx,go+rx $(BUILD)/bin/s3 \
++ $(MYDESTDIR)/bin/s3
+ $(QUIET_ECHO) \
+ $(LIBDIR)/libs3.so.$(LIBS3_VER): Installing shared library
+- $(VERBOSE_SHOW) $(INSTALL) -Dps -m u+rw,go+r \
++ $(VERBOSE_SHOW) $(MYINSTALL) -Dps -m u+rw,go+r \
+ $(BUILD)/lib/libs3.so.$(LIBS3_VER_MAJOR) \
+ $(LIBDIR)/libs3.so.$(LIBS3_VER)
+ $(QUIET_ECHO) \
+@@ -186,11 +186,11 @@ install: exported
+ $(QUIET_ECHO) $(LIBDIR)/libs3.so: Linking shared library
+ $(VERBOSE_SHOW) ln -sf libs3.so.$(LIBS3_VER_MAJOR) $(LIBDIR)/libs3.so
+ $(QUIET_ECHO) $(LIBDIR)/libs3.a: Installing static library
+- $(VERBOSE_SHOW) $(INSTALL) -Dp -m u+rw,go+r $(BUILD)/lib/libs3.a \
++ $(VERBOSE_SHOW) $(MYINSTALL) -Dp -m u+rw,go+r $(BUILD)/lib/libs3.a \
+ $(LIBDIR)/libs3.a
+- $(QUIET_ECHO) $(DESTDIR)/include/libs3.h: Installing header
+- $(VERBOSE_SHOW) $(INSTALL) -Dp -m u+rw,go+r $(BUILD)/include/libs3.h \
+- $(DESTDIR)/include/libs3.h
++ $(QUIET_ECHO) $(MYDESTDIR)/include/libs3.h: Installing header
++ $(VERBOSE_SHOW) $(MYINSTALL) -Dp -m u+rw,go+r $(BUILD)/include/libs3.h \
++ $(MYDESTDIR)/include/libs3.h
+
+
+ # --------------------------------------------------------------------------
+@@ -200,12 +200,12 @@ install: exported
+ uninstall:
+ $(QUIET_ECHO) Installed files: Uninstalling
+ $(VERBOSE_SHOW) \
+- rm -f $(DESTDIR)/bin/s3 \
+- $(DESTDIR)/include/libs3.h \
+- $(DESTDIR)/lib/libs3.a \
+- $(DESTDIR)/lib/libs3.so \
+- $(DESTDIR)/lib/libs3.so.$(LIBS3_VER_MAJOR) \
+- $(DESTDIR)/lib/libs3.so.$(LIBS3_VER)
++ rm -f $(MYDESTDIR)/bin/s3 \
++ $(MYDESTDIR)/include/libs3.h \
++ $(MYDESTDIR)/lib/libs3.a \
++ $(MYDESTDIR)/lib/libs3.so \
++ $(MYDESTDIR)/lib/libs3.so.$(LIBS3_VER_MAJOR) \
++ $(MYDESTDIR)/lib/libs3.so.$(LIBS3_VER)
+
+
+ # --------------------------------------------------------------------------
+@@ -338,7 +338,7 @@ $(DEBPKG): exported $(BUILD)/deb/DEBIAN/control $(BUIL
+ $(BUILD)/deb/usr/share/doc/libs3/changelog.gz \
+ $(BUILD)/deb/usr/share/doc/libs3/changelog.Debian.gz \
+ $(BUILD)/deb/usr/share/doc/libs3/copyright
+- DESTDIR=$(BUILD)/deb/usr $(MAKE) install
++ MYDESTDIR=$(BUILD)/deb/usr $(MAKE) install
+ rm -rf $(BUILD)/deb/usr/include
+ rm -f $(BUILD)/deb/usr/lib/libs3.a
+ @mkdir -p $(dir $@)
+@@ -351,7 +351,7 @@ $(DEBDEVPKG): exported $(BUILD)/deb-dev/DEBIAN/control
+ $(BUILD)/deb-dev/usr/share/doc/libs3-dev/changelog.gz \
+ $(BUILD)/deb-dev/usr/share/doc/libs3-dev/changelog.Debian.gz \
+ $(BUILD)/deb-dev/usr/share/doc/libs3-dev/copyright
+- DESTDIR=$(BUILD)/deb-dev/usr $(MAKE) install
++ MYDESTDIR=$(BUILD)/deb-dev/usr $(MAKE) install
+ rm -rf $(BUILD)/deb-dev/usr/bin
+ rm -f $(BUILD)/deb-dev/usr/lib/libs3.so*
+ @mkdir -p $(dir $@)
diff --git a/sysutils/bacula-libs3/pkg-descr b/sysutils/bacula-libs3/pkg-descr
new file mode 100644
index 000000000000..f0a801978e53
--- /dev/null
+++ b/sysutils/bacula-libs3/pkg-descr
@@ -0,0 +1,11 @@
+Bacula is a set of computer programs that permit you (or the system
+administrator) to manage backup, recovery, and verification of
+computer data across a network of computers of different kinds.
+In technical terms, it is a network Client/Server based backup program.
+Bacula is relatively easy to use and efficient, while offering many
+advanced storage management features that make it easy to find and
+recover lost or damaged files. Due to its modular design, Bacula is
+scalable from small single computer systems to systems consisting of
+hundreds of computers located over a large network.
+
+This is its bundled S3 library.
diff --git a/sysutils/bacula-libs3/pkg-plist b/sysutils/bacula-libs3/pkg-plist
new file mode 100644
index 000000000000..9a0f6dc8ae97
--- /dev/null
+++ b/sysutils/bacula-libs3/pkg-plist
@@ -0,0 +1,6 @@
+include/libs3.h
+lib/libs3.a
+lib/libs3.so.4
+lib/libs3.so
+lib/libs3.so.4.1.bac
+bin/s3