aboutsummaryrefslogtreecommitdiff
path: root/sysutils/bacula-server/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2006-12-14 16:36:10 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2006-12-14 16:36:10 +0000
commit1fc5fd5d94ab8916aa494653e77b279b50f9993c (patch)
treecea6f5b9c53533efe355d590055578b00a437083 /sysutils/bacula-server/Makefile
parentcbd186b57adc36a3db65175337ff2b3b9825f602 (diff)
downloadports-1fc5fd5d94ab8916aa494653e77b279b50f9993c.tar.gz
ports-1fc5fd5d94ab8916aa494653e77b279b50f9993c.zip
Notes
Diffstat (limited to 'sysutils/bacula-server/Makefile')
-rw-r--r--sysutils/bacula-server/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/sysutils/bacula-server/Makefile b/sysutils/bacula-server/Makefile
index 440f63c95ea8..fa922386e940 100644
--- a/sysutils/bacula-server/Makefile
+++ b/sysutils/bacula-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bacula
DISTVERSION= 1.38.11
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= bacula
@@ -76,6 +76,7 @@ OPTIONS+= POSTGRESQL "Use PostgreSQL database instead of SqLite" off
OPTIONS+= MTX "Install mtx for control of autochanger devices" off
.endif
+OPTIONS+= NLS "Native Language Support via gettext utilities" on
OPTIONS+= OPENSSL "Enable OpenSSL for encrypted communication" off
# Prepare if gnome-console is selected this must be happen before
@@ -100,6 +101,13 @@ DISTFILES+= ${PORTNAME}-docs-${PORTVERSION}-1.tar.gz
PORTDOCS= ReleaseNotes bacula.pdf developers.pdf kernstodo manual bacula-web
.endif
+.if defined(WITH_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ARGS+= --enable-nls
+.else
+CONFIGURE_ARGS+= --disable-nls
+.endif
+
# Client only or full server version
.if defined(WITH_CLIENT_ONLY)
CONFFILES= fd
@@ -120,6 +128,7 @@ PLIST_SUB+= GNOMECONS="@comment "
.if defined(WITH_WXCONSOLE)
USE_WX= 2.4
CONFIGURE_ARGS+= --enable-wx-console
+CONFIGURE_ENV+= WXCONFIG="${WX_CONFIG}"
PLIST_SUB+= WXCONS=""
.else
# We didn't need GTK (it's not possible to put WANT_GNOME in an .if statement!)