aboutsummaryrefslogtreecommitdiff
path: root/sysutils/bacula-server/Makefile
diff options
context:
space:
mode:
authorLars Koeller <lkoeller@FreeBSD.org>2004-08-03 20:22:02 +0000
committerLars Koeller <lkoeller@FreeBSD.org>2004-08-03 20:22:02 +0000
commit54fb240d5c078f056b0418c84b17beece8882b19 (patch)
treef92248e7da7f2980ff3f067c9996a92a38cc3e8d /sysutils/bacula-server/Makefile
parent253f20b45270962c5ce405bc6e453de75d485e23 (diff)
downloadports-54fb240d5c078f056b0418c84b17beece8882b19.tar.gz
ports-54fb240d5c078f056b0418c84b17beece8882b19.zip
Notes
Diffstat (limited to 'sysutils/bacula-server/Makefile')
-rw-r--r--sysutils/bacula-server/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/sysutils/bacula-server/Makefile b/sysutils/bacula-server/Makefile
index bb4d2591374b..8cae04eeb2f4 100644
--- a/sysutils/bacula-server/Makefile
+++ b/sysutils/bacula-server/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= bacula
-PORTVERSION= 1.34.5
-PORTREVISION= 4
+PORTVERSION= 1.34.6
+#PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= bacula
@@ -43,6 +43,7 @@ OPTIONS+= WXCONSOLE "Build with wxGTK based GUI console" off
OPTIONS+= GNOMECONSOLE "Build with GNOME based GUI console" off
OPTIONS+= MYSQL "Use MySQL database instead of SqLite" off
OPTIONS+= POSTGRESQL7 "Use PostgreSQL 7.X database instead of SqLite" off
+OPTIONS+= MTX "Install mtx for control of autochanger devices" off
# Prepare if gnome-console is selected this must be happen before
# include of bsd.port.pre.mk!
@@ -98,6 +99,11 @@ PLIST_SUB+= DBTYPE=${DBTYPE}
PLIST_SUB+= SERVER=""
.endif
+# Install mtx
+.if defined(WITH_MTX)
+RUN_DEPENDS+= ${LOCALBASE}/sbin/mtx:${PORTSDIR}/misc/mtx
+.endif
+
PORTDOCS= bacula.pdf ReleaseNotes html-manual/*
pre-everything::
@@ -115,11 +121,12 @@ pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "You may use the following build options (or make config):"
@${ECHO_MSG} ""
- @${ECHO_MSG} " WITH_CLIENT_ONLY=yes if you only want the file daemon."
- @${ECHO_MSG} " WITH_WXCONSOLE=yes if you only want a wxGTK based GUI console."
- @${ECHO_MSG} " WITH_GNOMECONSOLE=yes if you only want a GNOME based GUI console."
+ @${ECHO_MSG} " WITH_CLIENT_ONLY=yes if you only want the file daemon."
+ @${ECHO_MSG} " WITH_WXCONSOLE=yes if you only want a wxGTK based GUI console."
+ @${ECHO_MSG} " WITH_GNOMECONSOLE=yes if you only want a GNOME based GUI console."
+ @${ECHO_MSG} " WITH_MTX=yes if you want to use mtx instead of chio for autochanger control."
.if !defined(WITH_MYSQL) && !defined(WITH_POSTGRESQL7)
- @${ECHO_MSG} " WITH_MYSQL=yes if you want MySQL instead of SqLite as the database."
+ @${ECHO_MSG} " WITH_MYSQL=yes if you want MySQL instead of SqLite as the database."
@${ECHO_MSG} " WITH_POSTGRESQL7=yes if you want PostgreSQL 7.X instead of SqLite as the database."
@${ECHO_MSG} ""
@${ECHO_MSG} "The default DB is SQLite!"