aboutsummaryrefslogtreecommitdiff
path: root/sysutils/boot-extract
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-07-21 19:28:10 +0000
committerKurt Jaeger <pi@FreeBSD.org>2019-07-21 19:28:10 +0000
commitfb25a0de07a7009b18c818c9dab98c83e4bec6ee (patch)
treecb06f51061ef61a738860e20e200acca1cfa1c17 /sysutils/boot-extract
parent062692d7eea929581420945ef5002ee1ab4a7394 (diff)
downloadports-fb25a0de07a7009b18c818c9dab98c83e4bec6ee.tar.gz
ports-fb25a0de07a7009b18c818c9dab98c83e4bec6ee.zip
New port: sysutils/boot-extract
Utility to extract kernel and ramdisk from an Android boot or recovery image file WWW: https://github.com/csimmonds/boot-extract PR: 239206 Submitted by: Martin Filla <freebsd@sysctl.cz>
Notes
Notes: svn path=/head/; revision=507065
Diffstat (limited to 'sysutils/boot-extract')
-rw-r--r--sysutils/boot-extract/Makefile24
-rw-r--r--sysutils/boot-extract/distinfo3
-rw-r--r--sysutils/boot-extract/files/patch-Makefile16
-rw-r--r--sysutils/boot-extract/pkg-descr4
4 files changed, 47 insertions, 0 deletions
diff --git a/sysutils/boot-extract/Makefile b/sysutils/boot-extract/Makefile
new file mode 100644
index 000000000000..8fee551aa9e4
--- /dev/null
+++ b/sysutils/boot-extract/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= boot-extract
+PORTVERSION= g20190614
+CATEGORIES= sysutils
+
+MAINTAINER= freebsd@sysctl.cz
+COMMENT= Android Boot image extraction tool
+
+LICENSE= GPLv2
+
+USES= gmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= csimmonds
+GH_PROJECT= boot-extract
+GH_TAGNAME= 486995f
+
+PLIST_FILES= bin/boot-extract
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/sysutils/boot-extract/distinfo b/sysutils/boot-extract/distinfo
new file mode 100644
index 000000000000..b3a7bfe49bae
--- /dev/null
+++ b/sysutils/boot-extract/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1563120360
+SHA256 (csimmonds-boot-extract-g20190614-486995f_GH0.tar.gz) = 3dcdc36c308e6a8a76db8cb902c2162ee02d9bd06704c010c39ee15ea9b475ba
+SIZE (csimmonds-boot-extract-g20190614-486995f_GH0.tar.gz) = 3785
diff --git a/sysutils/boot-extract/files/patch-Makefile b/sysutils/boot-extract/files/patch-Makefile
new file mode 100644
index 000000000000..3088ed5edab4
--- /dev/null
+++ b/sysutils/boot-extract/files/patch-Makefile
@@ -0,0 +1,16 @@
+--- Makefile.orig 2017-11-25 09:25:52 UTC
++++ Makefile
+@@ -1,4 +1,5 @@
+
++
+ CFLAGS=-Wall
+ PROGS=boot-extract
+
+@@ -10,3 +11,7 @@ clean:
+ rm -f *.o
+ rm -f $(PROGS)
+
++install: boot-extract
++
++.PHONY: all clean install
++
diff --git a/sysutils/boot-extract/pkg-descr b/sysutils/boot-extract/pkg-descr
new file mode 100644
index 000000000000..a8e52b5e80d6
--- /dev/null
+++ b/sysutils/boot-extract/pkg-descr
@@ -0,0 +1,4 @@
+Utility to extract kernel and ramdisk from
+an Android boot or recovery image file
+
+WWW: https://github.com/csimmonds/boot-extract