aboutsummaryrefslogtreecommitdiff
path: root/sysutils/brasero
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2012-02-12 16:56:13 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2012-02-12 16:56:13 +0000
commit060738f06430eb3523bd25ff82aa6ccd0d2fdead (patch)
treef8040b8d1ae2f8049c1c59af8036d3b299409eca /sysutils/brasero
parentd56ff146fb03cb8f88812e2ff476d37494176605 (diff)
downloadports-060738f06430eb3523bd25ff82aa6ccd0d2fdead.tar.gz
ports-060738f06430eb3523bd25ff82aa6ccd0d2fdead.zip
Fix detection of CDs in certain drives using ATAPI_CAM.
PR: 164927 Submitted by: Shin-ichi Okano <s-okano@n08.itscom.net> Based on: sysutils/cdrecord
Notes
Notes: svn path=/head/; revision=291055
Diffstat (limited to 'sysutils/brasero')
-rw-r--r--sysutils/brasero/Makefile2
-rw-r--r--sysutils/brasero/files/patch-libbrasero-media_scsi-cam.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/sysutils/brasero/Makefile b/sysutils/brasero/Makefile
index ff2c54293e9c..02f16b2b3f9e 100644
--- a/sysutils/brasero/Makefile
+++ b/sysutils/brasero/Makefile
@@ -7,7 +7,7 @@
PORTNAME= brasero
PORTVERSION= 2.32.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils audio multimedia gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/sysutils/brasero/files/patch-libbrasero-media_scsi-cam.c b/sysutils/brasero/files/patch-libbrasero-media_scsi-cam.c
new file mode 100644
index 000000000000..74f10adc0ea4
--- /dev/null
+++ b/sysutils/brasero/files/patch-libbrasero-media_scsi-cam.c
@@ -0,0 +1,13 @@
+--- libbrasero-media/scsi-cam.c.orig 2012-02-11 21:16:20.000000000 -0500
++++ libbrasero-media/scsi-cam.c 2012-02-11 21:17:13.000000000 -0500
+@@ -103,6 +103,10 @@ brasero_scsi_command_issue_sync (gpointe
+ else if (cmd->info->direction & BRASERO_SCSI_WRITE)
+ direction = CAM_DIR_OUT;
+
++ if (size == 0)
++ direction = CAM_DIR_NONE;
++ direction |= CAM_DEV_QFRZDIS;
++
+ g_assert (direction > -1);
+
+ cam_fill_csio(&cam_ccb.csio,