aboutsummaryrefslogtreecommitdiff
path: root/sysutils/brasero
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-01-16 04:46:57 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-01-16 04:46:57 +0000
commit136e55f9dd14be4e24e0dcd8f9c03b1a9f5c13dc (patch)
tree4ecc86947d919b28b00a455e48509c3250eab664 /sysutils/brasero
parentc4adff48e42fcc857624639d4d5cb23c689643d4 (diff)
downloadports-136e55f9dd14be4e24e0dcd8f9c03b1a9f5c13dc.tar.gz
ports-136e55f9dd14be4e24e0dcd8f9c03b1a9f5c13dc.zip
Fix detection of media on FreeBSD. There are still some issues with brasero,
but hopefully they will be worked out soon. Reported by: Alexander Logvinov <freebsd@akavia.ru>
Notes
Notes: svn path=/head/; revision=226233
Diffstat (limited to 'sysutils/brasero')
-rw-r--r--sysutils/brasero/Makefile4
-rw-r--r--sysutils/brasero/files/patch-src_scsi-cam.c22
2 files changed, 24 insertions, 2 deletions
diff --git a/sysutils/brasero/Makefile b/sysutils/brasero/Makefile
index f610f498a261..13a5d717b95d 100644
--- a/sysutils/brasero/Makefile
+++ b/sysutils/brasero/Makefile
@@ -7,7 +7,7 @@
PORTNAME= brasero
PORTVERSION= 0.8.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils audio multimedia gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -28,7 +28,7 @@ USE_GSTREAMER= gconf core
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
CONFIGURE_ARGS= --disable-inotify
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DHAVE_CAM_LIB_H=1" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= brasero.1
diff --git a/sysutils/brasero/files/patch-src_scsi-cam.c b/sysutils/brasero/files/patch-src_scsi-cam.c
new file mode 100644
index 000000000000..74546979f326
--- /dev/null
+++ b/sysutils/brasero/files/patch-src_scsi-cam.c
@@ -0,0 +1,22 @@
+--- src/scsi-cam.c.orig 2009-01-13 21:35:42.000000000 -0500
++++ src/scsi-cam.c 2009-01-13 21:36:01.000000000 -0500
+@@ -62,7 +62,7 @@ typedef struct _BraseroScsiCmd BraseroSc
+ #define BRASERO_SCSI_CMD_OPCODE_OFF 0
+ #define BRASERO_SCSI_CMD_SET_OPCODE(command) (command->cmd [BRASERO_SCSI_CMD_OPCODE_OFF] = command->info->opcode)
+
+-#define OPEN_FLAGS O_RDWR /*|O_EXCL */|O_NONBLOCK
++#define OPEN_FLAGS O_RDONLY /*|O_EXCL */|O_NONBLOCK
+
+ BraseroScsiResult
+ brasero_scsi_command_issue_sync (gpointer command,
+@@ -158,8 +158,8 @@ brasero_device_handle_open (const gchar
+
+ g_assert (path != NULL);
+
+- if (exclusive)
+- flags |= O_EXCL;
++/* if (exclusive)
++ flags |= O_EXCL;*/
+
+ /* cam_open_device() fails unless we use O_RDWR */
+ cam = cam_open_device (path, O_RDWR);