aboutsummaryrefslogtreecommitdiff
path: root/sysutils/bulk_extractor/Makefile
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-12-22 01:57:32 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-12-22 01:57:32 +0000
commitac5a7241d4e5b0a3df1cfb6308358f39502cb82b (patch)
tree524d9594769c70160ecb4e04347067c27c1c0726 /sysutils/bulk_extractor/Makefile
parentfc9c516346f9403a6db9506df9e2bd4bc10faa36 (diff)
downloadports-ac5a7241d4e5b0a3df1cfb6308358f39502cb82b.tar.gz
ports-ac5a7241d4e5b0a3df1cfb6308358f39502cb82b.zip
This port needs USES=compiler:c++11-lang to build on GCC-based
architectures. To build on powerpc* platforms, -DBIG_ENDIAN must be defined. While here, add USES=gnome, simplify by using localbase, and pet portlint. PR: 234226 Submitted by: Piotr Kubaj Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=488046
Diffstat (limited to 'sysutils/bulk_extractor/Makefile')
-rw-r--r--sysutils/bulk_extractor/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/sysutils/bulk_extractor/Makefile b/sysutils/bulk_extractor/Makefile
index 6b1bf54b7f54..5f6c7a3623fd 100644
--- a/sysutils/bulk_extractor/Makefile
+++ b/sysutils/bulk_extractor/Makefile
@@ -13,17 +13,21 @@ COMMENT= Program that scans a disk image and extracts useful information
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= autoreconf iconv:wchar_t sqlite ssl
-USE_GNOME= libxml2
LIB_DEPENDS= libafflib.so:sysutils/afflib \
libboost_system.so:devel/boost-libs \
libewf.so:devel/libewf \
libexiv2.so:graphics/exiv2 \
libexpat.so:textproc/expat2
+USES= autoreconf compiler:c++11-lang gnome iconv:wchar_t localbase \
+ sqlite ssl
+USE_GNOME= libxml2
+
GNU_CONFIGURE= yes
+CXXFLAGS_powerpc= -DBIG_ENDIAN
+CXXFLAGS_powerpcspe= -DBIG_ENDIAN
+CXXFLAGS_powerpc64= -DBIG_ENDIAN
CONFIGURE_ARGS= --enable-exiv2=true
-CPPFLAGS+= -I${LOCALBASE}/include
PLIST_FILES= bin/bulk_extractor bin/plugin_test man/man1/bulk_extractor.1.gz