aboutsummaryrefslogtreecommitdiff
path: root/sysutils/bulk_extractor
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2014-01-18 07:47:24 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2014-01-18 07:47:24 +0000
commit38cb017be2cba9ba4390301a6262554cf8df69a4 (patch)
treeb740527eb045d9f48ec72f1bd77582038613fd28 /sysutils/bulk_extractor
parentea66f9e4faf18f9f5c9a83a398e6bc00ae2fb2ab (diff)
downloadports-38cb017be2cba9ba4390301a6262554cf8df69a4.tar.gz
ports-38cb017be2cba9ba4390301a6262554cf8df69a4.zip
Update to 1.4.4.
Notes
Notes: svn path=/head/; revision=340148
Diffstat (limited to 'sysutils/bulk_extractor')
-rw-r--r--sysutils/bulk_extractor/Makefile2
-rw-r--r--sysutils/bulk_extractor/distinfo4
-rw-r--r--sysutils/bulk_extractor/files/patch-src__be13_api__plugin.cpp48
-rw-r--r--sysutils/bulk_extractor/files/patch-src__be13_api__sbuf.h11
-rw-r--r--sysutils/bulk_extractor/files/patch-src__bulk_extractor.cpp15
-rw-r--r--sysutils/bulk_extractor/files/patch-src__dfxml__src__dfxml_writer.cpp11
-rw-r--r--sysutils/bulk_extractor/files/patch-src__image_process.h11
-rw-r--r--sysutils/bulk_extractor/files/patch-src__scan_bulk.cpp11
-rw-r--r--sysutils/bulk_extractor/files/patch-src__scan_exif.cpp24
-rw-r--r--sysutils/bulk_extractor/files/patch-src__scan_net.cpp31
-rw-r--r--sysutils/bulk_extractor/files/patch-src__stand.cpp11
-rw-r--r--sysutils/bulk_extractor/files/patch-src__word_and_context_list.h40
12 files changed, 25 insertions, 194 deletions
diff --git a/sysutils/bulk_extractor/Makefile b/sysutils/bulk_extractor/Makefile
index d447d9c309a6..d94a4d5e1140 100644
--- a/sysutils/bulk_extractor/Makefile
+++ b/sysutils/bulk_extractor/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= bulk_extractor
-PORTVERSION= 1.4.0
+PORTVERSION= 1.4.4
CATEGORIES= sysutils
MASTER_SITES= http://www.digitalcorpora.org/downloads/bulk_extractor/
diff --git a/sysutils/bulk_extractor/distinfo b/sysutils/bulk_extractor/distinfo
index 61632e1b6602..c626b6706991 100644
--- a/sysutils/bulk_extractor/distinfo
+++ b/sysutils/bulk_extractor/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bulk_extractor-1.4.0.tar.gz) = 664df29fc0276f8d1b9ff259db13229ea01724915d6ad69493facdc2b4b44dd9
-SIZE (bulk_extractor-1.4.0.tar.gz) = 4346859
+SHA256 (bulk_extractor-1.4.4.tar.gz) = 9f779b0e9e938639bb2ec98af7c1cb8dd76ce845999fb13123b266fbac1d5bbb
+SIZE (bulk_extractor-1.4.4.tar.gz) = 4481240
diff --git a/sysutils/bulk_extractor/files/patch-src__be13_api__plugin.cpp b/sysutils/bulk_extractor/files/patch-src__be13_api__plugin.cpp
deleted file mode 100644
index 12c097f4f7f8..000000000000
--- a/sysutils/bulk_extractor/files/patch-src__be13_api__plugin.cpp
+++ /dev/null
@@ -1,48 +0,0 @@
---- ./src/be13_api/plugin.cpp.orig 2013-08-18 16:35:29.000000000 +0000
-+++ ./src/be13_api/plugin.cpp 2013-10-19 13:12:21.000000000 +0000
-@@ -9,7 +9,16 @@
- #include <sys/stat.h>
- #include <dirent.h>
- #include <algorithm>
-+#ifdef __clang__
-+#if __has_include(<unordered_set>)
-+#define HAVE_CXX11_UNORDERED_SET 1
-+#endif
-+#endif
-+#ifdef HAVE_CXX11_UNORDERED_SET
-+#include <unordered_set>
-+#else
- #include <tr1/unordered_set>
-+#endif
- #ifdef HAVE_ERR_H
- #include <err.h>
- #endif
-@@ -23,20 +32,28 @@
- #include "../dfxml/src/hash_t.h"
-
- namespace std {
-+#ifndef HAVE_CXX11_UNORDERED_SET
- namespace tr1 {
-+#endif
- template<>
- struct hash<md5_t> {
- size_t operator()(const md5_t &key) const {
- return *(size_t *)(key.final());
- }
- };
-+#ifndef HAVE_CXX11_UNORDERED_SET
- }
-+#endif
- }
-
- class atomic_hash_set
- {
- cppmutex M;
-+#ifdef HAVE_CXX11_UNORDERED_SET
-+ std::unordered_set<md5_t>myset;
-+#else
- std::tr1::unordered_set<md5_t>myset;
-+#endif
- public:
- atomic_hash_set():M(),myset(){}
- bool in(const md5_t &s){
diff --git a/sysutils/bulk_extractor/files/patch-src__be13_api__sbuf.h b/sysutils/bulk_extractor/files/patch-src__be13_api__sbuf.h
deleted file mode 100644
index ee7125e00980..000000000000
--- a/sysutils/bulk_extractor/files/patch-src__be13_api__sbuf.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/be13_api/sbuf.h.orig 2013-08-19 18:54:59.000000000 +0000
-+++ ./src/be13_api/sbuf.h 2013-10-19 13:09:32.000000000 +0000
-@@ -61,7 +61,7 @@
- * in a 64-bit number.
- */
-
--inline int stoi(std::string str){
-+inline int be13stoi(std::string str){
- std::istringstream ss(str);
- int val(0);
- ss >> val;
diff --git a/sysutils/bulk_extractor/files/patch-src__bulk_extractor.cpp b/sysutils/bulk_extractor/files/patch-src__bulk_extractor.cpp
deleted file mode 100644
index bdbc0ad19d4b..000000000000
--- a/sysutils/bulk_extractor/files/patch-src__bulk_extractor.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- ./src/bulk_extractor.cpp.orig 2013-09-04 17:58:01.000000000 +0000
-+++ ./src/bulk_extractor.cpp 2013-10-19 13:09:32.000000000 +0000
-@@ -1042,9 +1042,9 @@
- feature_recorder *fr = fs.get_name(params.at(1));
- const std::string &cmd = params.at(2);
- if(fr){
-- if(cmd=="window") fr->set_context_window(stoi(it->second));
-- if(cmd=="window_before") fr->set_context_window_before(stoi(it->second));
-- if(cmd=="window_after") fr->set_context_window_after(stoi(it->second));
-+ if(cmd=="window") fr->set_context_window(be13stoi(it->second));
-+ if(cmd=="window_before") fr->set_context_window_before(be13stoi(it->second));
-+ if(cmd=="window_after") fr->set_context_window_after(be13stoi(it->second));
- }
- }
- /* See if there is a scanner? */
diff --git a/sysutils/bulk_extractor/files/patch-src__dfxml__src__dfxml_writer.cpp b/sysutils/bulk_extractor/files/patch-src__dfxml__src__dfxml_writer.cpp
new file mode 100644
index 000000000000..6b31be503e2f
--- /dev/null
+++ b/sysutils/bulk_extractor/files/patch-src__dfxml__src__dfxml_writer.cpp
@@ -0,0 +1,11 @@
+--- src/dfxml/src/dfxml_writer.cpp.orig 2014-01-18 09:18:03.000000000 +0900
++++ src/dfxml/src/dfxml_writer.cpp 2014-01-18 09:18:26.000000000 +0900
+@@ -657,7 +657,7 @@
+ #endif
+
+ #ifdef HAVE_AFFLIB_AFFLIB_H
+-//#pragma GCC diagnostic ignored "-Wreserved-user-defined-literal" // required for C11
++#pragma GCC diagnostic ignored "-Wreserved-user-defined-literal" // required for C11
+ #include <afflib/afflib.h>
+ #endif
+
diff --git a/sysutils/bulk_extractor/files/patch-src__image_process.h b/sysutils/bulk_extractor/files/patch-src__image_process.h
new file mode 100644
index 000000000000..20fe96139164
--- /dev/null
+++ b/sysutils/bulk_extractor/files/patch-src__image_process.h
@@ -0,0 +1,11 @@
+--- src/image_process.h.orig 2014-01-18 09:13:38.000000000 +0900
++++ src/image_process.h 2014-01-18 09:14:25.000000000 +0900
+@@ -154,7 +154,7 @@
+ ****************************************************************/
+
+ #ifdef HAVE_LIBAFFLIB
+-//#pragma GCC diagnostic ignored "-Wreserved-user-defined-literal" // required for C11
++#pragma GCC diagnostic ignored "-Wreserved-user-defined-literal" // required for C11
+ #include <afflib/afflib.h>
+ #include <vector>
+ class process_aff : public image_process {
diff --git a/sysutils/bulk_extractor/files/patch-src__scan_bulk.cpp b/sysutils/bulk_extractor/files/patch-src__scan_bulk.cpp
deleted file mode 100644
index b5e03932ca3d..000000000000
--- a/sysutils/bulk_extractor/files/patch-src__scan_bulk.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/scan_bulk.cpp.orig 2013-08-18 16:39:31.000000000 +0000
-+++ ./src/scan_bulk.cpp 2013-10-19 13:09:32.000000000 +0000
-@@ -145,7 +145,7 @@
- exit(1);
- }
-
-- uint32_t len = stoi(vals[1]);
-+ uint32_t len = be13stoi(vals[1]);
-
- // If no data for this sector, simply append this type
- // and then continue
diff --git a/sysutils/bulk_extractor/files/patch-src__scan_exif.cpp b/sysutils/bulk_extractor/files/patch-src__scan_exif.cpp
deleted file mode 100644
index 9d9c7b003ed7..000000000000
--- a/sysutils/bulk_extractor/files/patch-src__scan_exif.cpp
+++ /dev/null
@@ -1,24 +0,0 @@
---- ./src/scan_exif.cpp.orig 2013-08-18 16:39:17.000000000 +0000
-+++ ./src/scan_exif.cpp 2013-10-19 13:09:32.000000000 +0000
-@@ -213,7 +213,7 @@
- * Used for helping to convert TIFF's GPS format to decimal lat/long
- */
-
--static double stod(string s)
-+static double be13stod(string s)
- {
- double d=0;
- sscanf(s.c_str(),"%lf",&d);
-@@ -223,9 +223,9 @@
- static double rational(string s)
- {
- std::vector<std::string> parts = split(s,'/');
-- if(parts.size()!=2) return stod(s); // no slash, so return without
-- double top = stod(parts[0]);
-- double bot = stod(parts[1]);
-+ if(parts.size()!=2) return be13stod(s); // no slash, so return without
-+ double top = be13stod(parts[0]);
-+ double bot = be13stod(parts[1]);
- return bot>0 ? top / bot : top;
- }
-
diff --git a/sysutils/bulk_extractor/files/patch-src__scan_net.cpp b/sysutils/bulk_extractor/files/patch-src__scan_net.cpp
deleted file mode 100644
index 1306ac101f1b..000000000000
--- a/sysutils/bulk_extractor/files/patch-src__scan_net.cpp
+++ /dev/null
@@ -1,31 +0,0 @@
---- ./src/scan_net.cpp.orig 2013-08-18 16:39:17.000000000 +0000
-+++ ./src/scan_net.cpp 2013-10-19 13:09:32.000000000 +0000
-@@ -27,7 +27,16 @@
- #include "be13_api/utils.h"
-
- #include <set>
-+#ifdef __clang__
-+#if __has_include(<unordered_set>)
-+#define HAVE_CXX11_UNORDERED_SET 1
-+#endif
-+#endif
-+#ifdef HAVE_CXX11_UNORDERED_SET
-+#include <unordered_set>
-+#else
- #include <tr1/unordered_set>
-+#endif
-
- #include <sys/types.h>
- #include <stdlib.h>
-@@ -603,7 +612,11 @@
- return *this; // no-op
- }
- public:
-+#ifdef HAVE_CXX11_UNORDERED_SET
-+ typedef std::unordered_set<const void *> packetset;
-+#else
- typedef std::tr1::unordered_set<const void *> packetset;
-+#endif
- feature_recorder_set &fs;
- packetset ps;
- feature_recorder *ip_recorder;
diff --git a/sysutils/bulk_extractor/files/patch-src__stand.cpp b/sysutils/bulk_extractor/files/patch-src__stand.cpp
deleted file mode 100644
index 5d848e2bd7b2..000000000000
--- a/sysutils/bulk_extractor/files/patch-src__stand.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/stand.cpp.orig 2012-12-12 15:36:14.000000000 +0000
-+++ ./src/stand.cpp 2013-10-19 13:09:32.000000000 +0000
-@@ -91,7 +91,7 @@
-
- if(argc!=1) usage();
-
-- opt_scan_bulk_block_size = stoi(be_config["bulk_block_size"]);
-+ opt_scan_bulk_block_size = be13stoi(be_config["bulk_block_size"]);
-
- feature_file_names_t feature_file_names;
- enable_feature_recorders(feature_file_names);
diff --git a/sysutils/bulk_extractor/files/patch-src__word_and_context_list.h b/sysutils/bulk_extractor/files/patch-src__word_and_context_list.h
deleted file mode 100644
index db4c713a358d..000000000000
--- a/sysutils/bulk_extractor/files/patch-src__word_and_context_list.h
+++ /dev/null
@@ -1,40 +0,0 @@
---- ./src/word_and_context_list.h.orig 2012-12-12 15:36:14.000000000 +0000
-+++ ./src/word_and_context_list.h 2013-10-19 13:09:32.000000000 +0000
-@@ -29,8 +29,18 @@
- * Typically this is used for stop lists and alert lists.
- */
-
-+#ifdef __clang__
-+#if __has_include(<unordered_set>)
-+#define HAVE_CXX11_UNORDERED_SET 1
-+#endif
-+#endif
-+#ifdef HAVE_CXX11_UNORDERED_SET
-+#include <unordered_map>
-+#include <unordered_set>
-+#else
- #include <tr1/unordered_map>
- #include <tr1/unordered_set>
-+#endif
-
- class context {
- public:
-@@ -75,10 +85,18 @@
- */
- class word_and_context_list {
- private:
-+#ifdef HAVE_CXX11_UNORDERED_SET
-+ typedef unordered_multimap<string,context> stopmap_t;
-+#else
- typedef tr1::unordered_multimap<string,context> stopmap_t;
-+#endif
- stopmap_t fcmap; // maps features to contexts; for finding them
-
-+#ifdef HAVE_CXX11_UNORDERED_SET
-+ typedef unordered_set< string > stopset_t;
-+#else
- typedef tr1::unordered_set< string > stopset_t;
-+#endif
- stopset_t context_set; // presence of a pair in fcmap
-
- beregex_vector patterns;