aboutsummaryrefslogtreecommitdiff
path: root/sysutils/bulk_extractor
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-06-13 19:00:19 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-06-13 19:00:19 +0000
commit6f068f4ba76013b7cba1d667366f56bc0a6a49a3 (patch)
tree1e7c78379129daf4654ae838732c04a9b8801a9d /sysutils/bulk_extractor
parentd278a38e90808124a1ebfb371a1c035589b8a294 (diff)
downloadports-6f068f4ba76013b7cba1d667366f56bc0a6a49a3.tar.gz
ports-6f068f4ba76013b7cba1d667366f56bc0a6a49a3.zip
- Remove __sync_add_and_fetch_8 hack, configure script now detects support for it
- Fix a use after free when dealing with ewf images (already committed upstream)
Notes
Notes: svn path=/head/; revision=357718
Diffstat (limited to 'sysutils/bulk_extractor')
-rw-r--r--sysutils/bulk_extractor/Makefile7
-rw-r--r--sysutils/bulk_extractor/files/patch-src__image_process.h13
2 files changed, 12 insertions, 8 deletions
diff --git a/sysutils/bulk_extractor/Makefile b/sysutils/bulk_extractor/Makefile
index 690a14a1ccc2..677b25d49d6e 100644
--- a/sysutils/bulk_extractor/Makefile
+++ b/sysutils/bulk_extractor/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bulk_extractor
PORTVERSION= 1.4.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= http://www.digitalcorpora.org/downloads/bulk_extractor/
@@ -35,11 +35,6 @@ BEVIEWER_PLIST_FILES= bin/BEViewer bin/BEViewer.jar
.include <bsd.port.options.mk>
-.if ${ARCH} == i386 && ! ${CFLAGS:M-march=*}
-# Needed for __sync_add_and_fetch_8
-CFLAGS+= -march=i586
-.endif
-
.if ${OSVERSION} < 1000033
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
CONFIGURE_ENV= LEX=${LOCALBASE}/bin/flex
diff --git a/sysutils/bulk_extractor/files/patch-src__image_process.h b/sysutils/bulk_extractor/files/patch-src__image_process.h
index 20fe96139164..d8ef64f302a3 100644
--- a/sysutils/bulk_extractor/files/patch-src__image_process.h
+++ b/sysutils/bulk_extractor/files/patch-src__image_process.h
@@ -1,5 +1,14 @@
---- src/image_process.h.orig 2014-01-18 09:13:38.000000000 +0900
-+++ src/image_process.h 2014-01-18 09:14:25.000000000 +0900
+--- ./src/image_process.h.orig 2014-01-15 15:00:06.000000000 +0000
++++ ./src/image_process.h 2014-06-09 14:15:54.000000000 +0000
+@@ -128,7 +128,7 @@
+ virtual int open()=0; /* open; return 0 if successful */
+ virtual int pread(uint8_t *,size_t bytes,int64_t offset) const =0; /* read */
+ virtual int64_t image_size() const=0;
+- virtual std::string image_fname() const { return image_fname_;}
++ virtual const std::string &image_fname() const { return image_fname_;}
+
+ /* iterator support; these virtual functions are called by iterator through (*myimage) */
+ virtual image_process::iterator begin() const =0;
@@ -154,7 +154,7 @@
****************************************************************/