aboutsummaryrefslogtreecommitdiff
path: root/sysutils/busybox
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2014-10-10 23:49:20 +0000
committerMatthias Andree <mandree@FreeBSD.org>2014-10-10 23:49:20 +0000
commit61563bdd1aea19133029048d815553f0ad38d444 (patch)
treedf23a268097b9748256ffa05ec4d5c8ef419f6ea /sysutils/busybox
parent66db0506290734ec28f285bcc5c97e790444968c (diff)
downloadports-61563bdd1aea19133029048d815553f0ad38d444.tar.gz
ports-61563bdd1aea19133029048d815553f0ad38d444.zip
+ Add a STATIC ports option to build a static executable [1].
+ USE_BZIP2 -> USES=...tar:bz2. + Move PORTSCOUT line down to appease portlint. + No PORTREVISION bump for now, no functional change unless options changed. PR: 194294 [1] Submitted by: bdrewery [1]
Notes
Notes: svn path=/head/; revision=370618
Diffstat (limited to 'sysutils/busybox')
-rw-r--r--sysutils/busybox/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/sysutils/busybox/Makefile b/sysutils/busybox/Makefile
index f54d9cc981b2..10b0ccea8646 100644
--- a/sysutils/busybox/Makefile
+++ b/sysutils/busybox/Makefile
@@ -19,20 +19,21 @@ COMMENT= Busybox for FreeBSD
LICENSE= GPLv2
-PORTSCOUT= skipv:1.23.0
-
BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed
CONFLICTS_INSTALL= busybox-unstable-*
+PORTSCOUT= skipv:1.23.0
+
MAKE_ARGS+= SKIP_STRIP=y CC="${CC}" HOSTCC="${CC}" CXX="${CXX}" HOSTCXX="${CXX}"
-USE_BZIP2= yes
# findutils/find.c l. 752+, uses a GCC extension/invalid C code:
-USES= compiler:nestedfct gmake
+USES= compiler:nestedfct gmake tar:bz2
PLIST_FILES= bin/busybox
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS STATIC
+
+STATIC_LDFLAGS= -static
.include <bsd.port.options.mk>