aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cdbakeoven
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-03-04 19:55:11 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-03-04 19:55:11 +0000
commitdf41664aea44e1026ffb68cf1e4334f96899e2c3 (patch)
tree9550e97236de67f23ba0784dc75c4f3aaafcbfc1 /sysutils/cdbakeoven
parent3dfbc30c76216ca0f4e9679a07ee4f7d0b5ab40a (diff)
downloadports-df41664aea44e1026ffb68cf1e4334f96899e2c3.tar.gz
ports-df41664aea44e1026ffb68cf1e4334f96899e2c3.zip
Notes
Diffstat (limited to 'sysutils/cdbakeoven')
-rw-r--r--sysutils/cdbakeoven/Makefile7
-rw-r--r--sysutils/cdbakeoven/files/patch-cdbakeoven::dialogs::CdboDialogActionFactory.cpp43
-rw-r--r--sysutils/cdbakeoven/pkg-message4
3 files changed, 45 insertions, 9 deletions
diff --git a/sysutils/cdbakeoven/Makefile b/sysutils/cdbakeoven/Makefile
index 29506a1a279e..11ca75a9e951 100644
--- a/sysutils/cdbakeoven/Makefile
+++ b/sysutils/cdbakeoven/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cdbakeoven
PORTVERSION= 1.8.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,7 +21,7 @@ RUN_DEPENDS= cdrecord:${PORTSDIR}/sysutils/cdrtools \
ogg123:${PORTSDIR}/audio/vorbis-tools
USE_BZIP2= yes
-USE_KDEBASE_VER=3
+USE_KDELIBS_VER=3
USE_REINPLACE= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -31,7 +31,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|-O2||' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>
diff --git a/sysutils/cdbakeoven/files/patch-cdbakeoven::dialogs::CdboDialogActionFactory.cpp b/sysutils/cdbakeoven/files/patch-cdbakeoven::dialogs::CdboDialogActionFactory.cpp
new file mode 100644
index 000000000000..70fc1cce34d7
--- /dev/null
+++ b/sysutils/cdbakeoven/files/patch-cdbakeoven::dialogs::CdboDialogActionFactory.cpp
@@ -0,0 +1,43 @@
+--- cdbakeoven/dialogs/CdboDialogActionFactory.cpp Tue Jan 21 11:11:55 2003
++++ cdbakeoven/dialogs/CdboDialogActionFactory.cpp.orig Tue Jan 21 11:11:58 2003
+@@ -385,9 +385,12 @@
+ user->status(i18n("Reading CDROM..."));
+ *out += ".iso";
+ cdboProc = new KProcess();
+- *cdboProc << "dd";
+- *cdboProc << "if=" + in;
+- *cdboProc << "of=" + *out + "";
++ *cdboProc << "readcd";
++ *cdboProc << "dev=" + user->getScsiDevice();
++ *cdboProc << "-q";
++ *cdboProc << "retries=32";
++ *cdboProc << "-s";
++ *cdboProc << "f=" + *out;
+ }
+ //---------------------------------------------------------------------------------------------
+ void CdboDialogActionFactory::initBurnProcess(QString image, bool audio ){
+@@ -517,6 +520,7 @@
+ strBuff.prepend("'" + tmpLbl->text());
+ strBuff.append("'");
+ *cdboShellProc << strBuff;*/
++ image.replace(QRegExp("'"),"");
+
+ if(image == "-")
+ *cdboShellProc << " - ";
+@@ -1132,7 +1136,7 @@
+ KRun::shellQuote( file );
+ KRun::shellQuote(outName);
+ if(mType.find("x-mp3") != -1){
+- *cdboShellProc << "mpg123 -v -s " + file + " > " + outName;
++ *cdboShellProc << "mpg123 -v -w " + outName + " " + file;
+ tmpList->append(outName);
+ tracksList->append(outName);
+ return true;
+@@ -1519,6 +1523,7 @@
+ void CdboDialogActionFactory::removeOneFile(QString fileName){
+ if(!fileName) return;
+
++ fileName.replace(QRegExp("'"),"");
+ if(!QFile::remove(fileName))
+ user->output(CdboDialogBase::ErrorMessage, i18n("Failed to remove ") + fileName + "!");
+ }
diff --git a/sysutils/cdbakeoven/pkg-message b/sysutils/cdbakeoven/pkg-message
deleted file mode 100644
index 4b93d6e66b82..000000000000
--- a/sysutils/cdbakeoven/pkg-message
+++ /dev/null
@@ -1,4 +0,0 @@
-*******************************************************************************
-PLEASE NOTE: This port will go away with the release of KDE 3.1, which will
- include cdbakeoven.
-*******************************************************************************