aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cdrtools
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2001-08-02 08:55:16 +0000
committerDirk Froemberg <dirk@FreeBSD.org>2001-08-02 08:55:16 +0000
commit63ee14dd881d27cd0e7ddffefc2ac1dec59d40ba (patch)
tree464a5a7033781e95cf24f507fd17febaf8cba42b /sysutils/cdrtools
parent8b6dfb734d4458d6875b83635516d78d9da38cfc (diff)
downloadports-63ee14dd881d27cd0e7ddffefc2ac1dec59d40ba.tar.gz
ports-63ee14dd881d27cd0e7ddffefc2ac1dec59d40ba.zip
Notes
Diffstat (limited to 'sysutils/cdrtools')
-rw-r--r--sysutils/cdrtools/Makefile43
-rw-r--r--sysutils/cdrtools/distinfo2
-rw-r--r--sysutils/cdrtools/files/patch-ac11
-rw-r--r--sysutils/cdrtools/files/patch-ae38
-rw-r--r--sysutils/cdrtools/files/patch-af89
-rw-r--r--sysutils/cdrtools/files/patch-ag20
-rw-r--r--sysutils/cdrtools/files/patch-ah20
-rw-r--r--sysutils/cdrtools/files/patch-ai87
-rw-r--r--sysutils/cdrtools/files/patch-aj42
-rw-r--r--sysutils/cdrtools/files/patch-ak11
-rw-r--r--sysutils/cdrtools/files/patch-ba10
-rw-r--r--sysutils/cdrtools/files/patch-bb13
-rw-r--r--sysutils/cdrtools/pkg-comment2
-rw-r--r--sysutils/cdrtools/pkg-comment.mkisofs1
-rw-r--r--sysutils/cdrtools/pkg-descr30
-rw-r--r--sysutils/cdrtools/pkg-descr.mkisofs4
-rw-r--r--sysutils/cdrtools/pkg-plist2
-rw-r--r--sysutils/cdrtools/pkg-plist.mkisofs6
18 files changed, 90 insertions, 341 deletions
diff --git a/sysutils/cdrtools/Makefile b/sysutils/cdrtools/Makefile
index a6d7e2966b16..ff369a12ca20 100644
--- a/sysutils/cdrtools/Makefile
+++ b/sysutils/cdrtools/Makefile
@@ -1,22 +1,29 @@
-# New ports collection makefile for: cdrecord
-# Date created: 2 November 1997
-# Whom: jmz
+# New ports collection makefile for: cdrtools
+# Date created: Wed Jul 25 23:30:19 CEST 2001
+# Whom: Dirk Froemberg <dirk@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME= cdrecord
-PORTVERSION= 1.9
-CATEGORIES= sysutils audio
+PORTNAME?= cdrtools
+PORTVERSION?= 1.10
+CATEGORIES?= sysutils audio
MASTER_SITES= ftp://ftp.fokus.gmd.de/pub/unix/cdrecord/ \
ftp://ftp.cs.tu-berlin.de/pub/misc/cdrecord/ \
ftp://ftp.gwdg.de/pub/linux/misc/cdrecord/
+DISTNAME= cdrtools-1.10
MAINTAINER= dirk@FreeBSD.org
-MAN1= cdrecord.1 cdda2wav.1 readcd.1
+.if defined(MKISOFS)
+MAN8= apple_driver.8 isoinfo.8 mkhybrid.8 mkisofs.8
+.else
+MAN1= cdda2wav.1 cdrecord.1 readcd.1
+.endif
+
USE_GMAKE= yes
MAKE_ENV= COPTX="-DBSD_SCSI_SENSE_BUG"
+SLAVEDIRS= sysutils/mkisofs
.if ${MACHINE_ARCH} == "alpha"
post-extract:
@@ -25,15 +32,33 @@ post-extract:
.endif
do-install:
+.if defined(MKISOFS)
+ @${INSTALL_PROGRAM} ${WRKSRC}/mkisofs/OBJ/${ARCH}-freebsd-cc/mkisofs \
+ ${PREFIX}/bin
+ @${LN} -sf mkisofs ${PREFIX}/bin/mkhybrid
+ @${INSTALL_PROGRAM} ${WRKSRC}/mkisofs/diag/OBJ/${ARCH}-freebsd-cc/devdump \
+ ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/mkisofs/diag/OBJ/${ARCH}-freebsd-cc/isodump \
+ ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/mkisofs/diag/OBJ/${ARCH}-freebsd-cc/isoinfo \
+ ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/mkisofs/diag/OBJ/${ARCH}-freebsd-cc/isovfy \
+ ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/mkisofs/apple_driver.8 ${PREFIX}/man/man8
+ @${INSTALL_MAN} ${WRKSRC}/mkisofs/diag/isoinfo.8 ${PREFIX}/man/man8
+ @${INSTALL_MAN} ${WRKSRC}/mkisofs/mkhybrid.8 ${PREFIX}/man/man8
+ @${INSTALL_MAN} ${WRKSRC}/mkisofs/mkisofs.8 ${PREFIX}/man/man8
+.else
@${INSTALL_PROGRAM} ${WRKSRC}/cdrecord/OBJ/${ARCH}-freebsd-cc/cdrecord \
${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/cdda2wav/OBJ/${ARCH}-freebsd-cc/cdda2wav \
${PREFIX}/bin
+ @${LN} -sf cdda2wav ${PREFIX}/bin/list_audio_tracks
@${INSTALL_PROGRAM} ${WRKSRC}/misc/OBJ/${ARCH}-freebsd-cc/readcd \
${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/cdrecord/cdrecord.1 ${PREFIX}/man/man1
@${INSTALL_MAN} ${WRKSRC}/cdda2wav/cdda2wav.1 ${PREFIX}/man/man1
+ @${INSTALL_MAN} ${WRKSRC}/cdrecord/cdrecord.1 ${PREFIX}/man/man1
@${INSTALL_MAN} ${WRKSRC}/misc/readcd.1 ${PREFIX}/man/man1
- @${LN} -sf ${PREFIX}/bin/cdda2wav ${PREFIX}/bin/list_audio_tracks
+.endif
.include <bsd.port.mk>
diff --git a/sysutils/cdrtools/distinfo b/sysutils/cdrtools/distinfo
index 47dc631cd26d..939d8a19f451 100644
--- a/sysutils/cdrtools/distinfo
+++ b/sysutils/cdrtools/distinfo
@@ -1 +1 @@
-MD5 (cdrecord-1.9.tar.gz) = 0fa360d9280d16370d7738ec0b62affb
+MD5 (cdrtools-1.10.tar.gz) = 3a7c452738eb9f58c738908d8146601d
diff --git a/sysutils/cdrtools/files/patch-ac b/sysutils/cdrtools/files/patch-ac
deleted file mode 100644
index c729a75dfe76..000000000000
--- a/sysutils/cdrtools/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/schily.h.orig Mon Aug 30 16:50:46 1999
-+++ include/schily.h Sat Sep 18 17:25:57 1999
-@@ -34,7 +34,7 @@
- #define _SCHILY_H
-
- #ifndef _STANDARD_H
--#include <standard.h.h>
-+#include <standard.h>
- #endif
-
- #if defined(_SIZE_T) || defined(_T_SIZE_) || defined(_T_SIZE) || \
diff --git a/sysutils/cdrtools/files/patch-ae b/sysutils/cdrtools/files/patch-ae
deleted file mode 100644
index 03f40b8e9ec0..000000000000
--- a/sysutils/cdrtools/files/patch-ae
+++ /dev/null
@@ -1,38 +0,0 @@
---- cdrecord/drv_philips.c.orig Sun May 7 14:39:57 2000
-+++ cdrecord/drv_philips.c Fri Aug 18 22:40:38 2000
-@@ -518,7 +518,7 @@
- int *speedp;
- int dummy;
- {
-- struct scsi_mode_page_header *mp;
-+ struct scg_scsi_mode_page_header *mp;
- char mode[256];
- int len = 16;
- int page = 0x31;
-@@ -539,7 +539,7 @@
- if (len == 0)
- return (-1);
-
-- mp = (struct scsi_mode_page_header *)
-+ mp = (struct scg_scsi_mode_page_header *)
- (mode + sizeof(struct scsi_mode_header) +
- ((struct scsi_mode_header *)mode)->blockdesc_len);
-
-@@ -567,7 +567,7 @@
- int *speedp;
- int dummy;
- {
-- struct scsi_mode_page_header *mp;
-+ struct scg_scsi_mode_page_header *mp;
- char mode[256];
- int len = 20;
- int page = 0x23;
-@@ -588,7 +588,7 @@
- if (len == 0)
- return (-1);
-
-- mp = (struct scsi_mode_page_header *)
-+ mp = (struct scg_scsi_mode_page_header *)
- (mode + sizeof(struct scsi_mode_header) +
- ((struct scsi_mode_header *)mode)->blockdesc_len);
-
diff --git a/sysutils/cdrtools/files/patch-af b/sysutils/cdrtools/files/patch-af
deleted file mode 100644
index 3e6ff143cf50..000000000000
--- a/sysutils/cdrtools/files/patch-af
+++ /dev/null
@@ -1,89 +0,0 @@
---- cdrecord/drv_sony.c.orig Sun Jul 2 23:11:58 2000
-+++ cdrecord/drv_sony.c Fri Aug 18 22:40:38 2000
-@@ -399,12 +399,12 @@
- msf_t msf;
-
- char mode[256];
-- struct scsi_mode_page_header *mp;
-+ struct scg_scsi_mode_page_header *mp;
- struct sony_924_mode_page_22 *xp;
-
- dummy = get_page22_sony(scgp, mode);
- if (dummy >= 0) {
-- mp = (struct scsi_mode_page_header *)
-+ mp = (struct scg_scsi_mode_page_header *)
- (mode + sizeof(struct scsi_mode_header) +
- ((struct scsi_mode_header *)mode)->blockdesc_len);
-
-@@ -572,7 +572,7 @@
- int sectype;
- int tracktype;
- {
-- struct scsi_mode_page_header *mp;
-+ struct scg_scsi_mode_page_header *mp;
- char mode[256];
- int len = 0x30;
- int page = 0x23;
-@@ -590,7 +590,7 @@
- if (len == 0)
- return (-1);
-
-- mp = (struct scsi_mode_page_header *)
-+ mp = (struct scg_scsi_mode_page_header *)
- (mode + sizeof(struct scsi_mode_header) +
- ((struct scsi_mode_header *)mode)->blockdesc_len);
-
-@@ -613,7 +613,7 @@
- int sectype;
- int tracktype;
- {
-- struct scsi_mode_page_header *mp;
-+ struct scg_scsi_mode_page_header *mp;
- char mode[256];
- int len = 0x30;
- int page = 0x23;
-@@ -635,7 +635,7 @@
- if (len == 0)
- return (-1);
-
-- mp = (struct scsi_mode_page_header *)
-+ mp = (struct scg_scsi_mode_page_header *)
- (mode + sizeof(struct scsi_mode_header) +
- ((struct scsi_mode_header *)mode)->blockdesc_len);
-
-@@ -707,7 +707,7 @@
- int toctype;
- int multi;
- {
-- struct scsi_mode_page_header *mp;
-+ struct scg_scsi_mode_page_header *mp;
- char mode[256];
- int i;
- int len = 0x30;
-@@ -718,7 +718,7 @@
- if ((len = get_page22_sony(scgp, mode)) < 0)
- return (-1);
-
-- mp = (struct scsi_mode_page_header *)
-+ mp = (struct scg_scsi_mode_page_header *)
- (mode + sizeof(struct scsi_mode_header) +
- ((struct scsi_mode_header *)mode)->blockdesc_len);
-
-@@ -747,7 +747,7 @@
- SCSI *scgp;
- char *mode;
- {
-- struct scsi_mode_page_header *mp;
-+ struct scg_scsi_mode_page_header *mp;
- int len = 0x30;
- int page = 0x22;
- struct sony_924_mode_page_22 *xp;
-@@ -764,7 +764,7 @@
- if (len == 0)
- return (-1);
-
-- mp = (struct scsi_mode_page_header *)
-+ mp = (struct scg_scsi_mode_page_header *)
- (mode + sizeof(struct scsi_mode_header) +
- ((struct scsi_mode_header *)mode)->blockdesc_len);
-
diff --git a/sysutils/cdrtools/files/patch-ag b/sysutils/cdrtools/files/patch-ag
deleted file mode 100644
index e1b0f3b748e2..000000000000
--- a/sysutils/cdrtools/files/patch-ag
+++ /dev/null
@@ -1,20 +0,0 @@
---- cdrecord/modes.c.orig Sun May 7 14:49:37 2000
-+++ cdrecord/modes.c Fri Aug 18 22:40:38 2000
-@@ -58,7 +58,7 @@
- int hdlen;
- int len = 1; /* Nach SCSI Norm */
- int try = 0;
-- struct scsi_mode_page_header *mp;
-+ struct scg_scsi_mode_page_header *mp;
-
- again:
- fillbytes((caddr_t)mode, sizeof(mode), '\0');
-@@ -89,7 +89,7 @@
- scsiprbytes("Mode Sense Data", mode, len - scsigetresid(scgp));
- hdlen = sizeof(struct scsi_mode_header) +
- ((struct scsi_mode_header *)mode)->blockdesc_len;
-- mp = (struct scsi_mode_page_header *)(mode + hdlen);
-+ mp = (struct scg_scsi_mode_page_header *)(mode + hdlen);
- if (scgp->verbose)
- scsiprbytes("Mode Page Data", (u_char *)mp, mp->p_len+2);
-
diff --git a/sysutils/cdrtools/files/patch-ah b/sysutils/cdrtools/files/patch-ah
deleted file mode 100644
index d9bc5cd64fc0..000000000000
--- a/sysutils/cdrtools/files/patch-ah
+++ /dev/null
@@ -1,20 +0,0 @@
---- libscg/scg/scsireg.h.orig Sun May 28 23:31:20 2000
-+++ libscg/scg/scsireg.h Fri Aug 18 22:40:38 2000
-@@ -244,7 +244,7 @@
-
- #if defined(_BIT_FIELDS_LTOH) /* Intel byteorder */
-
--struct scsi_mode_page_header {
-+struct scg_scsi_mode_page_header {
- Ucbit p_code : 6;
- Ucbit res : 1;
- Ucbit parsave : 1;
-@@ -262,7 +262,7 @@
-
- #else /* Motorola byteorder */
-
--struct scsi_mode_page_header {
-+struct scg_scsi_mode_page_header {
- Ucbit parsave : 1;
- Ucbit res : 1;
- Ucbit p_code : 6;
diff --git a/sysutils/cdrtools/files/patch-ai b/sysutils/cdrtools/files/patch-ai
deleted file mode 100644
index 6106947467d8..000000000000
--- a/sysutils/cdrtools/files/patch-ai
+++ /dev/null
@@ -1,87 +0,0 @@
---- cdrecord/drv_philips.c.orig Fri Feb 2 15:14:16 2001
-+++ cdrecord/drv_philips.c Fri Feb 2 16:00:48 2001
-@@ -62,6 +62,7 @@
- LOCAL int write_track_info_philips __PR((SCSI *scgp, int));
- LOCAL int write_track_philips __PR((SCSI *scgp, long, int));
- LOCAL int open_track_philips __PR((SCSI *scgp, cdr_t *dp, int track, track_t *track_info));
-+LOCAL int open_track_plasmon __PR((SCSI *scgp, cdr_t *dp, int track, track_t *track_info));
- LOCAL int open_track_oldphilips __PR((SCSI *scgp, cdr_t *dp, int track, track_t *track_info));
- LOCAL int open_track_yamaha __PR((SCSI *scgp, cdr_t *dp, int track, track_t *track_info));
- LOCAL int close_track_philips __PR((SCSI *scgp, int track, track_t *trackp));
-@@ -71,6 +72,7 @@
- LOCAL int plasmon_attach __PR((SCSI *scgp, cdr_t *));
- LOCAL int ricoh_attach __PR((SCSI *scgp, cdr_t *));
- LOCAL int philips_getlilo __PR((SCSI *scgp, long *lilenp, long *lolenp));
-+LOCAL int plasmon_buf __PR((SCSI *, long *, long *));
-
-
- struct cdd_52x_mode_page_21 { /* write track information */
-@@ -284,7 +286,7 @@
- philips_getdisktype,
- philips_load,
- philips_unload,
-- buf_dummy,
-+ plasmon_buf,
- recovery_needed,
- recover_philips,
- speed_select_philips,
-@@ -293,7 +295,7 @@
- reserve_track_philips,
- scsi_cdr_write_philips,
- no_sendcue,
-- open_track_philips,
-+ open_track_plasmon,
- close_track_philips,
- (int(*)__PR((SCSI *, cdr_t *, int, track_t *, int, int)))cmd_dummy,
- cmd_dummy,
-@@ -922,6 +924,22 @@
- }
-
- LOCAL int
-+open_track_plasmon(scgp, dp, track, track_info)
-+ SCSI *scgp;
-+ cdr_t *dp;
-+ int track;
-+ track_t *track_info;
-+{
-+ if (select_secsize(scgp, track_info->secsize) < 0)
-+ return (-1);
-+
-+ if (write_track_info_philips(scgp, track_info->sectype) < 0)
-+ return (-1);
-+
-+ return (0);
-+}
-+
-+LOCAL int
- open_track_oldphilips(scgp, dp, track, track_info)
- SCSI *scgp;
- cdr_t *dp;
-@@ -1211,4 +1229,27 @@
- *lolenp = lo;
-
- return (0);
-+}
-+
-+LOCAL int
-+plasmon_buf(scgp, sp, fp)
-+ SCSI *scgp;
-+ long *sp; /* Size pointer */
-+ long *fp; /* Free space pointer */
-+{
-+ /*
-+ * There's no way to obtain these values from the
-+ * Plasmon RF41xx devices. This function stub is only
-+ * present to prevent cdrecord.c from calling a pointless
-+ * READ BUFFER SCSI cmd which is meant to be used for
-+ * something totally else, and which would only jam the
-+ * Plasmon due to the incorrect parameters used.
-+ */
-+
-+ if (sp)
-+ *sp = 2 * 1024 * 1024; /* assume 2 MB */
-+ if (fp)
-+ *fp = 2 * 1024 * 1024; /* assume 2 MB */
-+
-+ return 100;
- }
diff --git a/sysutils/cdrtools/files/patch-aj b/sysutils/cdrtools/files/patch-aj
deleted file mode 100644
index fbc2f5ad3a22..000000000000
--- a/sysutils/cdrtools/files/patch-aj
+++ /dev/null
@@ -1,42 +0,0 @@
---- lib/cvt.c.orig Wed Sep 8 15:03:20 1999
-+++ lib/cvt.c Sun Feb 25 10:06:50 2001
-@@ -31,7 +31,7 @@
- #include <standard.h>
-
- #ifdef HAVE_DTOA /* 4.4BSD floating point implementation */
--extern char *__dtoa __PR((double value, int mode, int ndigit, int *decpt, int *sign, char **ep));
-+extern char *__dtoa __PR((double value, int mode, int ndigit, int *decpt, int *sign, char **ep, char **resultp));
- #endif
-
- #ifndef HAVE_ECVT
-@@ -57,7 +57,13 @@
- static char *buf;
- char *bufend;
- char *ep;
-- char *bp = __dtoa(value, 2, ndigit, decpt, sign, &ep);
-+ char *bp;
-+ static char *dtoaresult = NULL;
-+
-+ free(dtoaresult);
-+ dtoaresult = NULL;
-+
-+ bp = __dtoa(value, 2, ndigit, decpt, sign, &ep, &dtoaresult);
-
- if (value == 0.0) {
- /*
-@@ -102,7 +108,13 @@
- static char *buf;
- char *bufend;
- char *ep;
-- char *bp = __dtoa(value, 3, ndigit, decpt, sign, &ep);
-+ char *bp;
-+ static char *dtoaresult = NULL;
-+
-+ free(dtoaresult);
-+ dtoaresult = NULL;
-+
-+ bp = __dtoa(value, 3, ndigit, decpt, sign, &ep, &dtoaresult);
-
- if (value == 0.0) {
- /*
-
diff --git a/sysutils/cdrtools/files/patch-ak b/sysutils/cdrtools/files/patch-ak
new file mode 100644
index 000000000000..04afa2fa7f52
--- /dev/null
+++ b/sysutils/cdrtools/files/patch-ak
@@ -0,0 +1,11 @@
+--- scgcheck/Makefile.orig Mon Mar 19 00:19:43 2001
++++ scgcheck/Makefile Sun Jul 29 10:46:48 2001
+@@ -13,7 +13,7 @@
+
+ HFILES= scgcheck.h
+ #LIBS= -lschily $(LIB_SOCKET)
+-LIBS= -lrscg -lscg -lschily $(LIB_SOCKET)
++LIBS= -lrscg -lscg -lschily $(SCSILIB) $(LIB_SOCKET)
+ XMK_FILE= Makefile.man
+
+ ###########################################################################
diff --git a/sysutils/cdrtools/files/patch-ba b/sysutils/cdrtools/files/patch-ba
deleted file mode 100644
index 87417c340c18..000000000000
--- a/sysutils/cdrtools/files/patch-ba
+++ /dev/null
@@ -1,10 +0,0 @@
---- TARGETS/Targetdirs.orig Sat Apr 29 18:14:51 2000
-+++ TARGETS/Targetdirs Sun Jul 30 22:06:58 2000
-@@ -1,5 +1,5 @@
- #ident %W% %E% %Q%
- ###########################################################################
--DIRS= patches conf inc lib libdeflt libscg libhfs_iso libfile libunls \
-- cdrecord mkisofs mkisofs/diag cdda2wav misc man
-+DIRS= patches conf inc lib libdeflt libscg \
-+ cdrecord cdda2wav misc man
- ###########################################################################
diff --git a/sysutils/cdrtools/files/patch-bb b/sysutils/cdrtools/files/patch-bb
new file mode 100644
index 000000000000..b37ea2f81308
--- /dev/null
+++ b/sysutils/cdrtools/files/patch-bb
@@ -0,0 +1,13 @@
+--- mkisofs/tree.c.orig Thu Apr 27 11:44:57 2000
++++ mkisofs/tree.c Sat Apr 29 11:34:23 2000
+@@ -538,8 +538,8 @@
+ table->de_flags |= INHIBIT_JOLIET_ENTRY;
+ /* table->name = strdup("<translation table>");*/
+ table->name = strdup(trans_tbl);
+- table->table = (char *) e_malloc(ISO_ROUND_UP(tablesize));
+- memset(table->table, 0, ISO_ROUND_UP(tablesize));
++ table->table = (char *) e_malloc(ISO_ROUND_UP(tablesize+1));
++ memset(table->table, 0, ISO_ROUND_UP(tablesize+1));
+ iso9660_file_length(trans_tbl, table, 0);
+
+ if (use_RockRidge) {
diff --git a/sysutils/cdrtools/pkg-comment b/sysutils/cdrtools/pkg-comment
index 0b07c15a9a6c..1257714deea4 100644
--- a/sysutils/cdrtools/pkg-comment
+++ b/sysutils/cdrtools/pkg-comment
@@ -1 +1 @@
-Cdrecord and cdda2wav (CD-DA ripper) allow you to record CD-R's
+Cdrecord, mkisofs and several other programs to record CD-R[W]
diff --git a/sysutils/cdrtools/pkg-comment.mkisofs b/sysutils/cdrtools/pkg-comment.mkisofs
new file mode 100644
index 000000000000..3b56ca683c02
--- /dev/null
+++ b/sysutils/cdrtools/pkg-comment.mkisofs
@@ -0,0 +1 @@
+Create iso9660/Rock Ridge/Joliet filesystems
diff --git a/sysutils/cdrtools/pkg-descr b/sysutils/cdrtools/pkg-descr
index 7dd569aac23b..7ca2ab88f087 100644
--- a/sysutils/cdrtools/pkg-descr
+++ b/sysutils/cdrtools/pkg-descr
@@ -1,19 +1,25 @@
-Cdrecord allows you to create CD's on a CD-Recorder.
+This package contains the following software:
-Cdrecord has been implemented with a Philips CDD 521.
-Cdrecord now is maintained with the following drives:
+- cdda2wav (an digital CD audio extraction program)
- COMPRO/Matsushita/Panasonic CW-7502
- Philips CDD-2000
- TEAC CD-R55S
- Yamaha CDR-400
+- cdrecord (a CD recording program)
-It should run also on:
+- mkisofs (an ISO-9660 filesystem image creator)
- All SCSI-3/mmc compliant drives
- All ATAPI/mmc compliant drives
+- mkhybrid (an ISO-9660/HFS filesystem image creator)
-This version also includes cdda2wav, a CD-DA
-ripping program that includes customisable jitter correction.
+- several diagnostic programs for ISO-9660
+
+ - devdup dump a device or file in hex
+
+ - isodump dump a device or file based on ISO-9660
+
+ - isoinfo analyze or list an IDO-9660 image
+
+ - isovrfy verify an ISO-9660 image
+
+- readcd (a stripped down version of scgskeleton)
+ may be used to read data CD's, to write to DVD-RAM
+ and to copy Solaris boot CD's
WWW: http://www.fokus.gmd.de/research/cc/glone/employees/joerg.schilling/private/cdrecord.html
diff --git a/sysutils/cdrtools/pkg-descr.mkisofs b/sysutils/cdrtools/pkg-descr.mkisofs
new file mode 100644
index 000000000000..b58b8d83308a
--- /dev/null
+++ b/sysutils/cdrtools/pkg-descr.mkisofs
@@ -0,0 +1,4 @@
+mkisofs is effectively a pre-mastering program to generate the iso9660
+filesystem - it takes a snapshot of a given directory tree, and generates
+a binary image which will correspond to an iso9660 filesystem when written
+to a block device.
diff --git a/sysutils/cdrtools/pkg-plist b/sysutils/cdrtools/pkg-plist
index 2198998f463f..208f38dc4336 100644
--- a/sysutils/cdrtools/pkg-plist
+++ b/sysutils/cdrtools/pkg-plist
@@ -1,4 +1,4 @@
-bin/cdrecord
bin/cdda2wav
+bin/cdrecord
bin/list_audio_tracks
bin/readcd
diff --git a/sysutils/cdrtools/pkg-plist.mkisofs b/sysutils/cdrtools/pkg-plist.mkisofs
new file mode 100644
index 000000000000..c3fd0359d9e9
--- /dev/null
+++ b/sysutils/cdrtools/pkg-plist.mkisofs
@@ -0,0 +1,6 @@
+bin/devdump
+bin/isodump
+bin/isoinfo
+bin/isovfy
+bin/mkhybrid
+bin/mkisofs