aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cfengine314
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2019-09-23 00:11:52 +0000
committerCy Schubert <cy@FreeBSD.org>2019-09-23 00:11:52 +0000
commit9e4641f64bf8644ffa6fce9c46debcfc90fdc346 (patch)
tree28d892ba700b47a90f5f1e81031d2ea6530ef790 /sysutils/cfengine314
parent07b9206ce90301db146cc846cd045a61625d0f13 (diff)
downloadports-9e4641f64bf8644ffa6fce9c46debcfc90fdc346.tar.gz
ports-9e4641f64bf8644ffa6fce9c46debcfc90fdc346.zip
cfengine ./configure will detect pre-existing mysql and postgresql
installs and use them even when options are deselected. This causes unwanted dependencies and unintuitive errors.
Notes
Notes: svn path=/head/; revision=512606
Diffstat (limited to 'sysutils/cfengine314')
-rw-r--r--sysutils/cfengine314/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/sysutils/cfengine314/Makefile b/sysutils/cfengine314/Makefile
index ee16c44b8a3c..8ee66230007a 100644
--- a/sysutils/cfengine314/Makefile
+++ b/sysutils/cfengine314/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cfengine
PORTVERSION= 3.14.0
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= https://s3.amazonaws.com/cfengine-package-repos/tarballs/
@@ -57,10 +58,12 @@ OPTIONS_DEFINE= PGSQL MYSQL LIBVIRT
PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= --with-postgresql=${LOCALBASE}
+PGSQL_CONFIGURE_OFF= --without-postgresql
MYSQL_USES= mysql
MYSQL_BROKEN= configure: error: MySQL client library exports symbols (EVP_CIPHER_CTX_init) clashing with OpenSSL.
MYSQL_CONFIGURE_WITH= --with-mysql=${LOCALBASE}
+MYSQL_CONFIGURE_OFF= --without-mysql
MYSQL_LIB_DEPENDS= libmysqlclient.so:${_MYSQL_CLIENT}
MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql