aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cfengine
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2007-06-15 18:18:57 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2007-06-15 18:18:57 +0000
commit73de43e54b8c34aad95c3bd2e9109d912dfeaa9f (patch)
tree62c4c3fc5ef1e7e3fdb618e40c153b737fe7d049 /sysutils/cfengine
parent0bafb7f7e5abb49c9c623d2f6e99c8a2c915e8c9 (diff)
downloadports-73de43e54b8c34aad95c3bd2e9109d912dfeaa9f.tar.gz
ports-73de43e54b8c34aad95c3bd2e9109d912dfeaa9f.zip
- Update to 2.2.1 [1]
- Add rc.d scripts for cfexecd(8) and cfservd(8) PR: ports/113167 [1] Submitted by: Jo Rhett <jrhett AT svcolo dot com>
Notes
Notes: svn path=/head/; revision=193606
Diffstat (limited to 'sysutils/cfengine')
-rw-r--r--sysutils/cfengine/Makefile11
-rw-r--r--sysutils/cfengine/distinfo6
-rw-r--r--sysutils/cfengine/files/cfexecd.in30
-rw-r--r--sysutils/cfengine/files/cfservd.in30
-rw-r--r--sysutils/cfengine/files/patch-Makefile.in17
-rw-r--r--sysutils/cfengine/files/patch-doc_Makefile.in46
6 files changed, 113 insertions, 27 deletions
diff --git a/sysutils/cfengine/Makefile b/sysutils/cfengine/Makefile
index dd19f98e9100..b8c142a56fac 100644
--- a/sysutils/cfengine/Makefile
+++ b/sysutils/cfengine/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cfengine
-PORTVERSION= 2.1.22
+PORTVERSION= 2.2.1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.iu.hio.no/pub/cfengine/ \
${MASTER_SITE_GNU}
@@ -15,11 +15,16 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= sergei@FreeBSD.org
COMMENT= A systems administration tool for networks
-USE_BDB= 44
+USE_RC_SUBR= cfexecd cfservd
+
+USE_BDB?= 44
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-docs
+CONFIGURE_ARGS= --with-docs \
+ --docdir=${DOCSDIR} \
+ --infodir=${PREFIX}/info \
+ --mandir=${MANPREFIX}/man
CONFIGURE_ENV+= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} PTHREAD_LIBS=${PTHREAD_LIBS} \
BERKELEY_DB_CFLAGS=-I${BDB_INCLUDE_DIR} \
BERKELEY_DB_LDFLAGS=-L${BDB_LIB_DIR} \
diff --git a/sysutils/cfengine/distinfo b/sysutils/cfengine/distinfo
index ec42d8a87ff6..f71ef637ebe7 100644
--- a/sysutils/cfengine/distinfo
+++ b/sysutils/cfengine/distinfo
@@ -1,3 +1,3 @@
-MD5 (cfengine-2.1.22.tar.gz) = 5452c988225751da9ed2f1edf3426866
-SHA256 (cfengine-2.1.22.tar.gz) = fa30e5b29517370e5cea8d9935999e437709e574d103eb317eeed007c975d451
-SIZE (cfengine-2.1.22.tar.gz) = 3673965
+SHA256 (cfengine-2.2.1.tar.gz) = ad820f08dc0883eaceae58eafa043d7638d117825496abb289228746132bafea
+MD5 (cfengine-2.2.1.tar.gz) = 27764b352e835eeb648052ee01140953
+SIZE (cfengine-2.2.1.tar.gz) = 3715232
diff --git a/sysutils/cfengine/files/cfexecd.in b/sysutils/cfengine/files/cfexecd.in
new file mode 100644
index 000000000000..a892216ff80e
--- /dev/null
+++ b/sysutils/cfengine/files/cfexecd.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: cfexecd
+# REQUIRE: SERVERS
+# BEFORE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following line to /etc/rc.conf[.local] to enable cfexecd(8)
+#
+# cfexecd_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable cfexecd.
+# cfexecd_flags (str): Custom additional arguments to be passed
+# to cfexecd (default empty).
+#
+
+. %%RC_SUBR%%
+
+name="cfexecd"
+rcvar=${name}_enable
+
+command="%%PREFIX%%/sbin/${name}"
+
+load_rc_config $name
+
+: ${cfexecd_enable="NO"}
+: ${cfexecd_flags=""}
+
+run_rc_command "$1"
diff --git a/sysutils/cfengine/files/cfservd.in b/sysutils/cfengine/files/cfservd.in
new file mode 100644
index 000000000000..caa8300fd181
--- /dev/null
+++ b/sysutils/cfengine/files/cfservd.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: cfservd
+# REQUIRE: SERVERS
+# BEFORE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following line to /etc/rc.conf[.local] to enable cfservd(8)
+#
+# cfservd_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable cfservd.
+# cfservd_flags (str): Custom additional arguments to be passed
+# to cfservd (default empty).
+#
+
+. %%RC_SUBR%%
+
+name="cfservd"
+rcvar=${name}_enable
+
+command="%%PREFIX%%/sbin/${name}"
+
+load_rc_config $name
+
+: ${cfservd_enable="NO"}
+: ${cfservd_flags=""}
+
+run_rc_command "$1"
diff --git a/sysutils/cfengine/files/patch-Makefile.in b/sysutils/cfengine/files/patch-Makefile.in
index cb72f3e3c0c5..15fda846d1ee 100644
--- a/sysutils/cfengine/files/patch-Makefile.in
+++ b/sysutils/cfengine/files/patch-Makefile.in
@@ -1,12 +1,19 @@
---- Makefile.in.orig Sat Oct 1 16:32:09 2005
-+++ Makefile.in Fri Oct 7 10:36:51 2005
-@@ -201,8 +201,12 @@
+--- Makefile.in_orig Wed May 30 10:44:56 2007
++++ Makefile.in Wed May 30 10:48:32 2007
+@@ -174,7 +174,7 @@
+ build_vendor = @build_vendor@
+ datadir = @datadir@
+ datarootdir = @datarootdir@
+-docdir = $(pkgdatadir)
++docdir = $(prefix)/share/doc/cfengine
+ dvidir = @dvidir@
+ exec_prefix = @exec_prefix@
+ host = @host@
+@@ -209,7 +209,11 @@
@BUILD_DOC_TRUE@DOC_DIR = doc
SUBDIRS = pub src contrib inputs $(DOC_DIR)
EXTRA_DIST = acconfig.h doc/cfengine.8 COPYING ChangeLog INSTALL NEWS README
--docdir = $(pkgdatadir)
-doc_DATA = README ChangeLog INSTALL NEWS
-+docdir = $(prefix)/share/doc/cfengine
+.if defined(NOPORTDOCS)
+doc_DATA =
+.else
diff --git a/sysutils/cfengine/files/patch-doc_Makefile.in b/sysutils/cfengine/files/patch-doc_Makefile.in
index 4d5f5f77e89a..deb651f388b5 100644
--- a/sysutils/cfengine/files/patch-doc_Makefile.in
+++ b/sysutils/cfengine/files/patch-doc_Makefile.in
@@ -1,5 +1,5 @@
---- doc/Makefile.in.orig Wed Sep 20 10:27:06 2006
-+++ doc/Makefile.in Fri Dec 15 12:24:05 2006
+--- doc/Makefile.in.orig Tue May 29 11:07:06 2007
++++ doc/Makefile.in Wed May 30 10:58:27 2007
@@ -52,8 +52,12 @@
CONFIG_CLEAN_FILES =
SOURCES =
@@ -13,12 +13,28 @@
am__TEXINFO_TEX_DIR = $(srcdir)
DVIS = cfengine-Reference.dvi cfengine-Tutorial.dvi \
cfengine-Anomalies.dvi
-@@ -205,15 +209,23 @@
+@@ -171,7 +175,7 @@
+ build_vendor = @build_vendor@
+ datadir = @datadir@
+ datarootdir = @datarootdir@
+-docdir = $(pkgdatadir)/doc
++docdir = $(prefix)/share/doc/cfengine
+ dvidir = @dvidir@
+ exec_prefix = @exec_prefix@
+ host = @host@
+@@ -179,7 +183,7 @@
+ host_cpu = @host_cpu@
+ host_os = @host_os@
+ host_vendor = @host_vendor@
+-htmldir = $(pkgdatadir)/html
++htmldir = $(docdir)
+ includedir = @includedir@
+ infodir = @infodir@
+ install_sh = @install_sh@
+@@ -213,13 +217,21 @@
# Info used in building and installing HTML files
htmlfiles = $(info_TEXINFOS:.texinfo=.html)
--htmldir = $(pkgdatadir)/html
-+htmldir = $(docdir)
+.if defined(NOPORTDOCS)
+html_DATA =
+.else
@@ -29,8 +45,6 @@
psfiles = $(info_TEXINFOS:.texinfo=.ps)
pdffiles = $(info_TEXINFOS:.texinfo=.pdf)
dvifiles = $(info_TEXINFOS:.texinfo=.dvi)
--docdir = $(pkgdatadir)/doc
-+docdir = $(prefix)/share/doc/cfengine
+.if defined(NOPORTDOCS)
+doc_DATA =
+.else
@@ -39,7 +53,7 @@
# Make sure these get distributed with everything else.
EXTRA_DIST = cfagent.8 cfenvd.8 cfenvgraph.8 cfexecd.8 cfkey.8 cfrun.8 cfservd.8 cfengine.8 cfshow.8 cfetoolcheck.8 cfetooldump.8 cfetoolimport.8 cfetoolupdate.8 cfetoolcreate.8 cfetoolgraph.8 cfetoolinfo.8 cfetoolcheck.8 cfetooldump.8 cfetoolimport.8 cfetoolupdate.8 cfetoolcreate.8 cfetoolgraph.8 cfetoolinfo.8 texinfo.tex $(htmlfiles) $(infofiles) $(psfiles) $(dvifiles) $(pdffiles)
-@@ -316,7 +328,7 @@
+@@ -324,7 +336,7 @@
exit 1; \
fi
$(srcdir)/version1.texi: $(srcdir)/stamp-vti
@@ -48,7 +62,7 @@
@(dir=.; test -f ./cfengine-Reference.texinfo || dir=$(srcdir); \
set `$(SHELL) $(srcdir)/mdate-sh $$dir/cfengine-Reference.texinfo`; \
echo "@set UPDATED $$1 $$2 $$3"; \
-@@ -375,7 +387,7 @@
+@@ -385,7 +397,7 @@
exit 1; \
fi
$(srcdir)/version2.texi: $(srcdir)/stamp-1
@@ -57,7 +71,7 @@
@(dir=.; test -f ./cfengine-Tutorial.texinfo || dir=$(srcdir); \
set `$(SHELL) $(srcdir)/mdate-sh $$dir/cfengine-Tutorial.texinfo`; \
echo "@set UPDATED $$1 $$2 $$3"; \
-@@ -434,7 +446,7 @@
+@@ -446,7 +458,7 @@
exit 1; \
fi
$(srcdir)/version3.texi: $(srcdir)/stamp-2
@@ -66,7 +80,7 @@
@(dir=.; test -f ./cfengine-Anomalies.texinfo || dir=$(srcdir); \
set `$(SHELL) $(srcdir)/mdate-sh $$dir/cfengine-Anomalies.texinfo`; \
echo "@set UPDATED $$1 $$2 $$3"; \
-@@ -579,6 +591,7 @@
+@@ -592,6 +604,7 @@
rm -f "$(DESTDIR)$(man8dir)/$$inst"; \
done
install-docDATA: $(doc_DATA)
@@ -74,7 +88,7 @@
@$(NORMAL_INSTALL)
test -z "$(docdir)" || $(mkdir_p) "$(DESTDIR)$(docdir)"
@list='$(doc_DATA)'; for p in $$list; do \
-@@ -587,6 +600,7 @@
+@@ -600,6 +613,7 @@
echo " $(docDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(docdir)/$$f'"; \
$(docDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(docdir)/$$f"; \
done
@@ -82,7 +96,7 @@
uninstall-docDATA:
@$(NORMAL_UNINSTALL)
-@@ -596,6 +610,7 @@
+@@ -609,6 +623,7 @@
rm -f "$(DESTDIR)$(docdir)/$$f"; \
done
install-htmlDATA: $(html_DATA)
@@ -90,7 +104,7 @@
@$(NORMAL_INSTALL)
test -z "$(htmldir)" || $(mkdir_p) "$(DESTDIR)$(htmldir)"
@list='$(html_DATA)'; for p in $$list; do \
-@@ -604,6 +619,7 @@
+@@ -617,6 +632,7 @@
echo " $(htmlDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(htmldir)/$$f'"; \
$(htmlDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(htmldir)/$$f"; \
done
@@ -98,7 +112,7 @@
uninstall-htmlDATA:
@$(NORMAL_UNINSTALL)
-@@ -712,6 +728,7 @@
+@@ -725,6 +741,7 @@
install-info: install-info-am
install-info-am: $(INFO_DEPS)
@@ -106,7 +120,7 @@
@$(NORMAL_INSTALL)
test -z "$(infodir)" || $(mkdir_p) "$(DESTDIR)$(infodir)"
@srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`; \
-@@ -741,6 +758,7 @@
+@@ -754,6 +771,7 @@
install-info --info-dir="$(DESTDIR)$(infodir)" "$(DESTDIR)$(infodir)/$$relfile" || :;\
done; \
else : ; fi