aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ciso
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-02-07 15:35:58 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-02-07 15:35:58 +0000
commit25a185da97b5bf1c49fb741cb0935c8b821a08cd (patch)
treeb0ad5098c879548921da8c9aa66c3815f01f3409 /sysutils/ciso
parent7633cf3b76ccfdb0383e7379bd3cd1176af1b35e (diff)
downloadports-25a185da97b5bf1c49fb741cb0935c8b821a08cd.tar.gz
ports-25a185da97b5bf1c49fb741cb0935c8b821a08cd.zip
- Fix runtime on 64-bit platforms
PR: ports/142711 Submitted by: Jonathan Jacobs <jonathan+freebsd@jsphere.com> Approved by: maintainer timeout (26 days)
Notes
Notes: svn path=/head/; revision=249389
Diffstat (limited to 'sysutils/ciso')
-rw-r--r--sysutils/ciso/Makefile2
-rw-r--r--sysutils/ciso/files/patch-ciso.h23
2 files changed, 25 insertions, 0 deletions
diff --git a/sysutils/ciso/Makefile b/sysutils/ciso/Makefile
index ef6699dd463a..1066985a9729 100644
--- a/sysutils/ciso/Makefile
+++ b/sysutils/ciso/Makefile
@@ -7,12 +7,14 @@
PORTNAME= ciso
PORTVERSION= 1.0.0
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://ciso.tenshu.fr/
MAINTAINER= blttll@gmail.com
COMMENT= A tool to compress ISO images to CSO format
+USE_DOS2UNIX= yes
PLIST_FILES= bin/ciso
.include <bsd.port.mk>
diff --git a/sysutils/ciso/files/patch-ciso.h b/sysutils/ciso/files/patch-ciso.h
new file mode 100644
index 000000000000..7fd25c9a8d7d
--- /dev/null
+++ b/sysutils/ciso/files/patch-ciso.h
@@ -0,0 +1,23 @@
+--- ciso.h.orig 2010-02-07 16:32:56.000000000 +0100
++++ ciso.h 2010-02-07 16:33:38.000000000 +0100
+@@ -19,6 +19,8 @@
+ Copyright 2005 BOOSTER
+ */
+
++#include <stdint.h>
++
+
+ #ifndef __CISO_H__
+ #define __CISO_H__
+@@ -28,9 +30,9 @@
+ typedef struct ciso_header
+ {
+ unsigned char magic[4]; /* +00 : 'C','I','S','O' */
+- unsigned long header_size; /* +04 : header size (==0x18) */
++ uint32_t header_size; /* +04 : header size (==0x18) */
+ unsigned long long total_bytes; /* +08 : number of original data size */
+- unsigned long block_size; /* +10 : number of compressed block size */
++ uint32_t block_size; /* +10 : number of compressed block size */
+ unsigned char ver; /* +14 : version 01 */
+ unsigned char align; /* +15 : align of index value */
+ unsigned char rsv_06[2]; /* +16 : reserved */