aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ckl
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-06-02 21:01:10 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-06-02 21:01:10 +0000
commite3a5b1ddfa857d25abef394adeb3cbce96173272 (patch)
treec2f91bba920be26cf82070d54fe6a09ec74b0fd7 /sysutils/ckl
parentd2296c2269c8b41ccedf10ccbe1966ddbd09f0c2 (diff)
downloadports-e3a5b1ddfa857d25abef394adeb3cbce96173272.tar.gz
ports-e3a5b1ddfa857d25abef394adeb3cbce96173272.zip
Notes
Diffstat (limited to 'sysutils/ckl')
-rw-r--r--sysutils/ckl/Makefile45
-rw-r--r--sysutils/ckl/distinfo3
-rw-r--r--sysutils/ckl/files/cloudkick.conf.example2
-rw-r--r--sysutils/ckl/files/patch-src-conf.c27
-rw-r--r--sysutils/ckl/pkg-descr4
-rw-r--r--sysutils/ckl/pkg-plist4
6 files changed, 85 insertions, 0 deletions
diff --git a/sysutils/ckl/Makefile b/sysutils/ckl/Makefile
new file mode 100644
index 000000000000..876eda4a4b65
--- /dev/null
+++ b/sysutils/ckl/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: ckl
+# Date created: 1 June 2010
+# Whom: Tomaz Muraus <kami@k5-storitve.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ckl
+PORTVERSION= 0.9.1
+CATEGORIES= sysutils net
+MASTER_SITES= http://packages.cloudkick.com/releases/ckl/
+DISTNAME= ckl-${PORTVERSION}
+
+MAINTAINER= kami@k5-storitve.net
+COMMENT= A command line tool for noting when something was changed on a machine
+
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+
+USE_SCONS= yes
+USE_BZIP2= yes
+
+PORTDOCS= CHANGES LICENSE NOTICE README
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/ckl ${PREFIX}/bin
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${EXAMPLESDIR}/webapp
+ (cd ${WRKSRC}/webapp/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}/webapp)
+.endif
+ ${INSTALL_DATA} ${PATCHDIR}/cloudkick.conf.example ${PREFIX}/etc/cloudkick.conf.sample
+ @if [ ! -f ${PREFIX}/etc/cloudkick.conf ]; then \
+ ${INSTALL_DATA} -p ${PREFIX}/etc/cloudkick.conf.sample ${PREFIX}/etc/cloudkick.conf ; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/sysutils/ckl/distinfo b/sysutils/ckl/distinfo
new file mode 100644
index 000000000000..e0d68456d7d5
--- /dev/null
+++ b/sysutils/ckl/distinfo
@@ -0,0 +1,3 @@
+MD5 (ckl-0.9.1.tar.bz2) = 010b2e7455a41b5c2380cb0c56954802
+SHA256 (ckl-0.9.1.tar.bz2) = 270d8de8f08ff0eeb88191527f6991467d3fee10b99c5c9319b5e027e1d3f77f
+SIZE (ckl-0.9.1.tar.bz2) = 297908
diff --git a/sysutils/ckl/files/cloudkick.conf.example b/sysutils/ckl/files/cloudkick.conf.example
new file mode 100644
index 000000000000..c518beb6d862
--- /dev/null
+++ b/sysutils/ckl/files/cloudkick.conf.example
@@ -0,0 +1,2 @@
+ckl_endpoint http://ckl.example.com/
+secret mySuperSecret
diff --git a/sysutils/ckl/files/patch-src-conf.c b/sysutils/ckl/files/patch-src-conf.c
new file mode 100644
index 000000000000..601facd4f690
--- /dev/null
+++ b/sysutils/ckl/files/patch-src-conf.c
@@ -0,0 +1,27 @@
+*** src/conf.c.orig Sun Jan 24 02:46:27 2010
+--- src/conf.c Tue Jun 1 07:19:59 2010
+***************
+*** 86,96 ****
+ {
+ int rv;
+ FILE *fp;
+
+ /* TODO: respect prefix */
+! fp = fopen("/etc/cloudkick.conf", "r");
+ if (fp == NULL) {
+ char buf[2048];
+ const char *home = getenv("HOME");
+
+ if (home == NULL) {
+--- 86,96 ----
+ {
+ int rv;
+ FILE *fp;
+
+ /* TODO: respect prefix */
+! fp = fopen("/usr/local/etc/cloudkick.conf", "r");
+ if (fp == NULL) {
+ char buf[2048];
+ const char *home = getenv("HOME");
+
+ if (home == NULL) {
diff --git a/sysutils/ckl/pkg-descr b/sysutils/ckl/pkg-descr
new file mode 100644
index 000000000000..f6d893225717
--- /dev/null
+++ b/sysutils/ckl/pkg-descr
@@ -0,0 +1,4 @@
+A command line tool for noting when something was changed on a machine.
+The contents of the message are POST'ed to another server for logging.
+
+WWW: http://github.com/pquerna/ckl
diff --git a/sysutils/ckl/pkg-plist b/sysutils/ckl/pkg-plist
new file mode 100644
index 000000000000..c5aea6d4603b
--- /dev/null
+++ b/sysutils/ckl/pkg-plist
@@ -0,0 +1,4 @@
+bin/ckl
+@unexec if cmp -s %D/etc/cloudkick.conf %D/etc/cloudkick.conf.sample; then rm -f %D/etc/cloudkick.conf; fi
+etc/cloudkick.conf.sample
+@exec if [ ! -f %D/etc/cloudkick.conf ]; then cp %B/%f %D/etc/cloudkick.conf; fi