aboutsummaryrefslogtreecommitdiff
path: root/sysutils/clsync
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-01-14 19:04:35 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-01-14 19:04:35 +0000
commitc796587e990a1ab4044d3d1a7469f8d4bff48e76 (patch)
tree50e7b87e162a8a28a22eba9ddac8b36b22f125bc /sysutils/clsync
parent5c7145d13c92897c761584208a1c36520c6aca0d (diff)
downloadports-c796587e990a1ab4044d3d1a7469f8d4bff48e76.tar.gz
ports-c796587e990a1ab4044d3d1a7469f8d4bff48e76.zip
- Remove compiler flag unknown to clang to fix build on 10+
- Use INSTALL_PROGRAM to install binary, which fixes stripping - Remove slashes after ${STAGEDIR} PR: 195906 Submitted by: amdmi3 Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=377039
Diffstat (limited to 'sysutils/clsync')
-rw-r--r--sysutils/clsync/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/sysutils/clsync/Makefile b/sysutils/clsync/Makefile
index aa6e23a32f69..29d3bb1bd332 100644
--- a/sysutils/clsync/Makefile
+++ b/sysutils/clsync/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libinotify.so:${PORTSDIR}/devel/libinotify \
libexecinfo.so:${PORTSDIR}/devel/libexecinfo
GNU_CONFIGURE= yes
-USES= autoreconf gmake libtool pkgconfig
+USES= autoreconf compiler:features gmake libtool pkgconfig
USE_GNOME= glib20
USE_RC_SUBR= clsync
@@ -38,7 +38,7 @@ LIBCLSYNC_DESC= Build libclsync.so for control socket clients
OPTIONS_DEFAULT=PARANOID
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MVERYPARANOID}
CONFIGURE_ARGS+= --enable-paranoid=2
@@ -62,10 +62,15 @@ CONFIGURE_ARGS+= --enable-debug
CONFIGURE_ARGS+= --enable-libclsync
.endif
+.if ${COMPILER_TYPE} == clang
+post-patch:
+ @${REINPLACE_CMD} -e 's|-fstack-check||' ${WRKSRC}/configure.ac
+.endif
+
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/clsync ${STAGEDIR}/${PREFIX}/sbin/clsync
- ${INSTALL_DATA} ${WRKSRC}/man/man1/clsync.1 ${STAGEDIR}/${PREFIX}/man/man1/clsync.1
- ${MKDIR} ${STAGEDIR}/${ETCDIR}
- ${INSTALL_DATA} ${WRKSRC}/freebsd/usr/local/etc/clsync/${PORTNAME}.conf ${STAGEDIR}/${ETCDIR}/${PORTNAME}.conf.sample
+ ${INSTALL_PROGRAM} ${WRKSRC}/clsync ${STAGEDIR}${PREFIX}/sbin/clsync
+ ${INSTALL_DATA} ${WRKSRC}/man/man1/clsync.1 ${STAGEDIR}${PREFIX}/man/man1/clsync.1
+ ${MKDIR} ${STAGEDIR}${ETCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/freebsd/usr/local/etc/clsync/${PORTNAME}.conf ${STAGEDIR}${ETCDIR}/${PORTNAME}.conf.sample
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>