aboutsummaryrefslogtreecommitdiff
path: root/sysutils/conky
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2016-10-04 12:44:05 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2016-10-04 12:44:05 +0000
commit0062c5be04cfb4ff075425e0946039390af5e9b5 (patch)
treeed66d718fbb880d64bbd87685a1b27232f5a990d /sysutils/conky
parent9068a4d4e99c1697a324e163008497b35f3d45d5 (diff)
downloadports-0062c5be04cfb4ff075425e0946039390af5e9b5.tar.gz
ports-0062c5be04cfb4ff075425e0946039390af5e9b5.zip
- Update to 1.10.5
- Remove patches which have been accepted upstream
Notes
Notes: svn path=/head/; revision=423260
Diffstat (limited to 'sysutils/conky')
-rw-r--r--sysutils/conky/Makefile3
-rw-r--r--sysutils/conky/distinfo6
-rw-r--r--sysutils/conky/files/patch-src_c++wrap.cc10
-rw-r--r--sysutils/conky/files/patch-src_conky.cc36
-rw-r--r--sysutils/conky/files/patch-src_core.cc17
-rw-r--r--sysutils/conky/files/patch-src_freebsd.cc79
-rw-r--r--sysutils/conky/files/patch-src_freebsd.h10
-rw-r--r--sysutils/conky/files/patch-src_luamm.cc2
-rw-r--r--sysutils/conky/files/patch-src_luamm.hh14
9 files changed, 8 insertions, 169 deletions
diff --git a/sysutils/conky/Makefile b/sysutils/conky/Makefile
index 5646f803dd5b..416ae226d0a3 100644
--- a/sysutils/conky/Makefile
+++ b/sysutils/conky/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= conky
-PORTVERSION= 1.10.4
+PORTVERSION= 1.10.5
DISTVERSIONPREFIX= v
-PORTREVISION= 2
CATEGORIES= sysutils
MAINTAINER= madpilot@FreeBSD.org
diff --git a/sysutils/conky/distinfo b/sysutils/conky/distinfo
index eac3970d973a..33a76cf2e816 100644
--- a/sysutils/conky/distinfo
+++ b/sysutils/conky/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1470249422
-SHA256 (brndnmtthws-conky-v1.10.4_GH0.tar.gz) = ed61ffb3be9fd24965d40401c7d54553e732038f3da2e03454915779384f59b4
-SIZE (brndnmtthws-conky-v1.10.4_GH0.tar.gz) = 365145
+TIMESTAMP = 1475571819
+SHA256 (brndnmtthws-conky-v1.10.5_GH0.tar.gz) = 3bcf1ae93721e0575cd4ef8fd60da9e5bf1b2fbceb365fb9792f2aec6139f569
+SIZE (brndnmtthws-conky-v1.10.5_GH0.tar.gz) = 365176
diff --git a/sysutils/conky/files/patch-src_c++wrap.cc b/sysutils/conky/files/patch-src_c++wrap.cc
deleted file mode 100644
index c764660b5fab..000000000000
--- a/sysutils/conky/files/patch-src_c++wrap.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/c++wrap.cc.orig 2016-07-20 16:53:48 UTC
-+++ src/c++wrap.cc
-@@ -26,6 +26,7 @@
- #include "c++wrap.hh"
-
- #include <unistd.h>
-+#include <stdio.h>
-
- /* force use of POSIX strerror_r instead of non-portable GNU specific */
- #ifdef _GNU_SOURCE
diff --git a/sysutils/conky/files/patch-src_conky.cc b/sysutils/conky/files/patch-src_conky.cc
index 4a30994d0f22..5f4c27a9eab2 100644
--- a/sysutils/conky/files/patch-src_conky.cc
+++ b/sysutils/conky/files/patch-src_conky.cc
@@ -1,4 +1,4 @@
---- src/conky.cc.orig 2016-07-20 16:53:48 UTC
+--- src/conky.cc.orig 2016-10-04 07:49:19 UTC
+++ src/conky.cc
@@ -129,7 +129,7 @@
#include <microhttpd.h>
@@ -9,37 +9,3 @@
#include <bsd/bsd.h>
#endif
-@@ -728,13 +728,6 @@ int percent_print(char *buf, int size, u
- return spaced_print(buf, size, "%u", pad_percents.get(*state), value);
- }
-
--#if defined(__FreeBSD__)
--unsigned long long llabs(long long num) {
-- if(num < 0) return -num;
-- else return num;
--}
--#endif
--
- /* converts from bytes to human readable format (K, M, G, T)
- *
- * The algorithm always divides by 1024, as unit-conversion of byte
-@@ -1811,8 +1804,8 @@ int draw_each_line_inner(char *s, int sp
- #endif /* BUILD_X11 */
- case GOTO:
- if (current->arg >= 0) {
-- cur_x = (int) current->arg;
- #ifdef BUILD_X11
-+ cur_x = (int) current->arg;
- //make sure shades are 1 pixel to the right of the text
- if(draw_mode == BG) cur_x++;
- #endif /* BUILD_X11 */
-@@ -1934,7 +1927,9 @@ static void draw_text(void)
-
- static void draw_stuff(void)
- {
-+#ifdef BUILD_X11
- text_offset_x = text_offset_y = 0;
-+#endif
- #ifdef BUILD_IMLIB2
- cimlib_render(text_start_x, text_start_y, window.width, window.height);
- #endif /* BUILD_IMLIB2 */
diff --git a/sysutils/conky/files/patch-src_core.cc b/sysutils/conky/files/patch-src_core.cc
deleted file mode 100644
index 5796e807d9ea..000000000000
--- a/sysutils/conky/files/patch-src_core.cc
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/core.cc.orig 2016-07-20 16:53:48 UTC
-+++ src/core.cc
-@@ -898,11 +898,12 @@ struct text_object *construct_text_objec
- return NULL;
- }
- } else
--#ifdef __linux__
- OBJ(addr, &update_net_stats)
- parse_net_stat_arg(obj, arg, free_at_crash);
- obj->callbacks.print = &print_addr;
-- END OBJ(addrs, &update_net_stats)
-+ END
-+#ifdef __linux__
-+ OBJ(addrs, &update_net_stats)
- parse_net_stat_arg(obj, arg, free_at_crash);
- obj->callbacks.print = &print_addrs;
- #ifdef BUILD_IPV6
diff --git a/sysutils/conky/files/patch-src_freebsd.cc b/sysutils/conky/files/patch-src_freebsd.cc
deleted file mode 100644
index 6aa9be65eb56..000000000000
--- a/sysutils/conky/files/patch-src_freebsd.cc
+++ /dev/null
@@ -1,79 +0,0 @@
---- src/freebsd.cc.orig 2016-07-20 16:53:48 UTC
-+++ src/freebsd.cc
-@@ -295,11 +295,7 @@ int update_running_processes(void)
- std::lock_guard<std::mutex> guard(kvm_proc_mutex);
- p = kvm_getprocs(kd, KERN_PROC_ALL, 0, &n_processes);
- for (i = 0; i < n_processes; i++) {
--#if (__FreeBSD__ < 5) && !defined(__FreeBSD_kernel__)
-- if (p[i].kp_proc.p_stat == SRUN) {
--#else
- if (p[i].ki_stat == SRUN) {
--#endif
- cnt++;
- }
- }
-@@ -475,7 +471,7 @@ void get_battery_stuff(char *buf, unsign
- break;
- case BATTERY_STATUS:
- if (batstate == 1) // Discharging
-- snprintf(buf, n, "remaining %d%%", batcapacity);
-+ snprintf(buf, n, "remaining (%d%%)", batcapacity);
- else
- snprintf(buf, n, batstate == 2 ? "charging (%d%%)" :
- (batstate == 7 ? "absent/on AC" : "charged (%d%%)"),
-@@ -508,26 +504,10 @@ static int check_bat(const char *bat)
-
- int get_battery_perct(const char *bat)
- {
-- union acpi_battery_ioctl_arg battio;
-- int batnum, acpifd;
-- int designcap, lastfulcap, batperct;
-+ int batcapacity;
-
-- if ((battio.unit = batnum = check_bat(bat)) < 0)
-- return 0;
-- if ((acpifd = open("/dev/acpi", O_RDONLY)) < 0) {
-- fprintf(stderr, "Can't open ACPI device\n");
-- return 0;
-- }
-- if (ioctl(acpifd, ACPIIO_BATT_GET_BIF, &battio) == -1) {
-- fprintf(stderr, "Unable to get info for battery unit %d\n", batnum);
-- return 0;
-- }
-- close(acpifd);
-- designcap = battio.bif.dcap;
-- lastfulcap = battio.bif.lfcap;
-- batperct = (designcap > 0 && lastfulcap > 0) ?
-- (int) (((float) lastfulcap / designcap) * 100) : 0;
-- return batperct > 100 ? 100 : batperct;
-+ get_battery_stats(NULL, &batcapacity, NULL, NULL);
-+ return batcapacity;
- }
-
- double get_battery_perct_bar(struct text_object *obj)
-@@ -729,6 +709,7 @@ void get_top_info(void)
-
- proc->time_stamp = g_time;
- proc->name = strndup(p[i].ki_comm, text_buffer_size.get(*state));
-+ proc->basename = strndup(p[i].ki_comm, text_buffer_size.get(*state));
- proc->amount = 100.0 * p[i].ki_pctcpu / FSCALE;
- proc->vsize = p[i].ki_size;
- proc->rss = (p[i].ki_rssize * getpagesize());
-@@ -745,11 +726,14 @@ void get_battery_short_status(char *buff
- if (0 == strncmp("charging", buffer, 8)) {
- buffer[0] = 'C';
- memmove(buffer + 1, buffer + 8, n - 8);
-- } else if (0 == strncmp("discharging", buffer, 11)) {
-+ } else if (0 == strncmp("remaining", buffer, 9)) {
- buffer[0] = 'D';
-- memmove(buffer + 1, buffer + 11, n - 11);
-+ memmove(buffer + 1, buffer + 9, n - 9);
-+ } else if (0 == strncmp("charged", buffer, 7)) {
-+ buffer[0] = 'F';
-+ memmove(buffer + 1, buffer + 7, n - 7);
- } else if (0 == strncmp("absent/on AC", buffer, 12)) {
-- buffer[0] = 'A';
-+ buffer[0] = 'N';
- memmove(buffer + 1, buffer + 12, n - 12);
- }
- }
diff --git a/sysutils/conky/files/patch-src_freebsd.h b/sysutils/conky/files/patch-src_freebsd.h
deleted file mode 100644
index 5f87b37d0ad1..000000000000
--- a/sysutils/conky/files/patch-src_freebsd.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/freebsd.h.orig 2016-07-20 16:53:48 UTC
-+++ src/freebsd.h
-@@ -7,6 +7,7 @@
- #include <sys/param.h>
- #include <sys/mount.h>
- #include <sys/ucred.h>
-+#include <strings.h>
- #include <fcntl.h>
- #include <kvm.h>
- #if (defined(i386) || defined(__i386__))
diff --git a/sysutils/conky/files/patch-src_luamm.cc b/sysutils/conky/files/patch-src_luamm.cc
index 2d28deba36a5..0cc6fb62e8c6 100644
--- a/sysutils/conky/files/patch-src_luamm.cc
+++ b/sysutils/conky/files/patch-src_luamm.cc
@@ -1,4 +1,4 @@
---- src/luamm.cc.orig 2016-07-20 16:53:48 UTC
+--- src/luamm.cc.orig 2016-10-04 07:49:19 UTC
+++ src/luamm.cc
@@ -57,7 +57,8 @@ namespace lua {
lua_pushstring(l, e.what());
diff --git a/sysutils/conky/files/patch-src_luamm.hh b/sysutils/conky/files/patch-src_luamm.hh
index 460d16036788..324ccc9c7244 100644
--- a/sysutils/conky/files/patch-src_luamm.hh
+++ b/sysutils/conky/files/patch-src_luamm.hh
@@ -1,16 +1,6 @@
---- src/luamm.hh.orig 2016-07-20 16:53:48 UTC
+--- src/luamm.hh.orig 2016-10-04 07:49:19 UTC
+++ src/luamm.hh
-@@ -25,7 +25,9 @@
- #include <assert.h>
- #include <memory>
- #include <mutex>
-+#include <exception>
- #include <stdexcept>
-+#include <string>
-
- #include <lua.hpp>
-
-@@ -210,7 +212,7 @@ namespace lua {
+@@ -212,7 +212,7 @@ namespace lua {
bool islightuserdata(int index) throw() { return lua_islightuserdata(cobj.get(), index); }
bool isnil(int index) throw() { return lua_isnil(cobj.get(), index); }
bool isnone(int index) throw() { return lua_isnone(cobj.get(), index); }