aboutsummaryrefslogtreecommitdiff
path: root/sysutils/conky
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2016-09-29 14:31:29 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2016-09-29 14:31:29 +0000
commit39595545680e06d09642cf310c5f24e19d372973 (patch)
tree60bf568daf2763a1fafe13194e8b11a5e256077f /sysutils/conky
parent4b2f32c726373933b6c14cff2d36661eba40b73e (diff)
downloadports-39595545680e06d09642cf310c5f24e19d372973.tar.gz
ports-39595545680e06d09642cf310c5f24e19d372973.zip
Add dependency on libinotify and fix build when it is present.
Reported by: Walter Schwarzenfeld <w.schwarzenfeld at utanet.at> (via email)
Notes
Notes: svn path=/head/; revision=422930
Diffstat (limited to 'sysutils/conky')
-rw-r--r--sysutils/conky/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/sysutils/conky/Makefile b/sysutils/conky/Makefile
index 5bf581adea17..ab41e6b64732 100644
--- a/sysutils/conky/Makefile
+++ b/sysutils/conky/Makefile
@@ -4,12 +4,14 @@
PORTNAME= conky
PORTVERSION= 1.10.4
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= sysutils
MAINTAINER= madpilot@FreeBSD.org
COMMENT?= Advanced, highly configurable system monitor for X11
-LIB_DEPENDS= libtolua++-5.1.so:lang/tolua++
+LIB_DEPENDS= libtolua++-5.1.so:lang/tolua++ \
+ libinotify.so:devel/libinotify
BUILD_DEPENDS= db2x_xsltproc:textproc/docbook2X \
docbook-xsl>=0:textproc/docbook-xsl \
xsltproc:textproc/libxslt
@@ -128,7 +130,7 @@ post-patch:
-e 's/-D_POSIX_C_SOURCE=200809L/& -D__BSD_VISIBLE=1 -D_XOPEN_SOURCE=700/' \
${WRKSRC}/cmake/Conky.cmake
@${REINPLACE_CMD} -e 's,^set(INCLUDE_SEARCH_PATH \(.*\)),set(INCLUDE_SEARCH_PATH \1 ${LUA_INCDIR}),' \
- -e 's/ -lbsd/ -lintl/' \
+ -e 's/ -lbsd/ -lintl -linotify/' \
${WRKSRC}/cmake/ConkyPlatformChecks.cmake
@${REINPLACE_CMD} -e 's,LOCALBASE,${LOCALBASE},' \
${WRKSRC}/doc/docgen.sh \