aboutsummaryrefslogtreecommitdiff
path: root/sysutils/conky
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2018-03-24 09:15:14 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2018-03-24 09:15:14 +0000
commit803c1480977659d4c9f10083e7c8c7ee9316ca12 (patch)
treea04672b4eafbe131556beea40c883b6b92f7b89a /sysutils/conky
parent3fe7173bf0ba1e72e49215b42f4fb10e95cab1e2 (diff)
downloadports-803c1480977659d4c9f10083e7c8c7ee9316ca12.tar.gz
ports-803c1480977659d4c9f10083e7c8c7ee9316ca12.zip
Import upstream patch to fix OSS (sound mixer) support.
While here, fix malformed line in patch causing build time warning. Reported by: pong (via IRC) Obtained from: https://github.com/brndnmtthws/conky/commit/6b386589c0822bdaf5ed38d5f388cf902e0e749e
Notes
Notes: svn path=/head/; revision=465440
Diffstat (limited to 'sysutils/conky')
-rw-r--r--sysutils/conky/Makefile1
-rw-r--r--sysutils/conky/files/patch-cmake_ConkyPlatformChecks.cmake30
-rw-r--r--sysutils/conky/files/patch-src_bsdapm.cc2
3 files changed, 32 insertions, 1 deletions
diff --git a/sysutils/conky/Makefile b/sysutils/conky/Makefile
index dd8c1d4c45f8..ce2248763128 100644
--- a/sysutils/conky/Makefile
+++ b/sysutils/conky/Makefile
@@ -4,6 +4,7 @@
PORTNAME= conky
PORTVERSION= 1.10.8
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= sysutils
MAINTAINER= madpilot@FreeBSD.org
diff --git a/sysutils/conky/files/patch-cmake_ConkyPlatformChecks.cmake b/sysutils/conky/files/patch-cmake_ConkyPlatformChecks.cmake
new file mode 100644
index 000000000000..f1c225ebb452
--- /dev/null
+++ b/sysutils/conky/files/patch-cmake_ConkyPlatformChecks.cmake
@@ -0,0 +1,30 @@
+diff --git a/cmake/ConkyPlatformChecks.cmake b/cmake/ConkyPlatformChecks.cmake
+index 334b4690..ce5c109b 100644
+--- cmake/ConkyPlatformChecks.cmake
++++ cmake/ConkyPlatformChecks.cmake
+@@ -30,8 +30,6 @@ check_include_files(sys/statfs.h HAVE_SYS_STATFS_H)
+ check_include_files(sys/param.h HAVE_SYS_PARAM_H)
+ check_include_files(sys/inotify.h HAVE_SYS_INOTIFY_H)
+ check_include_files(dirent.h HAVE_DIRENT_H)
+-check_include_files("soundcard.h;sys/soundcard.h;linux/soundcard.h" HAVE_SOME_SOUNDCARD_H)
+-check_include_files("linux/soundcard.h" HAVE_LINUX_SOUNDCARD_H)
+
+ # Check for some functions
+ check_function_exists(strndup HAVE_STRNDUP)
+@@ -88,6 +86,16 @@ if(NOT OS_LINUX AND NOT OS_FREEBSD AND NOT OS_OPENBSD AND NOT OS_DRAGONFLY
+ endif(NOT OS_LINUX AND NOT OS_FREEBSD AND NOT OS_OPENBSD AND NOT OS_DRAGONFLY
+ AND NOT OS_SOLARIS AND NOT OS_HAIKU)
+
++# Check for soundcard header
++if(OS_LINUX)
++ check_include_files("linux/soundcard.h" HAVE_SOME_SOUNDCARD_H)
++ check_include_files("linux/soundcard.h" HAVE_LINUX_SOUNDCARD_H)
++elseif(OS_OPENBSD)
++ check_include_files("soundcard.h" HAVE_SOME_SOUNDCARD_H)
++else(OS_LINUX)
++ check_include_files("sys/soundcard.h" HAVE_SOME_SOUNDCARD_H)
++endif(OS_LINUX)
++
+ if(BUILD_I18N AND OS_DRAGONFLY)
+ set(conky_libs ${conky_libs} -lintl)
+ endif(BUILD_I18N AND OS_DRAGONFLY)
diff --git a/sysutils/conky/files/patch-src_bsdapm.cc b/sysutils/conky/files/patch-src_bsdapm.cc
index 3a89bbce3621..e5fde8256d7c 100644
--- a/sysutils/conky/files/patch-src_bsdapm.cc
+++ b/sysutils/conky/files/patch-src_bsdapm.cc
@@ -5,7 +5,7 @@
*
*/
+
-+#if (defined(__FreeBSD__) || defined(__FreeBSD_kernel__) \
++#if (defined(__FreeBSD__) || defined(__FreeBSD_kernel__) \
+ || defined(__DragonFly__) \
+ || defined(__OpenBSD__)) && (defined(i386) || defined(__i386__))
#include "config.h"