aboutsummaryrefslogtreecommitdiff
path: root/sysutils/contractor/Makefile
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2014-05-29 17:11:38 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2014-05-29 17:11:38 +0000
commit4c8736f8f1f68a11164aa1aacb5e043948970220 (patch)
tree12913f806761605eaf553780c49cc1db38d948c2 /sysutils/contractor/Makefile
parent1cb2ec951e2c08fdb14b1ff16a2844f66cf0d416 (diff)
downloadports-4c8736f8f1f68a11164aa1aacb5e043948970220.tar.gz
ports-4c8736f8f1f68a11164aa1aacb5e043948970220.zip
Notes
Diffstat (limited to 'sysutils/contractor/Makefile')
-rw-r--r--sysutils/contractor/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/sysutils/contractor/Makefile b/sysutils/contractor/Makefile
new file mode 100644
index 000000000000..3a6a1730f3e1
--- /dev/null
+++ b/sysutils/contractor/Makefile
@@ -0,0 +1,23 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+
+PORTNAME= contractor
+PORTVERSION= 0.3.1
+CATEGORIES= sysutils
+MASTER_SITES= https://launchpadlibrarian.net/176424633/ \
+ https://launchpad.net/${PORTNAME}/${PORTVERSION:R}/${PORTVERSION}/+download/
+DIST_SUBDIR= eos
+
+MAINTAINER= olivierd@FreeBSD.org
+COMMENT= Desktop-wide extension service
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala
+LIB_DEPENDS= libgee-0.8.so:${PORTSDIR}/devel/libgee
+
+USE_GCC= yes
+USES= cmake pkgconfig
+USE_GNOME= glib20
+
+.include <bsd.port.mk>