aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cpdup
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2006-04-25 15:52:08 +0000
committerVolker Stolz <vs@FreeBSD.org>2006-04-25 15:52:08 +0000
commite6120dcce12e435a3ea249bf2749bb7dc8b8a750 (patch)
treec1b4003dbb09f72e072d7be4a9b22bf578e20737 /sysutils/cpdup
parent67c7391607044742d450c745939bb74964eddeaf (diff)
downloadports-e6120dcce12e435a3ea249bf2749bb7dc8b8a750.tar.gz
ports-e6120dcce12e435a3ea249bf2749bb7dc8b8a750.zip
Skip inodes with snapshot flag on (bump PORTREV)
PR: ports/96252 Submitted by: marck@
Notes
Notes: svn path=/head/; revision=160442
Diffstat (limited to 'sysutils/cpdup')
-rw-r--r--sysutils/cpdup/Makefile1
-rw-r--r--sysutils/cpdup/files/patch-cpdup.c17
2 files changed, 18 insertions, 0 deletions
diff --git a/sysutils/cpdup/Makefile b/sysutils/cpdup/Makefile
index 4f1e7159d047..6f9dd82539de 100644
--- a/sysutils/cpdup/Makefile
+++ b/sysutils/cpdup/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cpdup
PORTVERSION= 1.05
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://apollo.backplane.com/FreeBSDPorts/
#MASTER_SITE_SUBDIR= cp
diff --git a/sysutils/cpdup/files/patch-cpdup.c b/sysutils/cpdup/files/patch-cpdup.c
new file mode 100644
index 000000000000..aa5c1fca53ea
--- /dev/null
+++ b/sysutils/cpdup/files/patch-cpdup.c
@@ -0,0 +1,17 @@
+
+$FreeBSD$
+
+--- cpdup.c.orig
++++ cpdup.c
+@@ -321,6 +321,11 @@
+
+ if (lstat(spath, &st1) != 0)
+ return(0);
++#ifdef SF_SNAPSHOT
++ /* skip snapshot files: we cannot handle files larger than file system */
++ if (st1.st_flags & SF_SNAPSHOT)
++ return(0);
++#endif
+ st2.st_mode = 0; /* in case lstat fails */
+ st2.st_flags = 0; /* in case lstat fails */
+ if (dpath && lstat(dpath, &st2) == 0)