aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cpu-microcode-amd
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2023-08-10 16:57:31 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2023-08-16 17:06:40 +0000
commitbc7829212d153aeff69b439d08e2e3001ef88ba3 (patch)
treedbd5b697523d2fe44889d386bd07de89d5b4dad4 /sysutils/cpu-microcode-amd
parent9d00475d7caec16d27114ff4791ef78fd745f480 (diff)
downloadports-bc7829212d153aeff69b439d08e2e3001ef88ba3.tar.gz
ports-bc7829212d153aeff69b439d08e2e3001ef88ba3.zip
sysutils/cpu-microcode-*: Reorganize CPU microcode ports
Prior to this update, sysutils/devcpu-data, which only contained an RC script, had run dependencies on the AMD and Intel microcode ports. This made it cumbersome to have just the AMD or just the Intel microcode ports installed. With this change, the microcode ports now depend on the RC script. Other changes: - Use more intuitive port names: cpu-microcode, cpu-microcode-amd, cpu-microcode-intel, and cpu-microcode-rc. - Add the metaport, cpu-microcode, which pulls in all related ports. - Pet portclippy/portfmt Reviewed by: lwhsu, markj Approved by: sbruno (maintainer) Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D41406
Diffstat (limited to 'sysutils/cpu-microcode-amd')
-rw-r--r--sysutils/cpu-microcode-amd/Makefile44
-rw-r--r--sysutils/cpu-microcode-amd/distinfo11
-rw-r--r--sysutils/cpu-microcode-amd/files/LICENSE.amd-ucode64
-rw-r--r--sysutils/cpu-microcode-amd/pkg-descr4
-rw-r--r--sysutils/cpu-microcode-amd/pkg-message8
5 files changed, 131 insertions, 0 deletions
diff --git a/sysutils/cpu-microcode-amd/Makefile b/sysutils/cpu-microcode-amd/Makefile
new file mode 100644
index 000000000000..6c9cf47fb999
--- /dev/null
+++ b/sysutils/cpu-microcode-amd/Makefile
@@ -0,0 +1,44 @@
+PORTNAME= microcode
+PORTVERSION= 20230724
+CATEGORIES= sysutils
+MASTER_SITES= https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/amd-ucode/
+PKGNAMEPREFIX= cpu-
+PKGNAMESUFFIX= -amd
+DISTFILES= microcode_amd.bin?id=${_REV} \
+ microcode_amd_fam15h.bin?id=${_REV} \
+ microcode_amd_fam16h.bin?id=${_REV} \
+ microcode_amd_fam17h.bin?id=${_REV} \
+ microcode_amd_fam19h.bin?id=${_REV}
+DIST_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
+
+MAINTAINER= sbruno@FreeBSD.org
+COMMENT= AMD CPU microcode updates
+
+LICENSE= EULA
+LICENSE_NAME= Advanced Micro Devices License Agreement
+LICENSE_FILE= ${FILESDIR}/LICENSE.amd-ucode
+LICENSE_PERMS= dist-mirror no-dist-sell pkg-mirror no-pkg-sell auto-accept
+
+ONLY_FOR_ARCHS= amd64 i386
+
+RUN_DEPENDS= ${LOCALBASE}/etc/rc.d/microcode_update:sysutils/cpu-microcode-rc
+
+DATADIR= ${PREFIX}/share/cpucontrol
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS= # empty
+EXTRACT_AFTER_ARGS= .
+NO_ARCH= yes
+NO_BUILD= yes
+
+NO_WRKSUBDIR= yes
+PLIST_FILES= ${DISTFILES:S/^/${DATADIR}\//g:C/\?.*//}
+
+_REV= 0bc3126c9cfa0b8c761483215c25382f831a7c6f
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+.for f in ${DISTFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DATADIR}/${f:C/\?.*//}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/sysutils/cpu-microcode-amd/distinfo b/sysutils/cpu-microcode-amd/distinfo
new file mode 100644
index 000000000000..63bc387788f3
--- /dev/null
+++ b/sysutils/cpu-microcode-amd/distinfo
@@ -0,0 +1,11 @@
+TIMESTAMP = 1691693284
+SHA256 (cpu-microcode-amd/microcode_amd.bin?id=0bc3126c9cfa0b8c761483215c25382f831a7c6f) = 8a9d9e8b788e31e61cddc03cb1eeab5db99e0f667128943ff0780e6437d2e43e
+SIZE (cpu-microcode-amd/microcode_amd.bin?id=0bc3126c9cfa0b8c761483215c25382f831a7c6f) = 12684
+SHA256 (cpu-microcode-amd/microcode_amd_fam15h.bin?id=0bc3126c9cfa0b8c761483215c25382f831a7c6f) = 9d4a668410e72a4bdb86dc23e4261eca04daa83456ada02504115223f356981a
+SIZE (cpu-microcode-amd/microcode_amd_fam15h.bin?id=0bc3126c9cfa0b8c761483215c25382f831a7c6f) = 7876
+SHA256 (cpu-microcode-amd/microcode_amd_fam16h.bin?id=0bc3126c9cfa0b8c761483215c25382f831a7c6f) = e02ad653b39c975d6c52674b50f23727bb6706bab7b4e5b391a4ce229e7ff121
+SIZE (cpu-microcode-amd/microcode_amd_fam16h.bin?id=0bc3126c9cfa0b8c761483215c25382f831a7c6f) = 3510
+SHA256 (cpu-microcode-amd/microcode_amd_fam17h.bin?id=0bc3126c9cfa0b8c761483215c25382f831a7c6f) = 1eeaf4c86fb72a0f0e9d4ff28d3213d264ecb47a8dce8bcbd85addd0cfd999bb
+SIZE (cpu-microcode-amd/microcode_amd_fam17h.bin?id=0bc3126c9cfa0b8c761483215c25382f831a7c6f) = 12924
+SHA256 (cpu-microcode-amd/microcode_amd_fam19h.bin?id=0bc3126c9cfa0b8c761483215c25382f831a7c6f) = 2e503e1381154297e30f7fdc83a639d81b02196ff965f63427652709423fdcc4
+SIZE (cpu-microcode-amd/microcode_amd_fam19h.bin?id=0bc3126c9cfa0b8c761483215c25382f831a7c6f) = 16804
diff --git a/sysutils/cpu-microcode-amd/files/LICENSE.amd-ucode b/sysutils/cpu-microcode-amd/files/LICENSE.amd-ucode
new file mode 100644
index 000000000000..de5b29c4e486
--- /dev/null
+++ b/sysutils/cpu-microcode-amd/files/LICENSE.amd-ucode
@@ -0,0 +1,64 @@
+Copyright (C) 2010-2018 Advanced Micro Devices, Inc., All rights reserved.
+
+Permission is hereby granted by Advanced Micro Devices, Inc. ("AMD"),
+free of any license fees, to any person obtaining a copy of this
+microcode in binary form (the "Software") ("You"), to install,
+reproduce, copy and distribute copies of the Software and to permit
+persons to whom the Software is provided to do the same, subject to
+the following terms and conditions. Your use of any portion of the
+Software shall constitute Your acceptance of the following terms and
+conditions. If You do not agree to the following terms and conditions,
+do not use, retain or redistribute any portion of the Software.
+
+If You redistribute this Software, You must reproduce the above
+copyright notice and this license with the Software.
+Without specific, prior, written permission from AMD, You may not
+reference AMD or AMD products in the promotion of any product derived
+from or incorporating this Software in any manner that implies that
+AMD endorses or has certified such product derived from or
+incorporating this Software.
+
+You may not reverse engineer, decompile, or disassemble this Software
+or any portion thereof.
+
+THE SOFTWARE IS PROVIDED "AS IS" WITHOUT ANY EXPRESS OR IMPLIED
+WARRANTY OF ANY KIND, INCLUDING BUT NOT LIMITED TO WARRANTIES OF
+MERCHANTABILITY, NONINFRINGEMENT, TITLE, FITNESS FOR ANY PARTICULAR
+PURPOSE, OR WARRANTIES ARISING FROM CONDUCT, COURSE OF DEALING, OR
+USAGE OF TRADE. IN NO EVENT SHALL AMD OR ITS LICENSORS BE LIABLE FOR
+ANY DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR
+LOSS OF PROFITS, BUSINESS INTERRUPTION, OR LOSS OF DATA OR
+INFORMATION) ARISING OUT OF AMD'S NEGLIGENCE, GROSS NEGLIGENCE, THE
+USE OF OR INABILITY TO USE THE SOFTWARE, EVEN IF AMD HAS BEEN ADVISED
+OF THE POSSIBILITY OF SUCH DAMAGES. BECAUSE SOME JURISDICTIONS
+PROHIBIT THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR
+INCIDENTAL DAMAGES OR THE EXCLUSION OF IMPLIED WARRANTIES, THE ABOVE
+LIMITATION MAY NOT APPLY TO YOU.
+
+Without limiting the foregoing, the Software may implement third party
+technologies for which You must obtain licenses from parties other
+than AMD. You agree that AMD has not obtained or conveyed to You, and
+that You shall be responsible for obtaining the rights to use and/or
+distribute the applicable underlying intellectual property rights
+related to the third party technologies. These third party
+technologies are not licensed hereunder.
+
+If You use the Software (in whole or in part), You shall adhere to all
+applicable U.S., European, and other export laws, including but not
+limited to the U.S. Export Administration Regulations ("EAR"), (15
+C.F.R. Sections 730 through 774), and E.U. Council Regulation (EC) No
+1334/2000 of 22 June 2000. Further, pursuant to Section 740.6 of the
+EAR, You hereby certify that, except pursuant to a license granted by
+the United States Department of Commerce Bureau of Industry and
+Security or as otherwise permitted pursuant to a License Exception
+under the U.S. Export Administration Regulations ("EAR"), You will not
+(1) export, re-export or release to a national of a country in Country
+Groups D:1, E:1 or E:2 any restricted technology, software, or source
+code You receive hereunder, or (2) export to Country Groups D:1, E:1
+or E:2 the direct product of such technology or software, if such
+foreign produced direct product is subject to national security
+controls as identified on the Commerce Control List (currently found
+in Supplement 1 to Part 774 of EAR). For the most current Country
+Group listings, or for additional information about the EAR or Your
+obligations under those regulations, please refer to the U.S. Bureau
+of Industry and Security?s website at ttp://www.bis.doc.gov/.
diff --git a/sysutils/cpu-microcode-amd/pkg-descr b/sysutils/cpu-microcode-amd/pkg-descr
new file mode 100644
index 000000000000..54659a1e1b75
--- /dev/null
+++ b/sysutils/cpu-microcode-amd/pkg-descr
@@ -0,0 +1,4 @@
+Processor microcode updates provide bug fixes, which can be critical to
+the security and stability of your system. This port uses the cpuctl(4)
+microcode update facility to keep your AMD processor's firmware
+up-to-date.
diff --git a/sysutils/cpu-microcode-amd/pkg-message b/sysutils/cpu-microcode-amd/pkg-message
new file mode 100644
index 000000000000..a7d69e95a216
--- /dev/null
+++ b/sysutils/cpu-microcode-amd/pkg-message
@@ -0,0 +1,8 @@
+[
+{ type: install
+ message: <<EOM
+Refer to the cpu-microcode-rc installation notes to enable AMD microcode
+updates.
+EOM
+}
+]