aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cpuid
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2016-11-28 12:26:10 +0000
committerThomas Zander <riggs@FreeBSD.org>2016-11-28 12:26:10 +0000
commitcbfcf30d709356482ff6ea2403aadf92b11e550f (patch)
tree77b1332e726d62f36c09f9a9c6efe53beeb1fc6c /sysutils/cpuid
parent4455069c3ab8d7709fc78ce3c028a4c71f4ff63a (diff)
downloadports-cbfcf30d709356482ff6ea2403aadf92b11e550f.tar.gz
ports-cbfcf30d709356482ff6ea2403aadf92b11e550f.zip
Update to upstream release as of 20161114
PR: 214865 Submitted by: pkubaj@anongoth.pl (maintainer)
Notes
Notes: svn path=/head/; revision=427299
Diffstat (limited to 'sysutils/cpuid')
-rw-r--r--sysutils/cpuid/Makefile2
-rw-r--r--sysutils/cpuid/distinfo6
-rw-r--r--sysutils/cpuid/files/patch-cpuid.c23
3 files changed, 15 insertions, 16 deletions
diff --git a/sysutils/cpuid/Makefile b/sysutils/cpuid/Makefile
index 7f53fefab7ad..7aae9d0c3367 100644
--- a/sysutils/cpuid/Makefile
+++ b/sysutils/cpuid/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= cpuid
-PORTVERSION= 20160814
+PORTVERSION= 20161114
CATEGORIES= sysutils
MASTER_SITES= http://www.etallen.com/cpuid/
PKGNAMESUFFIX= ${CPUID_SUFFIX}
diff --git a/sysutils/cpuid/distinfo b/sysutils/cpuid/distinfo
index 45b79eacca77..4cf1fc937e5c 100644
--- a/sysutils/cpuid/distinfo
+++ b/sysutils/cpuid/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1476108297
-SHA256 (cpuid-20160814.src.tar.gz) = fd4e2b2d88f417ae32f47a92d29351de395a36578fde8aedc228e2e131f38ecd
-SIZE (cpuid-20160814.src.tar.gz) = 77160
+TIMESTAMP = 1480199308
+SHA256 (cpuid-20161114.src.tar.gz) = 19564f068d0bc1a30d033476da89a9f348fd94b6dbfeae22dab7974514ffc3aa
+SIZE (cpuid-20161114.src.tar.gz) = 78758
diff --git a/sysutils/cpuid/files/patch-cpuid.c b/sysutils/cpuid/files/patch-cpuid.c
index 86af82ba74f0..b190a2978277 100644
--- a/sysutils/cpuid/files/patch-cpuid.c
+++ b/sysutils/cpuid/files/patch-cpuid.c
@@ -1,4 +1,4 @@
---- cpuid.c.orig 2016-08-15 03:54:53 UTC
+--- cpuid.c.orig 2016-11-14 01:57:53 UTC
+++ cpuid.c
@@ -23,6 +23,8 @@
#define USE_KERNEL_SCHED_SETAFFINITY
@@ -18,7 +18,7 @@
#ifdef USE_CPUID_MODULE
#include <linux/major.h>
-@@ -6420,11 +6424,16 @@ real_setup(unsigned int cpu,
+@@ -6471,11 +6475,16 @@ real_setup(unsigned int cpu,
int status;
status = syscall(__NR_sched_setaffinity, 0, sizeof(mask), &mask);
#else
@@ -37,7 +37,7 @@
#endif
if (status == -1) {
if (cpu > 0) {
-@@ -6539,11 +6548,14 @@ static int real_get (int cpuid
+@@ -6590,11 +6599,14 @@ static int real_get (int cpuid
: "a" (reg),
"c" (ecx));
} else {
@@ -55,17 +55,16 @@
if (result == -1) {
if (quiet) {
return FALSE;
-@@ -7050,7 +7062,8 @@ main(int argc,
+@@ -7134,7 +7146,7 @@ main(int argc,
};
- boolean opt_one_cpu = FALSE;
-- boolean opt_inst = FALSE;
-+ //boolean opt_inst = FALSE;
-+ boolean opt_inst = TRUE;
- boolean opt_kernel = FALSE;
- boolean opt_raw = FALSE;
- boolean opt_debug = FALSE;
-@@ -7134,7 +7147,8 @@ main(int argc,
+ boolean opt_one_cpu = FALSE;
+- boolean opt_inst = FALSE;
++ boolean opt_inst = TRUE;
+ boolean opt_kernel = FALSE;
+ boolean opt_raw = FALSE;
+ boolean opt_debug = FALSE;
+@@ -7264,7 +7276,8 @@ main(int argc,
}
// Default to -i. So use inst unless -k is specified.