aboutsummaryrefslogtreecommitdiff
path: root/sysutils/crate
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-08-04 07:21:36 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-08-04 07:21:36 +0000
commit8dc4c9bbfd71f9ea37cf10f6bc07b8761dce5e8d (patch)
treeae4f64bfcb58b7990635830a1d50c87f974896ed /sysutils/crate
parenta6573502adf34d5d09d427372bbfb4b4a4183cec (diff)
downloadports-8dc4c9bbfd71f9ea37cf10f6bc07b8761dce5e8d.tar.gz
ports-8dc4c9bbfd71f9ea37cf10f6bc07b8761dce5e8d.zip
New port: sysutils/crate: Containerizer for FreeBSD
Notes
Notes: svn path=/head/; revision=508065
Diffstat (limited to 'sysutils/crate')
-rw-r--r--sysutils/crate/Makefile33
-rw-r--r--sysutils/crate/distinfo3
-rw-r--r--sysutils/crate/pkg-descr17
3 files changed, 53 insertions, 0 deletions
diff --git a/sysutils/crate/Makefile b/sysutils/crate/Makefile
new file mode 100644
index 000000000000..f4a5c4c79d21
--- /dev/null
+++ b/sysutils/crate/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= crate
+DISTVERSION= 0.1
+CATEGORIES= sysutils
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Containerizer for FreeBSD (alpha-software, expect bugs)
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BROKEN_FreeBSD_11= STL feature 'filesystem' isn't available on 11
+.if defined(PACKAGE_BUILDING)
+BROKEN_FreeBSD_12= STL feature 'filesystem' isn't available in 12.0-RELEASE-p7
+.endif
+
+BUILD_DEPENDS= rang>0:devel/rang
+LIB_DEPENDS= libyaml-cpp.so:devel/yaml-cpp
+
+USES= compiler:c++17-lang pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= yurivict
+
+PLIST_FILES= bin/${PORTNAME} \
+ man/man5/${PORTNAME}.5.gz
+
+OPTIONS_DEFINE= EXAMPLES
+
+EXAMPLES_INSTALL_TARGET= install install-examples
+PORTEXAMPLES= *
+
+.include <bsd.port.mk>
diff --git a/sysutils/crate/distinfo b/sysutils/crate/distinfo
new file mode 100644
index 000000000000..41f0c3b18267
--- /dev/null
+++ b/sysutils/crate/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1564902749
+SHA256 (yurivict-crate-0.1_GH0.tar.gz) = dad83a6f72c7cdd426b32e3b828f0e47d9793c43951fb738e7dd64f916b816f6
+SIZE (yurivict-crate-0.1_GH0.tar.gz) = 30732
diff --git a/sysutils/crate/pkg-descr b/sysutils/crate/pkg-descr
new file mode 100644
index 000000000000..eeacbabf838d
--- /dev/null
+++ b/sysutils/crate/pkg-descr
@@ -0,0 +1,17 @@
+crate is a FreeBSD containerizer utilizing FreeBSD jails.
+
+crate creates application containers based on the description provided by the
+user, and then runs containers as a monolithic processes, with all dependencies
+included in the container.
+
+Containers can be useful in these scenarios:
+* You can keep any version of your application, and it will always run later the
+ same way, regardless of what packages will be installed on your system.
+* You can run a web browser from the crate container, and every time it will run
+ in the clean environment not allowing any tracking.
+* You can run closed source applications, they will be isolated from the rest of
+ your system, and there will be no chance for them seeing your disks.
+
+crate is in its alpha stage. Things might not work as expected!
+
+WWW: https://github.com/yurivict/crate