aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cw
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-04 22:14:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-04 22:14:17 +0000
commitd84d9aa11f9476cad01919508cba3e5fe8a92021 (patch)
treeebdc6ea66e93ddd61662271bebf6e6bf56858551 /sysutils/cw
parent3b45eafeafcea4e0b1120e167f953b5809d51c32 (diff)
downloadports-d84d9aa11f9476cad01919508cba3e5fe8a92021.tar.gz
ports-d84d9aa11f9476cad01919508cba3e5fe8a92021.zip
cw is a non-intrusive real-time ANSI color wrapper for common unix-based
command. cw is designed to simulate the environment of the commands being executed, so that if a person types 'du', 'df', 'ping', etc. in their shell it will automatically color the output in real-time according to a definition file containing the color format desired. cw has support for wildcard match coloring, tokenized coloring, headers/footers, case scenario coloring, command line dependent definition coloring, and includes over 50 pre-made definition files. WWW: http://cwrapper.sourceforge.net/ PR: ports/106291 Submitted by: Dryice Liu <dryice at dryice.name>
Notes
Notes: svn path=/head/; revision=178885
Diffstat (limited to 'sysutils/cw')
-rw-r--r--sysutils/cw/Makefile35
-rw-r--r--sysutils/cw/distinfo3
-rw-r--r--sysutils/cw/files/patch-Makefile.in11
-rw-r--r--sysutils/cw/pkg-descr12
-rw-r--r--sysutils/cw/pkg-plist115
5 files changed, 176 insertions, 0 deletions
diff --git a/sysutils/cw/Makefile b/sysutils/cw/Makefile
new file mode 100644
index 000000000000..a01616da1de0
--- /dev/null
+++ b/sysutils/cw/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: cw
+# Date created: 4 December 2006
+# Whom: Dryice Liu <dryice@dryice.name>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cw
+PORTVERSION= 1.0.14
+CATEGORIES= sysutils
+MASTER_SITES= http://cwrapper.sourceforge.net/ \
+ http://www.fakehalo.us/cw/ \
+ http://dryice.name/computer/FreeBSD/distfiles/
+
+MAINTAINER= dryice@dryice.name
+COMMENT= A non-intrusive color wrapper for common commands
+
+GNU_CONFIGURE= yes
+MAN1= cw.1 cwe.1 cwu.1
+MANCOMPRESSED= yes
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= CHANGES CONTRIB COPYING FILES INSTALL PLATFORM README \
+ VERSION
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/cw/distinfo b/sysutils/cw/distinfo
new file mode 100644
index 000000000000..04d17622e0a9
--- /dev/null
+++ b/sysutils/cw/distinfo
@@ -0,0 +1,3 @@
+MD5 (cw-1.0.14.tar.gz) = 533a9456c595a1d31f5f2478544969a1
+SHA256 (cw-1.0.14.tar.gz) = 768c5fe6097075cf82e396d1d6ff693f68d26f0725711c4015b245172895fd63
+SIZE (cw-1.0.14.tar.gz) = 83715
diff --git a/sysutils/cw/files/patch-Makefile.in b/sysutils/cw/files/patch-Makefile.in
new file mode 100644
index 000000000000..bd9e615ccb12
--- /dev/null
+++ b/sysutils/cw/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Mon Dec 4 11:30:55 2006
++++ Makefile.in Mon Dec 4 11:31:04 2006
+@@ -2,7 +2,7 @@
+ PREFIX=@prefix@
+ BINDIR=${PREFIX}/bin
+ LIBDIR=${PREFIX}/lib
+-MANDIR=@mandir@
++MANDIR=${PREFIX}/man
+ SHELL=@SHELL@
+ CC=@CC@
+ ECHO=echo
diff --git a/sysutils/cw/pkg-descr b/sysutils/cw/pkg-descr
new file mode 100644
index 000000000000..2d66905f8aa9
--- /dev/null
+++ b/sysutils/cw/pkg-descr
@@ -0,0 +1,12 @@
+cw is a non-intrusive real-time ANSI color wrapper for common unix-based
+command.
+
+cw is designed to simulate the environment of the commands being
+executed, so that if a person types 'du', 'df', 'ping', etc. in their
+shell it will automatically color the output in real-time according to
+a definition file containing the color format desired. cw has support
+for wildcard match coloring, tokenized coloring, headers/footers, case
+scenario coloring, command line dependent definition coloring, and
+includes over 50 pre-made definition files.
+
+WWW: http://cwrapper.sourceforge.net/
diff --git a/sysutils/cw/pkg-plist b/sysutils/cw/pkg-plist
new file mode 100644
index 000000000000..d6366d031454
--- /dev/null
+++ b/sysutils/cw/pkg-plist
@@ -0,0 +1,115 @@
+bin/color
+bin/colorcfg
+bin/cw
+bin/cwe
+bin/cwu
+lib/cw/arp
+lib/cw/arping
+lib/cw/blockdev
+lib/cw/cal
+lib/cw/cksum
+lib/cw/clock
+lib/cw/configure
+lib/cw/cpuinfo@
+lib/cw/cw-pipe
+lib/cw/cw-test.cgi
+lib/cw/date
+lib/cw/df
+lib/cw/diff
+lib/cw/dig
+lib/cw/dmesg
+lib/cw/du
+lib/cw/env
+lib/cw/etc/1line-blu.ftr
+lib/cw/etc/1line-blu.hdr
+lib/cw/etc/1line-cyn.ftr
+lib/cw/etc/1line-cyn.hdr
+lib/cw/etc/1line-grn.ftr
+lib/cw/etc/1line-grn.hdr
+lib/cw/etc/1line-gry.ftr
+lib/cw/etc/1line-gry.hdr
+lib/cw/etc/1line-grydash.ftr
+lib/cw/etc/1line-grydash.hdr
+lib/cw/etc/1line-gryfade.ftr
+lib/cw/etc/1line-gryfade.hdr
+lib/cw/etc/1line-prp.ftr
+lib/cw/etc/1line-prp.hdr
+lib/cw/etc/1line-red.ftr
+lib/cw/etc/1line-red.hdr
+lib/cw/etc/1line-ylw.ftr
+lib/cw/etc/1line-ylw.hdr
+lib/cw/etc/README
+lib/cw/etc/bendingbars.ftr
+lib/cw/etc/bendingbars.hdr
+lib/cw/etc/chrome.ftr
+lib/cw/etc/chrome.hdr
+lib/cw/etc/goop-cyngrn.ftr
+lib/cw/etc/goop-cyngrn.hdr
+lib/cw/etc/goop-redprp.ftr
+lib/cw/etc/goop-redprp.hdr
+lib/cw/figlet
+lib/cw/file
+lib/cw/find
+lib/cw/finger
+lib/cw/free
+lib/cw/fstab@
+lib/cw/fuser
+lib/cw/g++
+lib/cw/gcc
+lib/cw/group@
+lib/cw/groups
+lib/cw/hdparm
+lib/cw/hexdump
+lib/cw/host
+lib/cw/id
+lib/cw/ifconfig
+lib/cw/iptables
+lib/cw/last
+lib/cw/lastlog
+lib/cw/lsattr
+lib/cw/lsmod
+lib/cw/lsof
+lib/cw/make
+lib/cw/md5sum
+lib/cw/meminfo@
+lib/cw/messages@
+lib/cw/mount
+lib/cw/mpg123
+lib/cw/netstat
+lib/cw/nfsstat
+lib/cw/nmap
+lib/cw/nslookup
+lib/cw/passwd@
+lib/cw/ping
+lib/cw/pmap
+lib/cw/pmap_dump
+lib/cw/praliases
+lib/cw/ps
+lib/cw/pstree
+lib/cw/quota
+lib/cw/quotastats
+lib/cw/route
+lib/cw/routel
+lib/cw/sdiff
+lib/cw/services@
+lib/cw/showmount
+lib/cw/smbstatus
+lib/cw/stat
+lib/cw/sysctl
+lib/cw/syslog
+lib/cw/tar
+lib/cw/tcpdump
+lib/cw/tracepath
+lib/cw/traceroute
+lib/cw/umount
+lib/cw/uname
+lib/cw/uptime
+lib/cw/users
+lib/cw/vmstat
+lib/cw/w
+lib/cw/wc
+lib/cw/whereis
+lib/cw/who
+lib/cw/xferlog@
+@dirrm lib/cw/etc
+@dirrm lib/cw