aboutsummaryrefslogtreecommitdiff
path: root/sysutils/daemontools
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2016-05-03 18:27:04 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2016-05-03 18:27:04 +0000
commit1bffea19a2d38780fa2b689435cd6789466664f9 (patch)
tree2526573c99e7d1d6dac0b6e8c64e889a66ef3614 /sysutils/daemontools
parent2b569b9b460ff2783d1de8739e9380cc83de3ed5 (diff)
downloadports-1bffea19a2d38780fa2b689435cd6789466664f9.tar.gz
ports-1bffea19a2d38780fa2b689435cd6789466664f9.zip
rc.d/svscan: Use -f to daemon(8) again.
- This reverts the change from r247267 which removed it. - The upstream svscanboot script closes stdout, stdin and stderr. Our script should do the same. Doing this does not lose any output since the output is all piped to the proper logger. This fixes hangs when combined with Salt [1]. Reported by: C. R. Oldham <cro@ncbt.org> [1]
Notes
Notes: svn path=/head/; revision=414546
Diffstat (limited to 'sysutils/daemontools')
-rw-r--r--sysutils/daemontools/Makefile2
-rw-r--r--sysutils/daemontools/files/svscan.in6
2 files changed, 4 insertions, 4 deletions
diff --git a/sysutils/daemontools/Makefile b/sysutils/daemontools/Makefile
index 82040c303223..290d126d3dc8 100644
--- a/sysutils/daemontools/Makefile
+++ b/sysutils/daemontools/Makefile
@@ -3,7 +3,7 @@
PORTNAME= daemontools
PORTVERSION= 0.76
-PORTREVISION= 17
+PORTREVISION= 18
CATEGORIES= sysutils
MASTER_SITES= http://cr.yp.to/daemontools/ \
http://mirror.shatow.net/freebsd/${PORTNAME}/:DEFAULT,1 \
diff --git a/sysutils/daemontools/files/svscan.in b/sysutils/daemontools/files/svscan.in
index ef52adca8b71..d0078e4ed2cd 100644
--- a/sysutils/daemontools/files/svscan.in
+++ b/sysutils/daemontools/files/svscan.in
@@ -86,12 +86,12 @@ svscan_start () {
EP="/usr/bin/env \
PATH=%%PREFIX%%/sbin:%%PREFIX%%/bin:/usr/sbin:/usr/bin:/sbin:/bin"
if [ -z "${svscan_logdir}" ]; then
- ${EP} /usr/sbin/daemon /bin/sh -c "$command $svscan_servicedir 2>&1 | %%PREFIX%%/bin/readproctitle service errors: ................................................................................................................................................................................................................................................................................................................................................................................................................ &" > /dev/null
+ ${EP} /usr/sbin/daemon -f /bin/sh -c "$command $svscan_servicedir 2>&1 | %%PREFIX%%/bin/readproctitle service errors: ................................................................................................................................................................................................................................................................................................................................................................................................................ &"
else
logmax=${svscan_logmax+s$svscan_logmax}
lognum=${svscan_lognum+n$svscan_lognum}
- ${EP} /usr/sbin/daemon /bin/sh -c "$command $svscan_servicedir 2>&1 \
- | %%PREFIX%%/bin/multilog t $logmax $lognum '${svscan_logdir}' &" > /dev/null
+ ${EP} /usr/sbin/daemon -f /bin/sh -c "$command $svscan_servicedir 2>&1 \
+ | %%PREFIX%%/bin/multilog t $logmax $lognum '${svscan_logdir}' &"
fi
}