aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dc3dd
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2018-06-24 15:55:52 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2018-06-24 15:55:52 +0000
commit0a6d455ed530f5817bd58de0d1518a8a02b9c5d2 (patch)
treec228e30917d18e8b283bb826ddcb6b898f77c387 /sysutils/dc3dd
parent14004d4f892b378cfd5a124b61a21c0f6c6e7253 (diff)
downloadports-0a6d455ed530f5817bd58de0d1518a8a02b9c5d2.tar.gz
ports-0a6d455ed530f5817bd58de0d1518a8a02b9c5d2.zip
- Update to 7.2.646.
- Regenerate patches with make makepatch.
Notes
Notes: svn path=/head/; revision=473205
Diffstat (limited to 'sysutils/dc3dd')
-rw-r--r--sysutils/dc3dd/Makefile10
-rw-r--r--sysutils/dc3dd/distinfo5
-rw-r--r--sysutils/dc3dd/files/patch-lib_Makefile.in6
-rw-r--r--sysutils/dc3dd/files/patch-src_dc3dd.c10
4 files changed, 17 insertions, 14 deletions
diff --git a/sysutils/dc3dd/Makefile b/sysutils/dc3dd/Makefile
index 0d52555b80e1..77365c3a9eaa 100644
--- a/sysutils/dc3dd/Makefile
+++ b/sysutils/dc3dd/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= dc3dd
-PORTVERSION= 7.2.641
-PORTREVISION= 1
+PORTVERSION= 7.2.646
CATEGORIES= sysutils
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/7.2
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/${PORTNAME}%20${PORTVERSION}
MAINTAINER= nobutaka@FreeBSD.org
COMMENT= dd program useful for computer forensics
@@ -16,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_armv6= fails to compile: bit-field 'verify_error_if_negative_size__' has negative width
BROKEN_armv7= fails to compile: bit-field 'verify_error_if_negative_size__' has negative width
-USES= gettext iconv gmake tar:bzip2
+USES= gettext iconv gmake zip
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
@@ -32,4 +31,7 @@ CONFIGURE_ARGS= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+pre-configure:
+ ${CHMOD} +x ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/sysutils/dc3dd/distinfo b/sysutils/dc3dd/distinfo
index 710cc58251e8..213bba678ad2 100644
--- a/sysutils/dc3dd/distinfo
+++ b/sysutils/dc3dd/distinfo
@@ -1,2 +1,3 @@
-SHA256 (dc3dd-7.2.641.tar.bz2) = b6141ab8a51f1edc0c594616da7407a335248244d500be883349cb355a2e426a
-SIZE (dc3dd-7.2.641.tar.bz2) = 2917810
+TIMESTAMP = 1529848598
+SHA256 (dc3dd-7.2.646.zip) = c4e325e5cbdae49e3855b0849ea62fed17d553428724745cea53fe6d91fd2b7f
+SIZE (dc3dd-7.2.646.zip) = 5066316
diff --git a/sysutils/dc3dd/files/patch-lib_Makefile.in b/sysutils/dc3dd/files/patch-lib_Makefile.in
index b226689be8be..e79a149bf071 100644
--- a/sysutils/dc3dd/files/patch-lib_Makefile.in
+++ b/sysutils/dc3dd/files/patch-lib_Makefile.in
@@ -1,6 +1,6 @@
---- lib/Makefile.in.orig 2011-02-14 00:45:49.000000000 +0900
-+++ lib/Makefile.in 2011-02-14 00:50:19.000000000 +0900
-@@ -1629,18 +1629,6 @@
+--- lib/Makefile.in.orig 2012-11-06 03:52:20 UTC
++++ lib/Makefile.in
+@@ -1629,18 +1629,6 @@ inttypes.h: inttypes.in.h
all-local: charset.alias ref-add.sed ref-del.sed
install-exec-local: all-local
diff --git a/sysutils/dc3dd/files/patch-src_dc3dd.c b/sysutils/dc3dd/files/patch-src_dc3dd.c
index ddcf0382e881..acc81ca02160 100644
--- a/sysutils/dc3dd/files/patch-src_dc3dd.c
+++ b/sysutils/dc3dd/files/patch-src_dc3dd.c
@@ -1,15 +1,15 @@
---- src/dc3dd.c.orig 2011-02-14 00:17:13.000000000 +0900
-+++ src/dc3dd.c 2011-02-14 00:22:11.000000000 +0900
+--- src/dc3dd.c.orig 2012-12-02 23:29:48 UTC
++++ src/dc3dd.c
@@ -45,7 +45,7 @@
- #include <linux/types.h>
- #include "hdparm/hpa_dco.h"
+ #include <linux/types.h>
+ #include "hdparm/hpa_dco.h"
#endif
-#elif defined (__APPLE__)
+#elif defined (__APPLE__) || defined (__FreeBSD__)
#include <sys/disk.h>
#include <sys/ioctl.h>
#elif defined (__CYGWIN__)
-@@ -2325,6 +2325,56 @@
+@@ -2501,6 +2501,56 @@ get_file_stats(file_t* file)
}
}