aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dd_rescue
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2022-07-30 09:57:50 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2022-07-30 09:58:27 +0000
commit820c62d33ed405f98169307ddb92aa7436585d24 (patch)
treec3b00f1c558a3d508955038a03deb22b9ce9cfbd /sysutils/dd_rescue
parentdc56fccb09db7ddeaaaf1202eaf2a95832853134 (diff)
downloadports-820c62d33ed405f98169307ddb92aa7436585d24.tar.gz
ports-820c62d33ed405f98169307ddb92aa7436585d24.zip
sysutils/dd_rescue: Update to 1.99.12
Diffstat (limited to 'sysutils/dd_rescue')
-rw-r--r--sysutils/dd_rescue/Makefile3
-rw-r--r--sysutils/dd_rescue/distinfo6
-rw-r--r--sysutils/dd_rescue/files/patch-Makefile14
-rw-r--r--sysutils/dd_rescue/files/patch-aes__c.c11
-rw-r--r--sysutils/dd_rescue/files/patch-dd_rescue.c6
-rw-r--r--sysutils/dd_rescue/files/patch-find_nonzero_sse2.c6
-rw-r--r--sysutils/dd_rescue/files/patch-libddr_crypt.c4
-rw-r--r--sysutils/dd_rescue/files/patch-libddr_hash.c8
-rw-r--r--sysutils/dd_rescue/files/patch-libddr_lzo.c13
-rw-r--r--sysutils/dd_rescue/files/patch-pbkdf_ossl.c6
-rw-r--r--sysutils/dd_rescue/files/patch-random.c8
11 files changed, 53 insertions, 32 deletions
diff --git a/sysutils/dd_rescue/Makefile b/sysutils/dd_rescue/Makefile
index a828bbb074f0..565f3dcd0edf 100644
--- a/sysutils/dd_rescue/Makefile
+++ b/sysutils/dd_rescue/Makefile
@@ -1,5 +1,5 @@
PORTNAME= dd_rescue
-PORTVERSION= 1.99.11
+PORTVERSION= 1.99.12
CATEGORIES= sysutils
MASTER_SITES= http://www.garloff.de/kurt/linux/ddrescue/ \
http://fossies.org/unix/privat/
@@ -22,6 +22,7 @@ GNU_CONFIGURE= yes
ALL_TARGET= default
MAKE_ARGS= EXTRA_LDFLAGS=-L${LOCALBASE}/lib
CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= DOCS
diff --git a/sysutils/dd_rescue/distinfo b/sysutils/dd_rescue/distinfo
index f562eaeb3afe..f8764c73cf70 100644
--- a/sysutils/dd_rescue/distinfo
+++ b/sysutils/dd_rescue/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1620114532
-SHA256 (dd_rescue-1.99.11.tar.bz2) = 84c780919b971459e6fb18775ee097a41fc3dbdcb5aab8332e71e83a03ec645f
-SIZE (dd_rescue-1.99.11.tar.bz2) = 181927
+TIMESTAMP = 1659154970
+SHA256 (dd_rescue-1.99.12.tar.bz2) = f304750aecf2b04a4798b26373a66483cf075e0a8e4619e78dc307e8f794c895
+SIZE (dd_rescue-1.99.12.tar.bz2) = 181798
diff --git a/sysutils/dd_rescue/files/patch-Makefile b/sysutils/dd_rescue/files/patch-Makefile
index e1773aaec5dd..11fba0d58a69 100644
--- a/sysutils/dd_rescue/files/patch-Makefile
+++ b/sysutils/dd_rescue/files/patch-Makefile
@@ -1,8 +1,8 @@
---- Makefile.orig 2021-04-29 08:31:32 UTC
+--- Makefile.orig 2022-07-26 13:31:58 UTC
+++ Makefile
-@@ -7,11 +7,7 @@ VERSION = 1.99.11
+@@ -7,11 +7,7 @@ VERSION = 1.99.12
DESTDIR =
- SRCDIR = .
+ SRCDIR ?= .
-CC = gcc
-SHELL = /bin/bash
@@ -13,7 +13,7 @@
INSTALL ?= install
INSTALLFLAGS = -s
prefix = $(DESTDIR)/usr
-@@ -36,7 +32,7 @@ LIB = lib
+@@ -39,7 +35,7 @@ LIB = lib
LIBDIR = /usr/$(LIB)
COMPILER = $(shell $(CC) --version | head -n1)
ID = $(shell git describe --tags || cat REL-ID)
@@ -22,7 +22,7 @@
OUT = -o dd_rescue
PIC = -fPIC
PIE = -fPIE
-@@ -71,19 +67,13 @@ else
+@@ -74,19 +70,13 @@ else
HAVE_XATTR=0
endif
@@ -43,7 +43,7 @@
ISX86 := 1
LIB = lib64
endif
-@@ -289,7 +279,7 @@ libddr_MD5.so: libddr_hash.so
+@@ -292,7 +282,7 @@ libddr_MD5.so: libddr_hash.so
ln -sf $< $@
libddr_lzo.so: libddr_lzo.po
@@ -52,7 +52,7 @@
libddr_null.so: libddr_null.po
$(CC) -shared -o $@ $^
-@@ -360,7 +350,7 @@ libfalloc-static: $(SRCDIR)/dd_rescue.c $(DDR_HEADERS)
+@@ -363,7 +353,7 @@ libfalloc-static: $(SRCDIR)/dd_rescue.c $(DDR_HEADERS)
# This is the default built
dd_rescue: $(SRCDIR)/dd_rescue.c $(DDR_HEADERS) $(OBJECTS) $(OBJECTS2)
diff --git a/sysutils/dd_rescue/files/patch-aes__c.c b/sysutils/dd_rescue/files/patch-aes__c.c
new file mode 100644
index 000000000000..6943abda15cd
--- /dev/null
+++ b/sysutils/dd_rescue/files/patch-aes__c.c
@@ -0,0 +1,11 @@
+--- aes_c.c.orig 2022-07-30 04:37:00 UTC
++++ aes_c.c
+@@ -32,8 +32,6 @@
+
+ #include <string.h>
+ #include <assert.h>
+-#include <byteswap.h>
+-#include <endian.h>
+
+ typedef unsigned char u8;
+ typedef unsigned short u16;
diff --git a/sysutils/dd_rescue/files/patch-dd_rescue.c b/sysutils/dd_rescue/files/patch-dd_rescue.c
index 40c916eddfbc..7508cb37bd3d 100644
--- a/sysutils/dd_rescue/files/patch-dd_rescue.c
+++ b/sysutils/dd_rescue/files/patch-dd_rescue.c
@@ -1,4 +1,4 @@
---- dd_rescue.c.orig 2021-03-07 06:46:37 UTC
+--- dd_rescue.c.orig 2022-01-09 17:27:45 UTC
+++ dd_rescue.c
@@ -116,6 +116,7 @@
#include "list.h"
@@ -8,7 +8,7 @@
#include "fstrim.h"
-@@ -2725,7 +2726,9 @@ int is_filename(char* arg)
+@@ -2728,7 +2729,9 @@ int is_filename(char* arg)
const char* retstrdupcat3(const char* dir, char dirsep, const char* inm)
{
@@ -19,7 +19,7 @@
const int dlen = strlen(dir) + (dirsep>0? 1: dirsep);
char* ret = (char*)malloc(dlen + strlen(inm) + 1);
strcpy(ret, dir);
-@@ -2744,7 +2747,9 @@ const char* dirappfile(const char* onm, opt_t *op)
+@@ -2747,7 +2750,9 @@ const char* dirappfile(const char* onm, opt_t *op)
{
size_t oln = strlen(onm);
if (!strcmp(onm, ".")) {
diff --git a/sysutils/dd_rescue/files/patch-find_nonzero_sse2.c b/sysutils/dd_rescue/files/patch-find_nonzero_sse2.c
index 7c0d1239f851..3cac732ffe6a 100644
--- a/sysutils/dd_rescue/files/patch-find_nonzero_sse2.c
+++ b/sysutils/dd_rescue/files/patch-find_nonzero_sse2.c
@@ -1,4 +1,4 @@
---- find_nonzero_sse2.c.orig 2016-12-28 21:17:50 UTC
+--- find_nonzero_sse2.c.orig 2022-07-25 15:45:07 UTC
+++ find_nonzero_sse2.c
@@ -5,6 +5,7 @@
*/
@@ -6,5 +6,5 @@
#include "find_nonzero.h"
+#include "ffs.h"
- #if defined(__SSE2__)
- #include <emmintrin.h>
+ #if defined(__x86_64__) || defined(__i386__) || defined(__i486__) || defined(__i586__) || defined(__i686__)
+
diff --git a/sysutils/dd_rescue/files/patch-libddr_crypt.c b/sysutils/dd_rescue/files/patch-libddr_crypt.c
index f08f98550c61..e42e60a71a17 100644
--- a/sysutils/dd_rescue/files/patch-libddr_crypt.c
+++ b/sysutils/dd_rescue/files/patch-libddr_crypt.c
@@ -1,4 +1,4 @@
---- libddr_crypt.c.orig 2017-12-03 21:58:24 UTC
+--- libddr_crypt.c.orig 2022-07-26 10:06:31 UTC
+++ libddr_crypt.c
@@ -44,7 +44,7 @@
#include <unistd.h>
@@ -8,4 +8,4 @@
+#include <machine/endian.h>
#include <signal.h>
- #ifdef HAVE_ATTR_XATTR_H
+ #ifdef HAVE_SYS_XATTR_H
diff --git a/sysutils/dd_rescue/files/patch-libddr_hash.c b/sysutils/dd_rescue/files/patch-libddr_hash.c
index eb283c21f36e..7af72697ad67 100644
--- a/sysutils/dd_rescue/files/patch-libddr_hash.c
+++ b/sysutils/dd_rescue/files/patch-libddr_hash.c
@@ -1,11 +1,11 @@
---- libddr_hash.c.orig 2017-08-25 15:14:33 UTC
+--- libddr_hash.c.orig 2021-04-14 08:23:02 UTC
+++ libddr_hash.c
-@@ -34,7 +34,7 @@
+@@ -35,7 +35,7 @@
#include <fcntl.h>
#include <netinet/in.h> /* For ntohl/htonl */
-#include <endian.h>
+#include <machine/endian.h>
- #ifdef HAVE_ATTR_XATTR_H
- #include <attr/xattr.h>
+ #ifdef HAVE_SYS_XATTR_H
+ #include <sys/xattr.h>
diff --git a/sysutils/dd_rescue/files/patch-libddr_lzo.c b/sysutils/dd_rescue/files/patch-libddr_lzo.c
index 00f28dca875f..8bb24e9bae34 100644
--- a/sysutils/dd_rescue/files/patch-libddr_lzo.c
+++ b/sysutils/dd_rescue/files/patch-libddr_lzo.c
@@ -1,6 +1,15 @@
---- libddr_lzo.c.orig 2017-11-04 09:14:24 UTC
+--- libddr_lzo.c.orig 2022-07-26 13:53:37 UTC
+++ libddr_lzo.c
-@@ -46,6 +46,7 @@
+@@ -13,6 +13,8 @@
+ #define _LARGEFILE64_SOURCE 1
+ #define _FILE_OFFSET_BITS 64
+
++#include "config.h"
++
+ #include "ddr_plugin.h"
+ #include "ddr_ctrl.h"
+
+@@ -48,6 +50,7 @@
#error __WORDSIZE unknown
#endif
diff --git a/sysutils/dd_rescue/files/patch-pbkdf_ossl.c b/sysutils/dd_rescue/files/patch-pbkdf_ossl.c
index 99719786058b..18f9ff5cd595 100644
--- a/sysutils/dd_rescue/files/patch-pbkdf_ossl.c
+++ b/sysutils/dd_rescue/files/patch-pbkdf_ossl.c
@@ -1,7 +1,7 @@
---- pbkdf_ossl.c.orig 2017-11-04 09:03:51 UTC
+--- pbkdf_ossl.c.orig 2021-04-14 08:23:02 UTC
+++ pbkdf_ossl.c
-@@ -11,7 +11,7 @@
- #include "md5.h"
+@@ -12,7 +12,7 @@
+ #include "secmem.h"
#include <stdlib.h>
#include <assert.h>
-#include <endian.h>
diff --git a/sysutils/dd_rescue/files/patch-random.c b/sysutils/dd_rescue/files/patch-random.c
index e2a830f9b41c..e20ccfd66b9d 100644
--- a/sysutils/dd_rescue/files/patch-random.c
+++ b/sysutils/dd_rescue/files/patch-random.c
@@ -1,8 +1,8 @@
---- random.c.orig 2015-09-10 15:51:08 UTC
+--- random.c.orig 2022-07-25 15:45:07 UTC
+++ random.c
-@@ -22,6 +22,9 @@ typedef unsigned int __u32;
- #ifdef HAVE_LINUX_RANDOM_H
- #include <linux/random.h>
+@@ -28,6 +28,9 @@ typedef unsigned int __u32;
+ #endif
+ #include <sys/random.h>
#endif
+#ifdef __FreeBSD__
+#include <sys/random.h>