aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dd_rescue
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2012-06-02 13:33:49 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2012-06-02 13:33:49 +0000
commit9b8a7f2433438f94be3936d4091ff49ec3dd05a3 (patch)
tree9c67e951bb4793dc7690a87a998e19ff9b3d8e80 /sysutils/dd_rescue
parent6c27ba89eb3eb1dc31e23cc0afcbd96dcd8a052c (diff)
downloadports-9b8a7f2433438f94be3936d4091ff49ec3dd05a3.tar.gz
ports-9b8a7f2433438f94be3936d4091ff49ec3dd05a3.zip
Update to 1.28.
Notes
Notes: svn path=/head/; revision=298022
Diffstat (limited to 'sysutils/dd_rescue')
-rw-r--r--sysutils/dd_rescue/Makefile2
-rw-r--r--sysutils/dd_rescue/distinfo4
-rw-r--r--sysutils/dd_rescue/files/patch-dd_rescue.c12
3 files changed, 11 insertions, 7 deletions
diff --git a/sysutils/dd_rescue/Makefile b/sysutils/dd_rescue/Makefile
index a12b10bc5ac3..f6f37a228997 100644
--- a/sysutils/dd_rescue/Makefile
+++ b/sysutils/dd_rescue/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dd_rescue
-PORTVERSION= 1.25
+PORTVERSION= 1.28
CATEGORIES= sysutils
MASTER_SITES= http://www.garloff.de/kurt/linux/ddrescue/
diff --git a/sysutils/dd_rescue/distinfo b/sysutils/dd_rescue/distinfo
index c1bcf8e0ece2..aedaaa485a7a 100644
--- a/sysutils/dd_rescue/distinfo
+++ b/sysutils/dd_rescue/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dd_rescue-1.25.tar.gz) = 22a2b030868c6e0639240df590a0c8483fda9ad1c01c5e6a0f7f188271c02585
-SIZE (dd_rescue-1.25.tar.gz) = 21794
+SHA256 (dd_rescue-1.28.tar.gz) = 4adcc368a1d4ad62577eaf8609809be1678335d54ef565a5a0fa6e1210489f03
+SIZE (dd_rescue-1.28.tar.gz) = 22093
diff --git a/sysutils/dd_rescue/files/patch-dd_rescue.c b/sysutils/dd_rescue/files/patch-dd_rescue.c
index 1f8493fa4232..3d619647b7a4 100644
--- a/sysutils/dd_rescue/files/patch-dd_rescue.c
+++ b/sysutils/dd_rescue/files/patch-dd_rescue.c
@@ -1,12 +1,16 @@
---- dd_rescue.c.orig Sun Mar 18 07:29:10 2007
-+++ dd_rescue.c
-@@ -742,7 +742,8 @@
+--- dd_rescue.c.orig 2012-05-20 05:46:14.000000000 +0900
++++ dd_rescue.c 2012-06-02 22:24:44.000000000 +0900
+@@ -1194,11 +1194,11 @@
ipos = 0;
#ifdef O_DIRECT
-- if (posix_memalign(mp, sysconf(_SC_PAGESIZE), softbs)) {
+- if (posix_memalign(&mp, pagesize, softbs)) {
+ buf = malloc(softbs);
+ if (!buf) {
fplog(stderr, "dd_rescue: (fatal): allocation of aligned buffer failed!\n");
cleanup(); exit(18);
}
+- buf = mp;
+ #else
+ buf = malloc(softbs);
+ if (!buf) {