aboutsummaryrefslogtreecommitdiff
path: root/sysutils/debhelper
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-06-26 08:43:14 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-06-26 08:43:14 +0000
commit45a3920a5e6028e1916416c07bc8fb369e244e90 (patch)
treeb2a2fd156fff774605ae34cf87524339b4ed6002 /sysutils/debhelper
parentfd0ced9c73f6c576bf77dd0029bc94dbce1dc11c (diff)
downloadports-45a3920a5e6028e1916416c07bc8fb369e244e90.tar.gz
ports-45a3920a5e6028e1916416c07bc8fb369e244e90.zip
Handle HIGHEST_STABLE_COMPAT_LEVEL correctly without dpkg-parsechangelog
- Bump PORTREVISION for package change
Notes
Notes: svn path=/head/; revision=540434
Diffstat (limited to 'sysutils/debhelper')
-rw-r--r--sysutils/debhelper/Makefile3
-rw-r--r--sysutils/debhelper/files/patch-Makefile16
2 files changed, 15 insertions, 4 deletions
diff --git a/sysutils/debhelper/Makefile b/sysutils/debhelper/Makefile
index 01c31a78024e..78c80abc5d33 100644
--- a/sysutils/debhelper/Makefile
+++ b/sysutils/debhelper/Makefile
@@ -3,6 +3,7 @@
PORTNAME= debhelper
PORTVERSION= 13.1
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= DEBIAN
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -15,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/GPL
USES= gmake perl5 shebangfix tar:xz
-MAKE_ARGS= PREFIX=${PREFIX} SITE_PERL=${PREFIX}/${SITE_PERL_REL}
+MAKE_ARGS= PREFIX=${PREFIX} SITE_PERL=${PREFIX}/${SITE_PERL_REL} VERSION=${PORTVERSION}
NO_ARCH= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/sysutils/debhelper/files/patch-Makefile b/sysutils/debhelper/files/patch-Makefile
index 3ddb91e28f05..aeabad0a5082 100644
--- a/sysutils/debhelper/files/patch-Makefile
+++ b/sysutils/debhelper/files/patch-Makefile
@@ -9,7 +9,16 @@
MANPAGES=$(COMMANDS:=.1) dh.1
# Find deprecated commands by looking at their synopsis.
-@@ -118,23 +118,22 @@ endif
+@@ -16,7 +16,7 @@ else
+ endif
+
+ # Figure out the `current debhelper version.
+-VERSION=$(shell dpkg-parsechangelog -SVersion)
++#VERSION=$(shell dpkg-parsechangelog -SVersion)
+
+ # This generates a list of synopses of debhelper commands, and substitutes
+ # it in to the #LIST# line on the man page fed to it on stdin. Must be passed
+@@ -118,23 +118,21 @@ endif
done;
install:
@@ -31,8 +40,9 @@
- sed -i '/$$prefix=/s@/usr@$(PREFIX)@g' $(DESTDIR)$(PERLLIBDIR)/Dh_Lib.pm
+ sed -i '' '/$$prefix=/s@/usr@$(PREFIX)@g' $(DESTDIR)${SITE_PERL}/Debian/Debhelper/Dh_Lib.pm
if [ "$(VERSION)" ]; then \
- MV=$$(echo "$(VERSION)" | $(PERL) -ne 'print $$1 if /^(\d+)[~.]/;') ; \
- sed -i "/constant HIGHEST_STABLE_COMPAT_LEVEL =>/s@=>.*;@=> $${MV};@g" $(DESTDIR)$(PERLLIBDIR)/Dh_Lib.pm ; \
+- MV=$$(echo "$(VERSION)" | $(PERL) -ne 'print $$1 if /^(\d+)[~.]/;') ; \
+- sed -i "/constant HIGHEST_STABLE_COMPAT_LEVEL =>/s@=>.*;@=> $${MV};@g" $(DESTDIR)$(PERLLIBDIR)/Dh_Lib.pm ; \
++ sed -i '' "/constant HIGHEST_STABLE_COMPAT_LEVEL =>/s@=>.*;@=> $${VERSION};@g" $(DESTDIR)${SITE_PERL}/Debian/Debhelper/Dh_Lib.pm ; \
fi
- install -m 0644 lib/Debian/Debhelper/Sequence/*.pm $(DESTDIR)$(PERLLIBDIR)/Sequence
- install -m 0644 lib/Debian/Debhelper/Buildsystem/*.pm $(DESTDIR)$(PERLLIBDIR)/Buildsystem