aboutsummaryrefslogtreecommitdiff
path: root/sysutils/debootstrap
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2023-02-10 17:18:08 +0000
committerNeel Chauhan <nc@FreeBSD.org>2023-02-10 17:18:08 +0000
commitf78f4879c494526e1bef0653c343753627b62cce (patch)
tree30ac1b0d5c3f1814a805433c1dea76da687e8ca6 /sysutils/debootstrap
parent5fd38aff4899441ca57eff82348536f85acb6199 (diff)
downloadports-f78f4879c494526e1bef0653c343753627b62cce.tar.gz
ports-f78f4879c494526e1bef0653c343753627b62cce.zip
sysutils/debootstrap: Set +x to debootstrap
PR: 268205
Diffstat (limited to 'sysutils/debootstrap')
-rw-r--r--sysutils/debootstrap/Makefile1
-rw-r--r--sysutils/debootstrap/files/patch-Makefile12
-rw-r--r--sysutils/debootstrap/files/patch-debootstrap21
-rw-r--r--sysutils/debootstrap/files/patch-scripts-gutsy8
-rw-r--r--sysutils/debootstrap/files/patch-scripts_debian-common6
5 files changed, 30 insertions, 18 deletions
diff --git a/sysutils/debootstrap/Makefile b/sysutils/debootstrap/Makefile
index 97d754cb3b90..a9febc33c241 100644
--- a/sysutils/debootstrap/Makefile
+++ b/sysutils/debootstrap/Makefile
@@ -1,5 +1,6 @@
PORTNAME= debootstrap
PORTVERSION= 1.0.128
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= DEBIAN
DISTNAME= ${PORTNAME}_${PORTVERSION}
diff --git a/sysutils/debootstrap/files/patch-Makefile b/sysutils/debootstrap/files/patch-Makefile
index 6b4e6b5164d7..db211f5a422d 100644
--- a/sysutils/debootstrap/files/patch-Makefile
+++ b/sysutils/debootstrap/files/patch-Makefile
@@ -1,15 +1,15 @@
---- Makefile.orig 2019-07-06 11:22:30 UTC
+--- Makefile.orig 2021-04-06 19:52:02 UTC
+++ Makefile
-@@ -5,14 +5,12 @@ all:
+@@ -5,14 +5,13 @@ all:
clean:
-DSDIR=$(DESTDIR)/usr/share/debootstrap
-+DSDIR=$(DESTDIR)%%DATADIR%%
++DSDIR=$(DESTDIR)/usr/local/share/debootstrap
install:
mkdir -p $(DSDIR)/scripts
- mkdir -p $(DESTDIR)/usr/sbin
-+ mkdir -p $(DESTDIR)%%PREFIX%%/sbin
++ mkdir -p $(DESTDIR)/usr/local/sbin
cp -a scripts/* $(DSDIR)/scripts/
- install -o root -g root -m 0644 functions $(DSDIR)/
@@ -17,5 +17,5 @@
- sed 's/@VERSION@/$(VERSION)/g' debootstrap >$(DESTDIR)/usr/sbin/debootstrap
- chown root:root $(DESTDIR)/usr/sbin/debootstrap
-- chmod 0755 $(DESTDIR)/usr/sbin/debootstrap
-+ sed 's/@VERSION@/$(VERSION)/g' debootstrap >$(DESTDIR)%%PREFIX%%/sbin/debootstrap
+ chmod 0755 $(DESTDIR)/usr/sbin/debootstrap
++ sed 's/@VERSION@/$(VERSION)/g' debootstrap >$(DESTDIR)/usr/local/sbin/debootstrap
diff --git a/sysutils/debootstrap/files/patch-debootstrap b/sysutils/debootstrap/files/patch-debootstrap
index b8b633661c06..82733b633193 100644
--- a/sysutils/debootstrap/files/patch-debootstrap
+++ b/sysutils/debootstrap/files/patch-debootstrap
@@ -1,8 +1,8 @@
---- debootstrap.orig 2020-03-13 02:03:08 UTC
+--- debootstrap.orig 2022-10-14 11:16:30 UTC
+++ debootstrap
@@ -1,4 +1,4 @@
-#!/bin/sh
-+#!%%LOCALBASE%%/bin/bash
++#!/usr/local/bin/bash
set -e
VERSION='@VERSION@'
@@ -11,11 +11,22 @@
DEBOOTSTRAP_DIR=/debootstrap
else
- DEBOOTSTRAP_DIR=/usr/share/debootstrap
-+ DEBOOTSTRAP_DIR=%%DATADIR%%
++ DEBOOTSTRAP_DIR=/usr/local/share/debootstrap
fi
fi
-@@ -516,13 +516,7 @@ fi
+@@ -379,8 +379,8 @@ if [ $# != 0 ] ; then
+ shift
+ ;;
+ --keyring|--keyring=?*)
+- if ! gpgv --version >/dev/null 2>&1; then
+- error 1 NEEDGPGV "gpgv not installed, but required for Release verification"
++ if ! gpgv2 --version >/dev/null 2>&1; then
++ error 1 NEEDGPGV "gpgv2 not installed, but required for Release verification"
+ fi
+ if [ "$1" = "--keyring" ] && [ -n "$2" ]; then
+ KEYRING="$2"
+@@ -536,13 +536,7 @@ fi
###########################################################################
@@ -30,7 +41,7 @@
HOST_ARCH=$(cat "$DEBOOTSTRAP_DIR/arch")
fi
HOST_OS="$HOST_ARCH"
-@@ -542,6 +536,14 @@ if [ -z "$HOST_OS" ]; then
+@@ -562,6 +556,14 @@ if [ -z "$HOST_OS" ]; then
HOST_OS=freebsd
;;
esac
diff --git a/sysutils/debootstrap/files/patch-scripts-gutsy b/sysutils/debootstrap/files/patch-scripts-gutsy
index 354c3c57e883..18b91b19d176 100644
--- a/sysutils/debootstrap/files/patch-scripts-gutsy
+++ b/sysutils/debootstrap/files/patch-scripts-gutsy
@@ -1,6 +1,6 @@
---- scripts/gutsy.orig 2020-03-13 02:04:21 UTC
+--- scripts/gutsy.orig 2023-02-08 17:55:01 UTC
+++ scripts/gutsy
-@@ -242,10 +242,21 @@ echo \"Warning: Fake initctl called, doing nothing\""
+@@ -296,10 +296,21 @@ echo \"Warning: Fake initctl called, doing nothing\""
predep=$(without "$(without "$(resolve_deps $predep)" "$required")" "$done_predeps")
# XXX: progress is tricky due to how dpkg_progress works
# -- cjwatson 2009-07-29
@@ -22,7 +22,7 @@
done
if [ -n "$base" ]; then
-@@ -256,10 +267,13 @@ echo \"Warning: Fake initctl called, doing nothing\""
+@@ -310,10 +321,13 @@ echo \"Warning: Fake initctl called, doing nothing\""
info CONFBASE "Configuring the base system..."
@@ -36,7 +36,7 @@
fi
if [ -x "$TARGET/sbin/initctl.REAL" ]; then
-@@ -267,6 +281,12 @@ echo \"Warning: Fake initctl called, doing nothing\""
+@@ -321,6 +335,12 @@ echo \"Warning: Fake initctl called, doing nothing\""
fi
mv "$TARGET/sbin/start-stop-daemon.REAL" "$TARGET/sbin/start-stop-daemon"
rm -f "$TARGET/usr/sbin/policy-rc.d"
diff --git a/sysutils/debootstrap/files/patch-scripts_debian-common b/sysutils/debootstrap/files/patch-scripts_debian-common
index 8027154f25e4..0eb7c31d2064 100644
--- a/sysutils/debootstrap/files/patch-scripts_debian-common
+++ b/sysutils/debootstrap/files/patch-scripts_debian-common
@@ -1,6 +1,6 @@
---- scripts/debian-common.orig 2020-03-13 02:04:21 UTC
+--- scripts/debian-common.orig 2023-02-08 17:55:01 UTC
+++ scripts/debian-common
-@@ -200,10 +200,21 @@ echo \"Warning: Fake start-stop-daemon called, doing n
+@@ -215,10 +215,21 @@ echo \"Warning: Fake start-stop-daemon called, doing n
predep=$(without "$(without "$(resolve_deps $predep)" "$required")" "$done_predeps")
# XXX: progress is tricky due to how dpkg_progress works
# -- cjwatson 2009-07-29
@@ -22,7 +22,7 @@
done
if [ -n "$base" ]; then
-@@ -222,6 +233,12 @@ echo \"Warning: Fake start-stop-daemon called, doing n
+@@ -237,6 +248,12 @@ echo \"Warning: Fake start-stop-daemon called, doing n
mv "$TARGET/sbin/start-stop-daemon.REAL" "$TARGET/sbin/start-stop-daemon"
rm -f "$TARGET/usr/sbin/policy-rc.d"