aboutsummaryrefslogtreecommitdiff
path: root/sysutils/deltup
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-04-06 12:52:37 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-04-06 12:52:37 +0000
commit464bbaba48318f813f31af226d98c1fdbb79f241 (patch)
tree8b02f1c979e3af9aa75c74b197ac19218f06687c /sysutils/deltup
parent40cf78ae6a8a3301b285b5dbfc8256af16572946 (diff)
downloadports-464bbaba48318f813f31af226d98c1fdbb79f241.tar.gz
ports-464bbaba48318f813f31af226d98c1fdbb79f241.zip
- Fix RUN_DEPENDS on archivers/gzip by checking if the package is installed,
not the executable (since in the later case base-system gzip will always be found). - be a little more explicit in the related patch - bump PORTREVISION for depends "change" Approved by: novel@ (implicit)
Notes
Notes: svn path=/head/; revision=210649
Diffstat (limited to 'sysutils/deltup')
-rw-r--r--sysutils/deltup/Makefile3
-rw-r--r--sysutils/deltup/files/patch-gzip.cpp16
2 files changed, 12 insertions, 7 deletions
diff --git a/sysutils/deltup/Makefile b/sysutils/deltup/Makefile
index 2765cfd572ce..dd4affdf81a8 100644
--- a/sysutils/deltup/Makefile
+++ b/sysutils/deltup/Makefile
@@ -7,6 +7,7 @@
PORTNAME= deltup
PORTVERSION= 0.4.4
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://deltup.org/e107_files/downloads/ \
LOCAL/rafan \
@@ -21,7 +22,7 @@ COMMENT= Source delta update program
RUN_DEPENDS= bdelta:${PORTSDIR}/misc/bdelta \
xdelta:${PORTSDIR}/misc/xdelta \
- gzip:${PORTSDIR}/archivers/gzip
+ gzip>=1:${PORTSDIR}/archivers/gzip
BZIP2_102_SOURCE= bzip2-${BZIP2_102}.tar.gz
BZIP2_103_SOURCE= bzip2-${BZIP2_103}.tar.gz
diff --git a/sysutils/deltup/files/patch-gzip.cpp b/sysutils/deltup/files/patch-gzip.cpp
index ada647dcc6b7..09ecaf7f9f86 100644
--- a/sysutils/deltup/files/patch-gzip.cpp
+++ b/sysutils/deltup/files/patch-gzip.cpp
@@ -1,6 +1,6 @@
---- gzip.cpp.orig 1970-01-01 05:00:00.000000000 +0500
-+++ gzip.cpp 2008-03-10 14:15:19.000000000 +0500
-@@ -0,0 +1,59 @@
+--- ./gzip.cpp.orig 2008-04-06 15:43:16.000000000 +0300
++++ ./gzip.cpp 2008-04-06 15:43:48.000000000 +0300
+@@ -0,0 +1,63 @@
+/* Copyright (C) 2007 John Whitney
+ *
+ * This program is free software; you can redistribute it and/or modify
@@ -29,7 +29,7 @@
+
+void find_gzip_compressor() {
+ string tempfile = getTmpFilename();
-+ string command = "find `echo $PATH | tr \":\" \" \"` -iname \"gzip\" -exec sh -c 'echo {};{} -V 2>&1|grep \"^gzip\"' \\; 2> /dev/null > "
++ string command = "find `echo $PATH | tr ':' ' '` -iname 'gzip' -exec sh -c 'echo {};{} -V 2>&1|grep ^gzip' \\; 2> /dev/null > "
+ + tempfile;
+
+ system(command.c_str());
@@ -56,7 +56,11 @@
+ fname = line;
+ }
+ if (verbose) {
-+ printf("found gnu gzip compressor/decompressor:\n");
-+ if (gzip_name!=NULL) printf(" %s\n", gzip_name);
++ if (gzip_name!=NULL)
++ {
++ printf("found GNU gzip compressor/decompressor:\n");
++ printf(" %s\n", gzip_name);
++ }
++ else printf("GNU gzip compressor/decompressor NOT found!\n");
+ }
+}