aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dfc
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-07-24 11:33:20 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-07-24 11:33:20 +0000
commit404ade345a0b95c45673a3deeef46475c2a87961 (patch)
treeeb586f5d784451b67a07b64a458af7ae43243442 /sysutils/dfc
parenta80c24846411205670a6998783b08f4d3c60b926 (diff)
downloadports-404ade345a0b95c45673a3deeef46475c2a87961.tar.gz
ports-404ade345a0b95c45673a3deeef46475c2a87961.zip
Notes
Diffstat (limited to 'sysutils/dfc')
-rw-r--r--sysutils/dfc/Makefile8
-rw-r--r--sysutils/dfc/files/patch-src__util.c13
2 files changed, 14 insertions, 7 deletions
diff --git a/sysutils/dfc/Makefile b/sysutils/dfc/Makefile
index eecc4f648dff..ca0732841d6a 100644
--- a/sysutils/dfc/Makefile
+++ b/sysutils/dfc/Makefile
@@ -33,10 +33,4 @@ CMAKE_ARGS+= -DNLS_ENABLED=false
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 800000
-BROKEN= does not compile on FreeBSD 7.X
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/dfc/files/patch-src__util.c b/sysutils/dfc/files/patch-src__util.c
new file mode 100644
index 000000000000..5906e4ccace4
--- /dev/null
+++ b/sysutils/dfc/files/patch-src__util.c
@@ -0,0 +1,13 @@
+--- src/util.c.orig 2012-07-24 13:34:08.000000000 +0400
++++ src/util.c 2012-07-24 13:34:29.000000000 +0400
+@@ -48,6 +48,10 @@
+ #include <libintl.h>
+ #endif
+
++#ifdef TIOCGSIZE
++#undef TIOCGSIZE
++#endif
++
+ /*
+ * Return the longest of the two parameters
+ * @a: first element to compare