aboutsummaryrefslogtreecommitdiff
path: root/sysutils/docker
diff options
context:
space:
mode:
authorNikolai Lifanov <lifanov@FreeBSD.org>2019-02-01 23:59:12 +0000
committerNikolai Lifanov <lifanov@FreeBSD.org>2019-02-01 23:59:12 +0000
commit265f40f014f74e4924be02c8d2fb86266669f617 (patch)
tree53798792c02e13ef494291ac3ac05cbc24dfe201 /sysutils/docker
parent896f048cdcebc7420c540e739298b56884232f5c (diff)
downloadports-265f40f014f74e4924be02c8d2fb86266669f617.tar.gz
ports-265f40f014f74e4924be02c8d2fb86266669f617.zip
update Docker client to 18.09.1
Changes: https://docs.docker.com/engine/release-notes/ PR: 235407 Submitted by: Dmitri Goutnik <dg@syrec.org>
Notes
Notes: svn path=/head/; revision=491902
Diffstat (limited to 'sysutils/docker')
-rw-r--r--sysutils/docker/Makefile3
-rw-r--r--sysutils/docker/distinfo6
-rw-r--r--sysutils/docker/files/patch-components_cli_vendor_github.com_tonistiigi_fsutil_stat__unix.go11
-rw-r--r--sysutils/docker/files/patch-components_cli_vendor_github.com_tonistiigi_fsutil_walker__unix.go11
4 files changed, 15 insertions, 16 deletions
diff --git a/sysutils/docker/Makefile b/sysutils/docker/Makefile
index f009af810453..92de1467d7fe 100644
--- a/sysutils/docker/Makefile
+++ b/sysutils/docker/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= docker
-PORTVERSION= 18.06.0
+PORTVERSION= 18.09.1
DISTVERSIONPREFIX= v
-DISTVERSIONSUFFIX= -ce
CATEGORIES= sysutils
MAINTAINER= lifanov@FreeBSD.org
diff --git a/sysutils/docker/distinfo b/sysutils/docker/distinfo
index 14685abb2777..afda369a0e4c 100644
--- a/sysutils/docker/distinfo
+++ b/sysutils/docker/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1533309208
-SHA256 (docker-docker-ce-v18.06.0-ce_GH0.tar.gz) = 18754ecb38d7c210fb2b96ee618dc2bdf94e66cd501d4eef0c685903a83e8501
-SIZE (docker-docker-ce-v18.06.0-ce_GH0.tar.gz) = 13656557
+TIMESTAMP = 1549036632
+SHA256 (docker-docker-ce-v18.09.1_GH0.tar.gz) = 9eadb1eae1954b0322aadf6505f5397d1b1eccf6395ab511cadf8e6975cfc576
+SIZE (docker-docker-ce-v18.09.1_GH0.tar.gz) = 15247155
diff --git a/sysutils/docker/files/patch-components_cli_vendor_github.com_tonistiigi_fsutil_stat__unix.go b/sysutils/docker/files/patch-components_cli_vendor_github.com_tonistiigi_fsutil_stat__unix.go
new file mode 100644
index 000000000000..771db18585a6
--- /dev/null
+++ b/sysutils/docker/files/patch-components_cli_vendor_github.com_tonistiigi_fsutil_stat__unix.go
@@ -0,0 +1,11 @@
+--- components/cli/vendor/github.com/tonistiigi/fsutil/stat_unix.go.orig 2019-02-01 16:05:34 UTC
++++ components/cli/vendor/github.com/tonistiigi/fsutil/stat_unix.go
+@@ -45,7 +45,7 @@ func setUnixOpt(fi os.FileInfo, stat *ty
+ stat.Devminor = int64(minor(uint64(s.Rdev)))
+ }
+
+- ino := s.Ino
++ ino := uint64(s.Ino)
+ if seenFiles != nil {
+ if s.Nlink > 1 {
+ if oldpath, ok := seenFiles[ino]; ok {
diff --git a/sysutils/docker/files/patch-components_cli_vendor_github.com_tonistiigi_fsutil_walker__unix.go b/sysutils/docker/files/patch-components_cli_vendor_github.com_tonistiigi_fsutil_walker__unix.go
deleted file mode 100644
index cad645a4a729..000000000000
--- a/sysutils/docker/files/patch-components_cli_vendor_github.com_tonistiigi_fsutil_walker__unix.go
+++ /dev/null
@@ -1,11 +0,0 @@
---- components/cli/vendor/github.com/tonistiigi/fsutil/walker_unix.go.orig 2018-01-03 19:53:04 UTC
-+++ components/cli/vendor/github.com/tonistiigi/fsutil/walker_unix.go
-@@ -41,7 +41,7 @@ func setUnixOpt(fi os.FileInfo, stat *Stat, path strin
- stat.Devminor = int64(minor(uint64(s.Rdev)))
- }
-
-- ino := s.Ino
-+ ino := uint64(s.Ino)
- if s.Nlink > 1 {
- if oldpath, ok := seenFiles[ino]; ok {
- stat.Linkname = oldpath