aboutsummaryrefslogtreecommitdiff
path: root/sysutils/docker
diff options
context:
space:
mode:
authorNikolai Lifanov <lifanov@FreeBSD.org>2017-03-21 16:52:16 +0000
committerNikolai Lifanov <lifanov@FreeBSD.org>2017-03-21 16:52:16 +0000
commit84c36cd706318034e46534c0e47ef0becd7fe8db (patch)
tree79b79d37fec708dbc27d5dfe513024e23c3da00f /sysutils/docker
parentd299bf2d5ec91cb5fcff79710b56013940548824 (diff)
downloadports-84c36cd706318034e46534c0e47ef0becd7fe8db.tar.gz
ports-84c36cd706318034e46534c0e47ef0becd7fe8db.zip
add sysutils/docker
Docker is the world's leading software container platform. Developers use Docker to eliminate "works on my machine" problems when collaborating on code with co-workers. Operators use Docker to run and manage apps side-by-side in isolated containers to get better compute density. Enterprises use Docker to build agile software delivery pipelines to ship new features faster, more securely and with confidence for both Linux and Windows Server apps. Note: this port contains Docker client only.
Notes
Notes: svn path=/head/; revision=436619
Diffstat (limited to 'sysutils/docker')
-rw-r--r--sysutils/docker/Makefile26
-rw-r--r--sysutils/docker/distinfo3
-rw-r--r--sysutils/docker/pkg-descr8
-rw-r--r--sysutils/docker/pkg-message2
4 files changed, 39 insertions, 0 deletions
diff --git a/sysutils/docker/Makefile b/sysutils/docker/Makefile
new file mode 100644
index 000000000000..1a8de04a4900
--- /dev/null
+++ b/sysutils/docker/Makefile
@@ -0,0 +1,26 @@
+# Created by: Nikolai Lifanov <lifanov@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= docker
+PORTVERSION= 17.03.0
+DISTVERSIONPREFIX= v
+DISTVERSIONSUFFIX= -ce
+CATEGORIES= sysutils
+
+MAINTAINER= lifanov@FreeBSD.org
+COMMENT= Open-source application container engine
+
+LICENSE= APACHE20
+
+PLIST_FILES= bin/docker
+
+USE_GITHUB= yes
+
+USES= go
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+GO_TARGET= github.com/${GH_ACCOUNT}/${PORTNAME}/cmd/docker
+
+STRIP= # stripping can break go binaries
+
+.include <bsd.port.mk>
diff --git a/sysutils/docker/distinfo b/sysutils/docker/distinfo
new file mode 100644
index 000000000000..ef5bce68e21d
--- /dev/null
+++ b/sysutils/docker/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1490113515
+SHA256 (docker-docker-v17.03.0-ce_GH0.tar.gz) = d8e91af5b2799cafac113a400d4db9c6abe01ae823f378d2f4d3d3e55e48eaf6
+SIZE (docker-docker-v17.03.0-ce_GH0.tar.gz) = 7769578
diff --git a/sysutils/docker/pkg-descr b/sysutils/docker/pkg-descr
new file mode 100644
index 000000000000..439c302f2917
--- /dev/null
+++ b/sysutils/docker/pkg-descr
@@ -0,0 +1,8 @@
+Docker is the world's leading software container platform. Developers use
+Docker to eliminate "works on my machine" problems when collaborating on code
+with co-workers. Operators use Docker to run and manage apps side-by-side in
+isolated containers to get better compute density. Enterprises use Docker to
+build agile software delivery pipelines to ship new features faster, more
+securely and with confidence for both Linux and Windows Server apps.
+
+WWW: https://www.docker.com/
diff --git a/sysutils/docker/pkg-message b/sysutils/docker/pkg-message
new file mode 100644
index 000000000000..9af3fe6fd0e6
--- /dev/null
+++ b/sysutils/docker/pkg-message
@@ -0,0 +1,2 @@
+This port contains Docker client only.
+For Docker server support, install docker-machine.