aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dtc/Makefile
diff options
context:
space:
mode:
authorMarc G. Fournier <scrappy@FreeBSD.org>2008-04-22 02:13:26 +0000
committerMarc G. Fournier <scrappy@FreeBSD.org>2008-04-22 02:13:26 +0000
commit417e3a8e2ba1f235c19b61ffef98c08514b7d2b6 (patch)
treef1c5dffbee8dcef2e890a2b393a12b2cd6948e4e /sysutils/dtc/Makefile
parent217959ddce2f9e8ddc092962746ea301c60a399d (diff)
downloadports-417e3a8e2ba1f235c19b61ffef98c08514b7d2b6.tar.gz
ports-417e3a8e2ba1f235c19b61ffef98c08514b7d2b6.zip
Notes
Diffstat (limited to 'sysutils/dtc/Makefile')
-rw-r--r--sysutils/dtc/Makefile77
1 files changed, 54 insertions, 23 deletions
diff --git a/sysutils/dtc/Makefile b/sysutils/dtc/Makefile
index 98ff0718e373..ec75b863c4e1 100644
--- a/sysutils/dtc/Makefile
+++ b/sysutils/dtc/Makefile
@@ -1,29 +1,36 @@
-# Ports collection makefile for: dtc
-# Date created: 1 December 2003
-# Whom: Frederic Cambus & Thomas Goirand
+# Ports collection makefile for: dtc
+# Date created: 1 December 2003
+# Whom: Frederic Cambus & Thomas Goirand & Marc G. Fournier
#
# $FreeBSD$
#
PORTNAME= dtc
-PORTVERSION= 0.25.0.1
+PORTVERSION= 0.28.2.1
CATEGORIES= sysutils
-MASTER_SITES= ftp://ftp.gplhost.com/pub/dtc/bsd/
+MASTER_SITES= ftp://ftp.gplhost.com/pub/dtc/bsd/ \
+ ftp://ftp.gplhost.fr/pub/dtc/bsd/ \
+ ftp://ftp.gplhost.sg/pub/dtc/bsd/
-MAINTAINER?= josh@tcbug.org
+MAINTAINER= thomas@goirand.fr
COMMENT= A hosting web GUI for admin and accounting all hosting services
-RUN_DEPENDS= ${LOCALBASE}/share/pear/Crypt/CBC.php:${PORTSDIR}/security/pear-Crypt_CBC \
+RUN_DEPENDS= ${LOCALBASE}/libexec/mysqld:${PORTSDIR}/databases/mysql50-server \
${LOCALBASE}/libexec/apache22/mod_log_sql.so:${PORTSDIR}/www/mod_log_sql2-dtc \
+ ${LOCALBASE}/libexec/apache22/libphp5.so:${PORTSDIR}/www/php5-session \
+ ${LOCALBASE}/share/pear/Crypt/CBC.php:${PORTSDIR}/security/pear-Crypt_CBC \
${LOCALBASE}/www/cgi-bin/sbox:${PORTSDIR}/www/sbox-dtc \
${LOCALBASE}/bin/sudo:${PORTSDIR}/security/sudo \
${LOCALBASE}/lib/nss_mysql.so:${PORTSDIR}/net/libnss-mysql \
${LOCALBASE}/sbin/chrootuid:${PORTSDIR}/security/chrootuid \
- ${LOCALBASE}/bin/rrdtool:${PORTSDIR}/databases/rrdtool \
${LOCALBASE}/bin/wget:${PORTSDIR}/ftp/wget \
- ${LOCALBASE}/lib/X11/fonts/bitstream-vera/Vera.ttf:${PORTSDIR}/x11-fonts/bitstream-vera \
- ${LOCALBASE}/lib/X11/fonts/webfonts/verdana.ttf:${PORTSDIR}/x11-fonts/webfonts \
- ${LOCALBASE}/libexec/mysqld:${PORTSDIR}/databases/mysql50-server
+ ${LOCALBASE}/share/fpdf/fpdf.php:${PORTSDIR}/print/fpdf \
+ ${X11BASE}/lib/X11/fonts/bitstream-vera/Vera.ttf:${PORTSDIR}/x11-fonts/bitstream-vera \
+ ${X11BASE}/lib/X11/fonts/webfonts/verdana.ttf:${PORTSDIR}/x11-fonts/webfonts \
+ ${LOCALBASE}/bin/mhonarc:${PORTSDIR}/www/mhonarc \
+ ${LOCALBASE}/bin/mlmmj-list:${PORTSDIR}/mail/mlmmj \
+ ${LOCALBASE}/bin/ncftpput:${PORTSDIR}/ftp/ncftp3 \
+ ${LOCALBASE}/bin/rrdtool:${PORTSDIR}/databases/rrdtool
NO_BUILD= yes
USE_PHP= mysql pcre session
@@ -44,12 +51,8 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/webalizer:${PORTSDIR}/www/webalizer
RUN_DEPENDS+= ${LOCALBASE}/www/awstats:${PORTSDIR}/www/awstats
.endif
-.if defined(WITH_MHONARC)
-RUN_DEPENDS+= ${LOCALBASE}/bin/mhonarc:${PORTSDIR}/www/mhonarc
-.endif
-
-.if defined(WITH_MLMMJ)
-RUN_DEPENDS+= ${LOCALBASE}/bin/mlmmj-list:${PORTSDIR}/mail/mlmmj
+.if defined(WITH_VISITORS)
+RUN_DEPENDS+= ${LOCALBASE}/bin/visitors:${PORTSDIR}/www/visitors
.endif
.if defined(WITH_PUREFTPD)
@@ -63,9 +66,37 @@ RUN_DEPENDS+= ${LOCALBASE}/libexec/postfix/smtpd:${PORTSDIR}/mail/postfix
.if defined(WITH_CYRUS_IMAPD)
RUN_DEPENDS+= ${LOCALBASE}/cyrus/bin/deliver:${PORTSDIR}/mail/cyrus-imapd23
.endif
-.elif defined(WITH_COURIER)
-RUN_DEPENDS+= ${LOCALBASE}/libexec/courier/courierd:${PORTSDIR}/mail/courier \
- ${LOCALBASE}/lib/pam_mysql.so:${PORTSDIR}/security/pam-mysql
+.elif defined(WITH_COURIER_IMAP)
+RUN_DEPENDS+= ${LOCALBASE}/sbin/pop3login:${PORTSDIR}/mail/courier-imap \
+ ${LOCALBASE}lib/courier-authlib/libauthmysql.a:${PORTSDIR}/databases/courier-authlib-mysql
+.endif
+
+.if defined(WITH_MAILDROP)
+RUN_DEPENDS+= ${LOCALBASE}/bin/maildrop:${PORTSDIR}/mail/maildrop
+.endif
+
+.if defined(WITH_CYRUS_SASL2)
+RUN_DEPENDS+= ${LOCALBASE}/lib/sasl2/libcrammd5.so:${PORTSDIR}/security/cyrus-sasl2
+.endif
+
+.if defined(WITH_SPAMASSASSIN)
+RUN_DEPENDS+= ${LOCALBASE}/bin/spamd:${PORTSDIR}/mail/p5-Mail-SpamAssassin
+.endif
+
+.if defined(WITH_CLAMAV)
+RUN_DEPENDS+= ${LOCALBASE}/bin/clamdscan:${PORTSDIR}/security/clamav
+.endif
+
+.if defined(WITH_AMAVIS)
+RUN_DEPENDS+= ${LOCALBASE}/sbin/amavisd:${PORTSDIR}/security/amavisd-new
+.endif
+
+.if defined(WITH_SQUIRRELMAIL)
+RUN_DEPENDS+= ${LOCALBASE}/www/squirrelmail/src/login.php:${PORTSDIR}/mail/squirrelmail
+.endif
+
+.if defined(WITH_PHPMYADMIN)
+RUN_DEPENDS+= ${LOCALBASE}/www/phpMyAdmin/index.html:${PORTSDIR}/databases/phpmyadmin
.endif
.if defined(WITH_APACHE2)
@@ -77,13 +108,13 @@ DTCDIR= ${PREFIX}/${DTCROOT}
PLIST_SUB+= DTCROOT="${DTCROOT}"
SUB_FILES= dtc-install dtc-deinstall
-SUB_LIST+= QMAIL_DIR="${QMAIL_DIR}" DTCROOT="${DTCROOT}"
+SUB_LIST+= QMAIL_DIR="${QMAIL_DIR}"
do-install:
@${INSTALL_SCRIPT} ${WRKDIR}/dtc-install ${PREFIX}/sbin/dtc-install
@${INSTALL_SCRIPT} ${WRKDIR}/dtc-deinstall ${PREFIX}/sbin/dtc-deinstall
- @${MKDIR} ${DTCDIR}
- @cd ${WRKSRC} ; ${TAR} cfp - . | ${TAR} xfp - -C ${DTCDIR}
+ @${MAKE} -C ${WRKDIR}/dtc-0.28.2.1 install-dtc-common INSTALL=install DTC_APP_DIR=${LOCALBASE}/www DTC_GEN_DIR=${LOCALBASE}/var CONFIG_DIR=${LOCALBASE}/etc \
+ DTC_DOC_DIR=${LOCALBASE}/share/doc MANUAL_DIR=${LOCALBASE}/man BIN_DIR=${LOCALBASE}/bin UNIX_TYPE=bsd
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>