aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dtpstree
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-20 09:33:04 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-20 09:33:04 +0000
commitdf3238e851ed72103084992ab5fdfffdc2ee1caa (patch)
tree1fde580288f4cd751ff283b149ffd5ec09fe7724 /sysutils/dtpstree
parent1142d62e9c8897343843e02a1a50878435221bbb (diff)
downloadports-df3238e851ed72103084992ab5fdfffdc2ee1caa.tar.gz
ports-df3238e851ed72103084992ab5fdfffdc2ee1caa.zip
- Fix build with clang
- Use USES=gmake - Support STAGEDIR PR: ports/183116 Submitted by: sunpoet (myself) Approved by: Douglas Thrift <douglas@douglasthrift.net> (maintainer)
Notes
Notes: svn path=/head/; revision=330995
Diffstat (limited to 'sysutils/dtpstree')
-rw-r--r--sysutils/dtpstree/Makefile7
-rw-r--r--sysutils/dtpstree/files/patch-dtpstree.cpp10
2 files changed, 14 insertions, 3 deletions
diff --git a/sysutils/dtpstree/Makefile b/sysutils/dtpstree/Makefile
index d85da0798b71..307d8c8a4edf 100644
--- a/sysutils/dtpstree/Makefile
+++ b/sysutils/dtpstree/Makefile
@@ -13,11 +13,12 @@ COMMENT= Display a tree of processes
LICENSE= AL2
USE_XZ= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKEFILE= GNUmakefile
+USES= gmake
+
MAN1= dtpstree.1
-PLIST_FILES= bin/dtpstree
+PLIST_FILES= bin/dtpstree \
+ man/man1/dtpstree.1.gz
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/sysutils/dtpstree/files/patch-dtpstree.cpp b/sysutils/dtpstree/files/patch-dtpstree.cpp
new file mode 100644
index 000000000000..405864f7f623
--- /dev/null
+++ b/sysutils/dtpstree/files/patch-dtpstree.cpp
@@ -0,0 +1,10 @@
+--- dtpstree.cpp.orig 2010-08-05 16:01:47.000000000 +0800
++++ dtpstree.cpp 2013-10-19 19:48:34.750149337 +0800
+@@ -21,6 +21,7 @@
+
+ #include <cerrno>
+ #include <climits>
++#include <clocale>
+ #include <cstdarg>
+ #include <cstdio>
+ #include <cstdlib>