aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dvdbackup
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-01-22 20:54:11 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-01-22 20:54:11 +0000
commit990ea8bdd0dc06f137220b0e9ef5d0ef4c75b87f (patch)
tree942723624272e31ba908947f6b6d3c71009a7f33 /sysutils/dvdbackup
parentc79b42fc98bc0a9f4441bd5b76b2aae087be1204 (diff)
downloadports-990ea8bdd0dc06f137220b0e9ef5d0ef4c75b87f.tar.gz
ports-990ea8bdd0dc06f137220b0e9ef5d0ef4c75b87f.zip
Notes
Diffstat (limited to 'sysutils/dvdbackup')
-rw-r--r--sysutils/dvdbackup/Makefile4
-rw-r--r--sysutils/dvdbackup/files/patch-src::dvdbackup.c10
2 files changed, 12 insertions, 2 deletions
diff --git a/sysutils/dvdbackup/Makefile b/sysutils/dvdbackup/Makefile
index 36dd3f96f3a4..982bee6559dc 100644
--- a/sysutils/dvdbackup/Makefile
+++ b/sysutils/dvdbackup/Makefile
@@ -7,9 +7,9 @@
PORTNAME= dvdbackup
PORTVERSION= 0.1.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
-MASTER_SITES= http://dvd-create.sourceforge.net/
+MASTER_SITES= http://dvd-create.sourceforge.net/ GENTOO/distfiles
MAINTAINER= conrads@cox.net
COMMENT= Backup content from DVD to hard disk
diff --git a/sysutils/dvdbackup/files/patch-src::dvdbackup.c b/sysutils/dvdbackup/files/patch-src::dvdbackup.c
index ee1f81bdfd1c..1741e69209d8 100644
--- a/sysutils/dvdbackup/files/patch-src::dvdbackup.c
+++ b/sysutils/dvdbackup/files/patch-src::dvdbackup.c
@@ -19,6 +19,16 @@
fprintf(stderr,"\t-a is option to the -F switch and has no effect on other options\n");
fprintf(stderr,"\t-s and -e should prefereibly be used together with -t \n\n");
exit(1);
+@@ -228,7 +228,8 @@
+ }
+
+ int CheckSizeArray(const int size_array[], int reference, int target) {
+- if ( (size_array[reference]/size_array[target] == 1) &&
++ if ( size_array[target] &&
++ (size_array[reference]/size_array[target] == 1) &&
+ ((size_array[reference] * 2 - size_array[target])/ size_array[target] == 1) &&
+ ((size_array[reference]%size_array[target] * 3) < size_array[reference]) ) {
+ /* We have a dual DVD with two feature films - now lets see if they have the same amount of chapters*/
@@ -782,7 +783,7 @@
to consider the second one a feature title we are doing two checks (biggest + biggest - second) /second == 1
and biggest%second * 3 < biggest */