aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dwatch-gource
diff options
context:
space:
mode:
authorDevin Teske <dteske@FreeBSD.org>2018-05-15 00:21:34 +0000
committerDevin Teske <dteske@FreeBSD.org>2018-05-15 00:21:34 +0000
commit10628b8f3dbae2f3dde9ccfebdb90a30e013ff85 (patch)
treeed3291e0af595245c7bde86f88bf340be77a52bc /sysutils/dwatch-gource
parentd0fb48ada3f73e48602faabfb3441fe1aa68298b (diff)
downloadports-10628b8f3dbae2f3dde9ccfebdb90a30e013ff85.tar.gz
ports-10628b8f3dbae2f3dde9ccfebdb90a30e013ff85.zip
[New Port] sysutils/dwatch-gource
DTrace modules for FreeBSD dwatch(1) to produce gource logs. Gource (graphics/gource) is a tool normally used for visualizing source control revisions, but it can also be used for visualizing process trees, filesystem activity, syscall access, and more. These modules allow you to generate log files for rendering realtime process, filesystem, and other activities in FreeBSD using gource. Reviewed by: imp (mentor; earlier version), mat (mentor) Approved by: mat (mentor) Sponsored by: Smule, Inc. Differential Revision: https://reviews.freebsd.org/D15407
Notes
Notes: svn path=/head/; revision=469983
Diffstat (limited to 'sysutils/dwatch-gource')
-rw-r--r--sysutils/dwatch-gource/Makefile31
-rw-r--r--sysutils/dwatch-gource/distinfo3
-rw-r--r--sysutils/dwatch-gource/pkg-descr9
-rw-r--r--sysutils/dwatch-gource/pkg-plist9
4 files changed, 52 insertions, 0 deletions
diff --git a/sysutils/dwatch-gource/Makefile b/sysutils/dwatch-gource/Makefile
new file mode 100644
index 000000000000..dd6bfce940b4
--- /dev/null
+++ b/sysutils/dwatch-gource/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= dwatch-gource
+DISTVERSION= 0.4
+CATEGORIES= sysutils
+
+MAINTAINER= dteske@FreeBSD.org
+COMMENT= FreeBSD dwatch profiles for creating gource logs
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= FrauBSD
+NO_BUILD= yes
+NO_ARCH= yes
+
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/gwatch ${STAGEDIR}${PREFIX}/sbin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/libexec/dwatch
+ ${INSTALL_DATA} ${WRKSRC}/gource-* ${STAGEDIR}${PREFIX}/libexec/dwatch
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/sysutils/dwatch-gource/distinfo b/sysutils/dwatch-gource/distinfo
new file mode 100644
index 000000000000..f21a7d71c5f4
--- /dev/null
+++ b/sysutils/dwatch-gource/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1526225519
+SHA256 (FrauBSD-dwatch-gource-0.4_GH0.tar.gz) = 519533cd1e886dc46c02dd6f46ac3a4107925bda5fc9f2b6903e9461786a047b
+SIZE (FrauBSD-dwatch-gource-0.4_GH0.tar.gz) = 10482
diff --git a/sysutils/dwatch-gource/pkg-descr b/sysutils/dwatch-gource/pkg-descr
new file mode 100644
index 000000000000..5cef8a1bcbb1
--- /dev/null
+++ b/sysutils/dwatch-gource/pkg-descr
@@ -0,0 +1,9 @@
+DTrace modules for FreeBSD dwatch(1) to produce gource logs. Gource
+(graphics/gource) is a tool normally used for visualizing source control
+revisions, but it can also be used for visualizing process trees, filesystem
+activity, syscall access, and more.
+
+These modules allow you to generate log files for rendering realtime process,
+filesystem, and other activities in FreeBSD using gource.
+
+WWW: https://fraubsd.org/dwatch-gource/
diff --git a/sysutils/dwatch-gource/pkg-plist b/sysutils/dwatch-gource/pkg-plist
new file mode 100644
index 000000000000..71f3754b5629
--- /dev/null
+++ b/sysutils/dwatch-gource/pkg-plist
@@ -0,0 +1,9 @@
+sbin/gwatch
+libexec/dwatch/gource-open
+libexec/dwatch/gource-open-raw
+libexec/dwatch/gource-proc
+libexec/dwatch/gource-proc-raw
+libexec/dwatch/gource-syscall
+libexec/dwatch/gource-syscall-raw
+libexec/dwatch/gource-vfs
+libexec/dwatch/gource-vfs-raw