aboutsummaryrefslogtreecommitdiff
path: root/sysutils/e2fsprogs/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2014-05-22 21:56:52 +0000
committerMatthias Andree <mandree@FreeBSD.org>2014-05-22 21:56:52 +0000
commit91d099f3c6034f607b5b94c98f2e6f17b96a22d8 (patch)
tree59fa963702c28f1e895dc1e1d530a7dd1515180c /sysutils/e2fsprogs/Makefile
parent364ab8781f379eb8759dcf9d825bfd1b61b9e489 (diff)
Notes
Diffstat (limited to 'sysutils/e2fsprogs/Makefile')
-rw-r--r--sysutils/e2fsprogs/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index 54efbdf84daf..909490c3768c 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -21,7 +21,7 @@ CONFIGURE_ARGS+=--disable-fsck --disable-e2initrd-helper \
--enable-quota \
--with-root-prefix='${PREFIX}'
CPPFLAGS+= -I${WRKSRC}/lib -I${LOCALBASE}/include # -D_EXT2_USE_C_VERSIONS
-MAKE_ARGS+= LDFLAGS='${LDFLAGS} -L${LOCALBASE}/lib'
+MAKE_ARGS+= LDFLAGS='${LDFLAGS} -L${LOCALBASE}/lib' pkgconfigdir='${PREFIX}/libdata/pkgconfig'
MAKE_ENV+= CHECK_CMD=@true
.if !defined(MASTERDIR)
@@ -81,6 +81,11 @@ post-patch::
.endfor
.if ${MASTERDIR} == ${.CURDIR}
+pre-build:
+# fix up Makefile ordering for parallel builds
+ cd ${WRKSRC}/lib/et && ${DO_MAKE_BUILD} compile_et
+ cd ${WRKSRC}/e2fsck && ${DO_MAKE_BUILD} prof_err.h
+
post-build:
# Relink e2fsck statically - We need to make sure that tools for the root file
# system are statically linked against anything that is outside the root fs,