aboutsummaryrefslogtreecommitdiff
path: root/sysutils/facter
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2018-09-27 06:47:03 +0000
committerRomain Tartière <romain@FreeBSD.org>2018-09-27 06:47:03 +0000
commit2197701d59316248268ea170a8eee2fc2a3f9792 (patch)
tree805657a3e3d50f03da21c97e29bfbf06c2c1a38e /sysutils/facter
parent1284529ab6ab253b0ac7dc5d1cf69ff8040c0bac (diff)
downloadports-2197701d59316248268ea170a8eee2fc2a3f9792.tar.gz
ports-2197701d59316248268ea170a8eee2fc2a3f9792.zip
Install the generated .gemspec file
Building the C implementation of facter also produce a .gemspec file. So far, it was not installed (probably by mistake: since nothing was using it, everything was fine). Now that we are about to add a consumer of this file as sysutils/rubygem-puppetserver-ca to the ports tree, this file must be installed. With hat: puppet
Notes
Notes: svn path=/head/; revision=480784
Diffstat (limited to 'sysutils/facter')
-rw-r--r--sysutils/facter/Makefile5
-rw-r--r--sysutils/facter/pkg-plist1
2 files changed, 6 insertions, 0 deletions
diff --git a/sysutils/facter/Makefile b/sysutils/facter/Makefile
index a276d4d26834..c1b8b123547a 100644
--- a/sysutils/facter/Makefile
+++ b/sysutils/facter/Makefile
@@ -2,6 +2,7 @@
PORTNAME= facter
PORTVERSION= 3.12.0
+PORTREVISION= 1
CATEGORIES?= sysutils
MASTER_SITES= https://downloads.puppetlabs.com/facter/
@@ -46,6 +47,10 @@ post-patch:
${WRKSRC}/lib/src/facts/posix/collection.cc \
${WRKSRC}/lib/src/util/config/posix/config.cc
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/ruby/gems/${RUBY_VER}/specifications
+ ${INSTALL_DATA} ${WRKSRC}/.gemspec ${STAGEDIR}${PREFIX}/lib/ruby/gems/${RUBY_VER}/specifications/${DISTNAME}.gemspec
+
test: build
cd ${WRKSRC}/lib && bundle install --path vendor
cd ${WRKSRC} && ${MAKE_CMD} test
diff --git a/sysutils/facter/pkg-plist b/sysutils/facter/pkg-plist
index 26620f30ed77..f63cbb03c9a4 100644
--- a/sysutils/facter/pkg-plist
+++ b/sysutils/facter/pkg-plist
@@ -19,6 +19,7 @@ include/facter/util/string.hpp
include/facter/version.h
lib/libfacter.so
lib/libfacter.so.%%PORTVERSION%%
+lib/ruby/gems/%%RUBY_VER%%/specifications/facter-%%PORTVERSION%%.gemspec
lib/ruby/vendor_ruby/facter.rb
man/man8/facter.8.gz
%%FACTER_JAVA%%lib/ruby/vendor_ruby/facter.jar