aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fcron
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-07-30 14:22:03 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-07-30 14:22:03 +0000
commited81849c9fdf8157d25771a3ab22b2c43f993590 (patch)
tree93158f9f0d80e0e989e79dc7033ed1d95e532600 /sysutils/fcron
parent486caf99151c2047d2c36740ef9807d4daf8a24f (diff)
downloadports-ed81849c9fdf8157d25771a3ab22b2c43f993590.tar.gz
ports-ed81849c9fdf8157d25771a3ab22b2c43f993590.zip
sysutils/fcron: 3.2.0 -> 3.2.1
- @-lines can now be run up to every second (previously every 10s at most) PR: 211451 Submitted by: bob@eager.cx (maintainer)
Notes
Notes: svn path=/head/; revision=419320
Diffstat (limited to 'sysutils/fcron')
-rw-r--r--sysutils/fcron/Makefile2
-rw-r--r--sysutils/fcron/distinfo5
-rw-r--r--sysutils/fcron/files/patch-configure4
-rw-r--r--sysutils/fcron/files/patch-fcrondyn.c23
-rw-r--r--sysutils/fcron/files/patch-fileconf.c4
-rw-r--r--sysutils/fcron/files/patch-save.c4
6 files changed, 10 insertions, 32 deletions
diff --git a/sysutils/fcron/Makefile b/sysutils/fcron/Makefile
index 6eba88dd1caa..29f7ce16bcd5 100644
--- a/sysutils/fcron/Makefile
+++ b/sysutils/fcron/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= fcron
-PORTVERSION= 3.2.0
+PORTVERSION= 3.2.1
CATEGORIES= sysutils
MASTER_SITES= http://fcron.free.fr/archives/ \
ftp://ftp.seul.org/pub/fcron/
diff --git a/sysutils/fcron/distinfo b/sysutils/fcron/distinfo
index 307d486520f5..4593211ea87e 100644
--- a/sysutils/fcron/distinfo
+++ b/sysutils/fcron/distinfo
@@ -1,2 +1,3 @@
-SHA256 (fcron-3.2.0.src.tar.gz) = eb13b86ed96805d117e19847f1da30b834f1990f7ef4c38f5007234d44679564
-SIZE (fcron-3.2.0.src.tar.gz) = 595408
+TIMESTAMP = 1469650893
+SHA256 (fcron-3.2.1.src.tar.gz) = 6114d0a39a32853669c0c0ba0f96d92920e7cabca3ff1edf37d25750403e5f6a
+SIZE (fcron-3.2.1.src.tar.gz) = 601142
diff --git a/sysutils/fcron/files/patch-configure b/sysutils/fcron/files/patch-configure
index e96c7cfd317f..0133c8c8120b 100644
--- a/sysutils/fcron/files/patch-configure
+++ b/sysutils/fcron/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2014-07-06 10:05:56 UTC
+--- configure.orig 2016-06-26 17:46:37 UTC
+++ configure
-@@ -5153,7 +5153,7 @@ if ${ax_cv_lib_readline+:} false; then :
+@@ -5164,7 +5164,7 @@ if ${ax_cv_lib_readline+:} false; then :
else
ORIG_LIBS="$LIBS"
diff --git a/sysutils/fcron/files/patch-fcrondyn.c b/sysutils/fcron/files/patch-fcrondyn.c
deleted file mode 100644
index 4948b08b5e5e..000000000000
--- a/sysutils/fcron/files/patch-fcrondyn.c
+++ /dev/null
@@ -1,23 +0,0 @@
-Fix use of size_t in context where ssize_t (error value included) is
-more correct.
-
---- fcrondyn.c.orig 2014-05-10 17:03:59 UTC
-+++ fcrondyn.c
-@@ -482,7 +482,7 @@ talk_fcron(char *cmd_str, int fd)
- long int *cmd = NULL;
- int cmd_len = 0;
- char buf[LINE_LEN];
-- size_t read_len = 0;
-+ ssize_t read_len = 0;
- char existing_connection = (fd < 0) ? 0 : 1;
- fd_set read_set; /* needed to use select to check if some data is waiting */
- struct timeval tv;
-@@ -578,7 +578,7 @@ talk_fcron(char *cmd_str, int fd)
- }
-
-
-- while ((read_len = (size_t) recv(fd, buf, sizeof(buf) - 1, 0)) >= 0
-+ while ((read_len = (ssize_t) recv(fd, buf, sizeof(buf) - 1, 0)) >= 0
- || errno == EINTR) {
-
- if (errno == EINTR && debug_opt)
diff --git a/sysutils/fcron/files/patch-fileconf.c b/sysutils/fcron/files/patch-fileconf.c
index 53bff7b53462..1d85379dfff0 100644
--- a/sysutils/fcron/files/patch-fileconf.c
+++ b/sysutils/fcron/files/patch-fileconf.c
@@ -1,6 +1,6 @@
We don't need to fflush the file, since it is opened read-only.
---- fileconf.c.orig 2014-05-10 17:03:59 UTC
+--- fileconf.c.orig 2016-06-26 17:42:39 UTC
+++ fileconf.c
@@ -278,10 +278,6 @@ read_file(char *filename, int fd)
cf->cf_next = file_base;
@@ -11,5 +11,5 @@ We don't need to fflush the file, since it is opened read-only.
- error_e("could not fflush() file_name");
-
Free_safe(default_line.cl_runas);
+ Free_safe(default_line.cl_mailfrom);
Free_safe(default_line.cl_mailto);
- Free_safe(default_line.cl_tz);
diff --git a/sysutils/fcron/files/patch-save.c b/sysutils/fcron/files/patch-save.c
index 5ddd7209eebd..878a2d2cfd15 100644
--- a/sysutils/fcron/files/patch-save.c
+++ b/sysutils/fcron/files/patch-save.c
@@ -1,8 +1,8 @@
Replace fdatasync() with fsync() because FreeBSD doesn't have fdatasync().
---- save.c.orig 2014-05-10 17:03:59 UTC
+--- save.c.orig 2016-06-26 15:02:48 UTC
+++ save.c
-@@ -311,8 +311,8 @@ write_file_to_disk(int fd, struct cf_t *
+@@ -315,8 +315,8 @@ write_file_to_disk(int fd, struct cf_t *
* This is to avoid cases where the file name (meta-data) would be updated,
* and there is a crash before the data is fully written: not sure if that
* is possible, but better safe than sorry! */