aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fileschanged
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-03-17 19:47:22 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-03-17 19:47:22 +0000
commit97e238eadb249328d65f4f13c076d6498fbfad36 (patch)
tree4dd6de6595c7867c4d03a104cf9d89ef7da9a1c4 /sysutils/fileschanged
parentebab3f2307236e0230eff8fd775872e21a968ca6 (diff)
downloadports-97e238eadb249328d65f4f13c076d6498fbfad36.tar.gz
ports-97e238eadb249328d65f4f13c076d6498fbfad36.zip
- Respect NOPORTDOCS
PR: ports/132729 Submitted by: Steven Kreuzer <skreuzer@exit2shell.com>
Notes
Notes: svn path=/head/; revision=230314
Diffstat (limited to 'sysutils/fileschanged')
-rw-r--r--sysutils/fileschanged/Makefile8
-rw-r--r--sysutils/fileschanged/files/patch-Makefile.in29
2 files changed, 37 insertions, 0 deletions
diff --git a/sysutils/fileschanged/Makefile b/sysutils/fileschanged/Makefile
index b1b98edb084d..2a05a361ff63 100644
--- a/sysutils/fileschanged/Makefile
+++ b/sysutils/fileschanged/Makefile
@@ -30,4 +30,12 @@ MAN1= fileschanged.1
PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README
PLIST_FILES= bin/fileschanged
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for DOCFILE in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${DOCFILE} ${DOCSDIR}
+.endfor
+.endif
+
.include <bsd.port.mk>
diff --git a/sysutils/fileschanged/files/patch-Makefile.in b/sysutils/fileschanged/files/patch-Makefile.in
new file mode 100644
index 000000000000..04e3288658fd
--- /dev/null
+++ b/sysutils/fileschanged/files/patch-Makefile.in
@@ -0,0 +1,29 @@
+--- Makefile.in.orig 2009-03-17 09:37:59.000000000 -0400
++++ Makefile.in 2009-03-17 09:39:59.000000000 -0400
+@@ -244,16 +244,16 @@
+ redhat/fileschanged.spec: $(top_builddir)/config.status $(top_srcdir)/redhat/fileschanged.spec.in
+ cd $(top_builddir) && $(SHELL) ./config.status $@
+ uninstall-info-am:
+-install-dist_pkgdataDATA: $(dist_pkgdata_DATA)
+- @$(NORMAL_INSTALL)
+- test -z "$(pkgdatadir)" || $(mkdir_p) "$(DESTDIR)$(pkgdatadir)"
+- @list='$(dist_pkgdata_DATA)'; for p in $$list; do \
+- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+- f=$(am__strip_dir) \
+- echo " $(dist_pkgdataDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(pkgdatadir)/$$f'"; \
+- $(dist_pkgdataDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(pkgdatadir)/$$f"; \
+- done
+-
++#install-dist_pkgdataDATA: $(dist_pkgdata_DATA)
++# @$(NORMAL_INSTALL)
++# test -z "$(pkgdatadir)" || $(mkdir_p) "$(DESTDIR)$(pkgdatadir)"
++# @list='$(dist_pkgdata_DATA)'; for p in $$list; do \
++# if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
++# f=$(am__strip_dir) \
++# echo " $(dist_pkgdataDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(pkgdatadir)/$$f'"; \
++# $(dist_pkgdataDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(pkgdatadir)/$$f"; \
++#done
++#
+ uninstall-dist_pkgdataDATA:
+ @$(NORMAL_UNINSTALL)
+ @list='$(dist_pkgdata_DATA)'; for p in $$list; do \