aboutsummaryrefslogtreecommitdiff
path: root/sysutils/firstboot-pkgs
diff options
context:
space:
mode:
authorColin Percival <cperciva@FreeBSD.org>2014-09-19 19:02:33 +0000
committerColin Percival <cperciva@FreeBSD.org>2014-09-19 19:02:33 +0000
commit6f5a8e737fdb3733663ba880cd1632eb308cc860 (patch)
tree9202d9c9a241d21fc4483f09feb562d6f6a252b5 /sysutils/firstboot-pkgs
parent5f3d4a8b5905f4c5affec2798bf9d16c140172d5 (diff)
downloadports-6f5a8e737fdb3733663ba880cd1632eb308cc860.tar.gz
ports-6f5a8e737fdb3733663ba880cd1632eb308cc860.zip
Nominate myself for the useful-use-of-cat award.
pkg detects if its stdout is a terminal and prints many 'done%' lines, which are useful for interactive use on modern terminals, but not so useful on a serial console; piping through cat silences these.
Notes
Notes: svn path=/head/; revision=368591
Diffstat (limited to 'sysutils/firstboot-pkgs')
-rw-r--r--sysutils/firstboot-pkgs/Makefile2
-rw-r--r--sysutils/firstboot-pkgs/files/firstboot_pkgs.in6
2 files changed, 5 insertions, 3 deletions
diff --git a/sysutils/firstboot-pkgs/Makefile b/sysutils/firstboot-pkgs/Makefile
index 6f5cb797a1d8..905645bc2cd4 100644
--- a/sysutils/firstboot-pkgs/Makefile
+++ b/sysutils/firstboot-pkgs/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= firstboot-pkgs
-PORTVERSION= 1.3
+PORTVERSION= 1.4
CATEGORIES= sysutils
MASTER_SITES= # none
DISTFILES= # none
diff --git a/sysutils/firstboot-pkgs/files/firstboot_pkgs.in b/sysutils/firstboot-pkgs/files/firstboot_pkgs.in
index 8d366ad2644c..817ae95a8ad8 100644
--- a/sysutils/firstboot-pkgs/files/firstboot_pkgs.in
+++ b/sysutils/firstboot-pkgs/files/firstboot_pkgs.in
@@ -32,12 +32,14 @@ firstboot_pkgs_run()
# Bootstrap if necessary
if ! pkg -N 2>/dev/null; then
- env ASSUME_ALWAYS_YES=YES pkg bootstrap
+ env ASSUME_ALWAYS_YES=YES pkg bootstrap |
+ cat
fi
# Install requested packages, if any
if ! [ -z "$firstboot_pkgs_list" ]; then
- env ASSUME_ALWAYS_YES=YES pkg install $firstboot_pkgs_list </dev/null
+ env ASSUME_ALWAYS_YES=YES pkg install $firstboot_pkgs_list </dev/null |
+ cat
fi
# Count rc.d scripts again