aboutsummaryrefslogtreecommitdiff
path: root/sysutils/flashrom
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-02-19 15:48:23 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-02-19 15:48:23 +0000
commit1c81dd019efb76ff6ce3437e5ebc42d800ae1449 (patch)
tree89546449da2adb37a0721f5565e78e1eb51ac3e5 /sysutils/flashrom
parentb48b1fa597b03dde3a1f5129ae00ea0a3a4b097b (diff)
downloadports-1c81dd019efb76ff6ce3437e5ebc42d800ae1449.tar.gz
ports-1c81dd019efb76ff6ce3437e5ebc42d800ae1449.zip
- Fix build with clang by removing duplicate const specifiers
- While at it, get rid of useless PTHREAD_CFLAGS / PTHREAD_LIBS
Notes
Notes: svn path=/head/; revision=312577
Diffstat (limited to 'sysutils/flashrom')
-rw-r--r--sysutils/flashrom/Makefile4
-rw-r--r--sysutils/flashrom/files/patch-duplicate-const64
2 files changed, 66 insertions, 2 deletions
diff --git a/sysutils/flashrom/Makefile b/sysutils/flashrom/Makefile
index 514fdb0b875b..72aa2a02f99e 100644
--- a/sysutils/flashrom/Makefile
+++ b/sysutils/flashrom/Makefile
@@ -26,8 +26,8 @@ FTDI_DESC= Enable external FT2232SPI flasher support
USE_BZIP2= yes
USE_GMAKE= yes
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lc
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lc
ONLY_FOR_ARCHS= amd64 i386
diff --git a/sysutils/flashrom/files/patch-duplicate-const b/sysutils/flashrom/files/patch-duplicate-const
new file mode 100644
index 000000000000..68693a262d34
--- /dev/null
+++ b/sysutils/flashrom/files/patch-duplicate-const
@@ -0,0 +1,64 @@
+--- ichspi.c.orig 2013-02-19 16:43:01.000000000 +0100
++++ ichspi.c 2013-02-19 16:43:12.000000000 +0100
+@@ -1127,7 +1127,7 @@
+ static uint32_t ich_hwseq_get_erase_block_size(unsigned int addr)
+ {
+ uint8_t enc_berase;
+- static const uint32_t const dec_berase[4] = {
++ static uint32_t const dec_berase[4] = {
+ 256,
+ 4 * 1024,
+ 8 * 1024,
+--- bitbang_spi.c.orig 2013-02-19 16:45:02.000000000 +0100
++++ bitbang_spi.c 2013-02-19 16:45:34.000000000 +0100
+@@ -26,33 +26,33 @@
+ #include "spi.h"
+
+ /* Note that CS# is active low, so val=0 means the chip is active. */
+-static void bitbang_spi_set_cs(const const struct bitbang_spi_master *master, int val)
++static void bitbang_spi_set_cs(const struct bitbang_spi_master *master, int val)
+ {
+ master->set_cs(val);
+ }
+
+-static void bitbang_spi_set_sck(const const struct bitbang_spi_master *master, int val)
++static void bitbang_spi_set_sck(const struct bitbang_spi_master *master, int val)
+ {
+ master->set_sck(val);
+ }
+
+-static void bitbang_spi_set_mosi(const const struct bitbang_spi_master *master, int val)
++static void bitbang_spi_set_mosi(const struct bitbang_spi_master *master, int val)
+ {
+ master->set_mosi(val);
+ }
+
+-static int bitbang_spi_get_miso(const const struct bitbang_spi_master *master)
++static int bitbang_spi_get_miso(const struct bitbang_spi_master *master)
+ {
+ return master->get_miso();
+ }
+
+-static void bitbang_spi_request_bus(const const struct bitbang_spi_master *master)
++static void bitbang_spi_request_bus(const struct bitbang_spi_master *master)
+ {
+ if (master->request_bus)
+ master->request_bus();
+ }
+
+-static void bitbang_spi_release_bus(const const struct bitbang_spi_master *master)
++static void bitbang_spi_release_bus(const struct bitbang_spi_master *master)
+ {
+ if (master->release_bus)
+ master->release_bus();
+--- dummyflasher.c.orig 2013-02-19 16:45:38.000000000 +0100
++++ dummyflasher.c 2013-02-19 16:45:49.000000000 +0100
+@@ -66,7 +66,7 @@
+ static uint8_t emu_status = 0;
+
+ /* A legit complete SFDP table based on the MX25L6436E (rev. 1.8) datasheet. */
+-static const uint8_t const sfdp_table[] = {
++static uint8_t const sfdp_table[] = {
+ 0x53, 0x46, 0x44, 0x50, // @0x00: SFDP signature
+ 0x00, 0x01, 0x01, 0xFF, // @0x04: revision 1.0, 2 headers
+ 0x00, 0x00, 0x01, 0x09, // @0x08: JEDEC SFDP header rev. 1.0, 9 DW long