aboutsummaryrefslogtreecommitdiff
path: root/sysutils/flog
diff options
context:
space:
mode:
authorMark Pulford <markp@FreeBSD.org>2001-10-10 10:29:18 +0000
committerMark Pulford <markp@FreeBSD.org>2001-10-10 10:29:18 +0000
commit205e50037195a2c404b47c7a1655cea6d75f14ad (patch)
treedd7d43003171e754fba8844980a31f379a5280f6 /sysutils/flog
parent21479ebd6a358cf1e20de10ad13186a4afa45d0d (diff)
downloadports-205e50037195a2c404b47c7a1655cea6d75f14ad.tar.gz
ports-205e50037195a2c404b47c7a1655cea6d75f14ad.zip
Add flog 1.3, a small STDIN-to-file logger with support for log
rotation. PR: 31099 Submitted by: Anders Nordby <anders@fix.no>
Notes
Notes: svn path=/head/; revision=48647
Diffstat (limited to 'sysutils/flog')
-rw-r--r--sysutils/flog/Makefile26
-rw-r--r--sysutils/flog/distinfo1
-rw-r--r--sysutils/flog/pkg-comment1
-rw-r--r--sysutils/flog/pkg-descr10
-rw-r--r--sysutils/flog/pkg-plist3
5 files changed, 41 insertions, 0 deletions
diff --git a/sysutils/flog/Makefile b/sysutils/flog/Makefile
new file mode 100644
index 000000000000..2b1a99f5d9ba
--- /dev/null
+++ b/sysutils/flog/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: flog
+# Date created: 7 October 2001
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flog
+PORTVERSION= 1.3
+CATEGORIES= sysutils
+MASTER_SITES= http://oss.ezic.com/flog/ \
+ http://ftp.nuug.no/pub/anders/distfiles/
+
+MAINTAINER= ports@FreeBSD.org
+
+do-build:
+ ${CC} ${CFLAGS} -o ${WRKSRC}/flog ${WRKSRC}/flog.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/flog ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/flog/distinfo b/sysutils/flog/distinfo
new file mode 100644
index 000000000000..5b9b2f298ca4
--- /dev/null
+++ b/sysutils/flog/distinfo
@@ -0,0 +1 @@
+MD5 (flog-1.3.tar.gz) = cc97339bd757a651558438463c5f2721
diff --git a/sysutils/flog/pkg-comment b/sysutils/flog/pkg-comment
new file mode 100644
index 000000000000..40fa19e04c5d
--- /dev/null
+++ b/sysutils/flog/pkg-comment
@@ -0,0 +1 @@
+A small STDIN-to-file logger with support for log rotation
diff --git a/sysutils/flog/pkg-descr b/sysutils/flog/pkg-descr
new file mode 100644
index 000000000000..5ea8ed33abd4
--- /dev/null
+++ b/sysutils/flog/pkg-descr
@@ -0,0 +1,10 @@
+flog (file logger) is a small C program that reads input from STDIN and writes
+to a file, optionally adding timestamps. If SIGHUP is received, the file will
+be reopened, allowing for log rotation (see newsyslog(8)). The log file will
+only be reopened if flog detects that rotation has occurred (i.e., the old file
+is gone or the inode has changed). flog is extremely small (a memory footprint
+of less than 500 bytes). It also protects you from running out of disk space;
+if that happens, the logfile will be truncated and a warning generated. This
+could save you from waking up to pager beeps in the middle of the night.
+
+WWW: http://oss.ezic.com/
diff --git a/sysutils/flog/pkg-plist b/sysutils/flog/pkg-plist
new file mode 100644
index 000000000000..836656ea493a
--- /dev/null
+++ b/sysutils/flog/pkg-plist
@@ -0,0 +1,3 @@
+bin/flog
+%%PORTDOCS%%share/doc/flog/README
+%%PORTDOCS%%@dirrm share/doc/flog